1. Post #1
    Chlapecek96's Avatar
    March 2007
    45 Posts
    Hello I have recently reinstalled gmod and used Gmod SVN Updater and udpated all i got before, so, i started game, and wanted to PWN some n00bs on multiplayer, I jointed server and my weapon mounts wont work anymore, I tried SP and still not working, i got these errors

    Manned turret:
    Code:
    [@addons\sbep_experimental\lua\entities\mannedturret\init.lua:229] bad argument #2 to '?' (Vector expected, got Angle)
    Vierling Mount:
    Code:
    [@addons\sbep_entities\lua\entities\sf-vierling\init.lua:224] bad argument #2 to '?' (Vector expected, got Angle)
    And lots of other errors

    Can you help me solve it? Please, I tried teh old version of gmod, but that version wont work anymore :(
    Reply With Quote Edit / Delete Czech Republic Show Events

  2. Post #2

    August 2010
    96 Posts
    have you edited/looked at the code? sometimes you just accidently press a button when you close it
    Reply With Quote Edit / Delete Sweden Show Events

  3. Post #3
    Gold Member
    whosdr's Avatar
    July 2008
    3,017 Posts
    [@addons\sbep_experimental\lua\entities\mannedturre t\init.lua:229]
    Code:
    physi1:AddAngleVelocity((physi1:GetAngleVelocity() * -1) + Angle(0,Pitch,0))
    to
    Code:
    physi1:AddAngleVelocity((physi1:GetAngleVelocity() * -1) + Vector(0,Pitch,0))

    [@addons\sbep_entities\lua\entities\sf-vierling\init.lua:224]
    Code:
    physi:AddAngleVelocity((physi:GetAngleVelocity() * -1) + Angle(0,0,-Yaw))
    physi2:AddAngleVelocity((physi2:GetAngleVelocity() * -1) + Angle(0,Pitch,0))
    To
    Code:
    physi:AddAngleVelocity((physi:GetAngleVelocity() * -1) + Vector(0,0,-Yaw))
    physi2:AddAngleVelocity((physi2:GetAngleVelocity() * -1) + Vector(0,Pitch,0))
    Reply With Quote Edit / Delete United Kingdom Show Events

  4. Post #4

    January 2012
    6 Posts
    I have this same problem too, the models are fine, but about 90% of the entities refuse to work. The Arwing, just about all the weapons and most of the SENTS just give me LUA errors when I try to use them. Also the Arwing just spawns a soda can and spams LUA errors. I'm on the latest version of everything, and I have all the requirements listed on the wiki. I have used SBEP before, and it's worked fine. Only now when I try to use it it just doesn't work. Any help would be greatly appreciated.
    Reply With Quote Edit / Delete Windows 7 United States Show Events Dumb Dumb x 1 (list)