1. Post #1

    July 2011
    19 Posts
    Well,I have been playing some servers which had WireMod,But,When I join these server,I get notified that I am having an old version of WireMod,2248 I think,So I have found an WireMod Installer for Mac OSX(http://www.wiremod.com/forum/install...n-app-mac.html) but it doesn't work at all.When I Press install,It does nothing,And changes to 'Update Wire' even though,I didn't even install!
    So I have tried looking in Steam forums,And I have found that there's a way to install it via the Terminal Application just like this

    Code:
    cd ~/Library/Application\ Support/Steam/SteamApps/<YOUR STEAM USERNAME HERE>/garrysmod/garrysmod/addons/
    
    svn co https://wiremod.svn.sourceforge.net/svnroot/wiremod/trunk/
    When it stops spazing (it'll take like 2 mins depending on your internet connection), type:

    Code:
    cd trunk
    mv Adv\ Duplicator ..
    mv wire ..
    mv wire\ model\ pack\ 1 ..
    cd ..
    sudo rm -r trunk
    svn co https://phoenix-storms.svn.sourceforge.net/svnroot/phoenix-storms/
    The first commands work,But the other,I get asked that I need a password,Although I don't have any,So I just press enter(blank password) and it says that it is wrong,And without this stage,When I get to SP in Gmod,I see alot of Lua errors and there's an announcement which says that I didn't properly install WireMod...
    So can anyone help me with this,Please?

  2. Post #2
    BillyBob11432's Avatar
    July 2011
    16 Posts
    I'd say just learn to use a normal SVN program. I don't use mac, but with enough googling you could find a decent one.

    First, go here.

    Then, once you've found a good SVN program, go here and add the Wire Complete SVN into your program.
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Informative Informative x 2 (list)

  3. Post #3

    July 2011
    19 Posts
    I need some explanation,I can't understand how all this actually works!
    And thanks for replying!
    Reply With Quote Edit / Delete Reply Mac Israel Show Events Friendly Friendly x 1 (list)

  4. Post #4

    July 2011
    19 Posts
    Sorry for double-posting but this Topic can be removed,The thing i've done wrong is that I had all the old files of Wiremod,I just simply removed them from my addons folder,And tried their OneClickWM Application which easily installs WireMod for Mac and this time,It actually worked,Not like before.
    And thanks again BillyBob11432.
    Reply With Quote Edit / Delete Reply Mac Israel Show Events Friendly Friendly x 1 (list)

  5. Post #5
    Gold Member
    supervoltage's Avatar
    November 2009
    680 Posts
    You should still use SVN though, you don't have to go through the hassle of Delete->Place->Delete->Place etc.

    With SVN, you Place->Update->Update->Update and so on
    Reply With Quote Edit / Delete Reply Windows 7 Romania Show Events Useful Useful x 1 (list)

  6. Post #6
    sicklebrick's Avatar
    July 2011
    10 Posts
    Props for working out the gray matter on this one... but out of curiosity, did you try 'anonsvn' or 'anon' as passwords?
    Reply With Quote Edit / Delete Reply Windows 7 United Kingdom Show Events Friendly Friendly x 1 (list)

  7. Post #7

    July 2011
    19 Posts
    Props for working out the gray matter on this one... but out of curiosity, did you try 'anonsvn' or 'anon' as passwords?
    Your asking something that I don't really know how to reply to,I don't know much about the whole SVN process,I barely know how to do simple things with Wire itself...

    By the way,I have managed to get WireMod installed on my Mac...Didn't you read the Double-post I've submitted?
    But there's only one thing which bothers me,I can't use the Wire tool itself,That's the only tool that isn't working for me in Singleplayer,But in Multi it does...

  8. Post #8
    sicklebrick's Avatar
    July 2011
    10 Posts
    Your asking something that I don't really know how to reply to,I don't know much about the whole SVN process,I barely know how to do simple things with Wire itself...

    By the way,I have managed to get WireMod installed on my Mac...Didn't you read the Double-post I've submitted?
    But there's only one thing which bothers me,I can't use the Wire tool itself,That's the only tool that isn't working for me in Singleplayer,But in Multi it does...
    Lol that's weird :S Try reinstalling maybe? The whole thing's not that big.

    What I was saying though was congrats on using your brain and actually attempting to use the command line tools (which work fine) before taking the easy route and just downloading a proggie. Nice to see someone try. As for the username and password, you said it asked for one but you didn't have it... I just suggested trying anon/anon or anonsvn/anonsvn.

    Sorry I can't be more help!

  9. Post #9

    July 2011
    19 Posts
    Lol that's weird :S Try reinstalling maybe? The whole thing's not that big.

    What I was saying though was congrats on using your brain and actually attempting to use the command line tools (which work fine) before taking the easy route and just downloading a proggie. Nice to see someone try. As for the username and password, you said it asked for one but you didn't have it... I just suggested trying anon/anon or anonsvn/anonsvn.

    Sorry I can't be more help!
    Well,It appears to be that I have managed to install Wiremod properly,But I can't use the Wire tool itself in Singleplayer,In Multiplayer,The Wire Tool works...

  10. Post #10

    July 2011
    19 Posts
    Guys please help,I really want to get Wire Tool to get working on Singleplayer
    Btw,Whenever I enter the game,I see alot of .lua errors concerning the Wire Tool itself...

  11. Post #11

    July 2011
    19 Posts
    Sorry for replying/bumping again,But I found a solution,I need a Windows user to upload the Wire folder which includes the Wire Tool itself,And I might now get Wire Tool to work.