1. Post #1
    Gold Member
    Upgrade123's Avatar
    January 2008
    5,478 Posts
    So I want to load songs from my laptop (Ubuntu 11.10) onto my iPod Nano (3rd generation 4GB), but whenever I connect it I can't do anything to it. It shows up on media players (Banshee, Rhythmbox, Amarok) and such, and I'm able to copy songs off of it just fine, but I can't put songs onto it.

  2. Post #2
    Glorious GNU/Linux Master Race
    kaukassus's Avatar
    May 2010
    5,246 Posts
    I think that would require the iTunes libraries, but I don't think they exist as linux libraries.

  3. Post #3
    Wait... so if I write anything here, it's going to show up under my name?
    B!N4RY's Avatar
    December 2009
    7,227 Posts
    You can try pwntunes, but i'm not sure if it is compatible with linux

  4. Post #4
    Gold Member

    July 2006
    1,105 Posts
    This might help

    http://ubuntuforums.org/showthread.php?t=1471018

    Sorry didn't see but this is apps only.

  5. Post #5
    P320's Avatar
    September 2011
    957 Posts
    Try it as Root. Guaranteed success.

  6. Post #6
    Gold Member
    Upgrade123's Avatar
    January 2008
    5,478 Posts
    I'm pretty new to Linux, so how would I do this? Sorry if I sound like a dumbass, hahaha

  7. Post #7
    I wasted a dollar on a stupid title.
    nikomo's Avatar
    September 2007
    16,846 Posts
    Stick "sudo" in front of a command to run it as root.
    Root is the main, administrative user on Linux.

    Example:
    passwd - Change your password
    sudo passwd - Change root's password, because you're now running the command as root.
    Reply With Quote Edit / Delete Reply Windows 7 Finland Show Events Informative Informative x 1 (list)

  8. Post #8
    Gold Member
    Upgrade123's Avatar
    January 2008
    5,478 Posts
    So I tried "sudo banshee" to open up Banshee as root, but then it doesn't detect the iPod as being connected.

  9. Post #9

    January 2012
    68 Posts
    hello, it will work either with rythmbox or gtkpod (both work)

    rythmbox is another media player, to install:
    Code:
    sudo apt-get install rhythmbox
    gtkpod is especially for ipods (but a little confusing), to install:
    Code:
    sudo apt-get install gtkpod
    btw, when you plug it in the pc does it detect as an ipod?

  10. Post #10
    Gold Member
    Upgrade123's Avatar
    January 2008
    5,478 Posts
    I have both Rhythmbox and Gtkpod, but Gtkpod doesn't want to work with my .m4a files for some reason.
    My system always recognizes the iPod whenever I plug it in, but none of my programs do when I run them as root.

    Edited:

    Also whenever I try to use Gtkpod with this iPod, it gives me this notice:
    Import Repository Errors
    Errors created during repository import
    Extended info will not be used.

  11. Post #11

    January 2012
    68 Posts
    have you installed codecs?:
    Code:
    sudo apt-get install ubuntu-restricted-extras

  12. Post #12
    Gold Member
    Upgrade123's Avatar
    January 2008
    5,478 Posts
    I already have, yes.

  13. Post #13

    January 2012
    68 Posts
    intstall this:
    Code:
    sudo apt-get install gtkpod-aac
    see if that helps

  14. Post #14
    Gold Member
    Upgrade123's Avatar
    January 2008
    5,478 Posts
    It gave me this:
    Code:
    sudo apt-get install gtkpod-aac
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Unable to locate package gtkpod-aac

  15. Post #15

    January 2012
    68 Posts
    hmpf. seems to be a bug in the latest stable, try the beta:
    Code:
    sudo apt-get-repository ppa:forage/gtkpod
    sudo apt-get update
    sudo apt-get install gtkpod

  16. Post #16
    Gold Member
    Upgrade123's Avatar
    January 2008
    5,478 Posts
    Code:
    sudo: apt-get-repository: command not found

  17. Post #17

    January 2012
    68 Posts
    ugh. typo, sorry:
    Code:
    sudo add-apt-repository ppa:forage/gtkpod
    sudo apt-get update
    sudo apt-get install gtkpod

  18. Post #18
    Gold Member
    Upgrade123's Avatar
    January 2008
    5,478 Posts
    It still won't recognize the .m4a files. Gah.

    Edited:

    I don't know if this is relevant, but when I try running Banshee as root I get this in the terminal:
    Code:
    [Info  16:01:58.333] AppleDeviceSource is ignoring unmounted volume floppy0

  19. Post #19

    January 2012
    68 Posts
    do this:
    Code:
    sudo apt-get install mp4v2
    also check your plugin in gtkpod:
    edit > Preferences

  20. Post #20
    Gold Member
    Upgrade123's Avatar
    January 2008
    5,478 Posts
    Unable to locate package. D:

  21. Post #21

    January 2012
    68 Posts
    I'm out of ideas.
    make sure you have all the codecs installed.
    Code:
    sudo apt-get install ubuntu-restricted-extras
    check if video or codec plugins are checked in gtkpod (edit > preferences)

  22. Post #22
    Gold Member
    Upgrade123's Avatar
    January 2008
    5,478 Posts
    I did some reading around and someone on the Ubuntu forums said that the Natty version of gtkpod works fine with m4a files. Is it possible to use that?

  23. Post #23

    January 2012
    68 Posts
    Not on Ubuntu atm, try:
    Code:
    sudo apt-get install gtkpod
    sudo apt-get-repository -r ppa:forage/gtkpod
    sudo apt-get update
    sudo apt-get install pkg=1.0.0 gtkpod

  24. Post #24
    Gold Member
    Upgrade123's Avatar
    January 2008
    5,478 Posts
    E: Unable to locate package pkg

  25. Post #25

    January 2012
    68 Posts
    I don't know how to do this in ubuntu:
    http://packages.ubuntu.com/natty/gtkpod

  26. Post #26
    P320's Avatar
    September 2011
    957 Posts
    Just install GTKpod from PPA.

  27. Post #27
    Gold Member
    Upgrade123's Avatar
    January 2008
    5,478 Posts
    Just install GTKpod from PPA.
    Tried that, didn't work.

  28. Post #28
    Gold Member
    Upgrade123's Avatar
    January 2008
    5,478 Posts
    When I try syncing with Amarok, I get this notice:
    Code:
    Could not write to: /media/[really long serial number]/iPod_Control/Music/F05/kpod0319031.mp4
    Edited:

    Also, I tried syncing an .mp3 onto the iPod via gtkpod and got this:
    Code:
    Transfer of 'Renob, Nevada' failed. Error opening '/media/95828af9-0fd4-3caa-b6d4-c8296caf3d5f/iPod_Control/Music/F01/libgpod536653.mp3' for writing (Read-only file system).

  29. Post #29

    January 2012
    68 Posts
    were you using your ipod on a mac before this? Try reformatting it under windows.
    Reply With Quote Edit / Delete Reply Linux Australia Show Events Useful Useful x 2 (list)

  30. Post #30
    P320's Avatar
    September 2011
    957 Posts
    were you using your ipod on a mac before this? Try reformatting it under windows.
    OMG, that's probably it. I doubt anybody thinks about that, but Linux still only has partial HFS+ support.
    Reply With Quote Edit / Delete Reply Windows 8 United States Show Events Useful Useful x 1 (list)

  31. Post #31
    Gold Member
    Upgrade123's Avatar
    January 2008
    5,478 Posts
    I'll have to find a computer that has Windows on it then, lmao.
    I should have access to one tomorrow.

    Edited:

    JUST KIDDING, I found one. And now my iPod works!
    Reply With Quote Edit / Delete Reply Linux United States Show Events Winner Winner x 1Agree Agree x 1 (list)