1. Post #1
    Support TheBroHouse!
    AlexGT's Avatar
    January 2011
    1,259 Posts
    So I got a new processor, an AMD Phenom II X4 980 Quad Core with 3.70 GHz, and something has been brought to my attention.

    My PSU unit, which is 430 watts, might not be enough for all of that, as my friend told me, but I do not know if this is true and I'd like to be told if it actually is enough to handle the graphics card and the processor efficiently enough.


    >> ALSO: I did not do a re-install of windows when I got the new processor, and I think this arose another problem that I think could be the PSU unit as well, but when I'm running around playing in games, the entire game lags to 30-20 fps, for example EFLC or JC2 (so far the only games I've tested) then jumps back to a super high 60-70 fps.


    All help would be appreciated!

  2. Post #2
    Cake like Lady Gaga
    Shadaez's Avatar
    December 2005
    16,012 Posts
    Which model PSU?

    Edited:

    If you can't find that, brand at least, and how much amps are on the 12v rail.
    It'll say "12v" with a number under it, usually, that says ##A

  3. Post #3
    Support TheBroHouse!
    AlexGT's Avatar
    January 2011
    1,259 Posts
    Which model PSU?

    Edited:

    If you can't find that, brand at least, and how much amps are on the 12v rail.
    It'll say "12v" with a number under it, usually, that says ##A

    A Corsair CX430.

  4. Post #4
    Cake like Lady Gaga
    Shadaez's Avatar
    December 2005
    16,012 Posts
    Yeah it'll work, but it only has one PCI-E power cord, so you'll need to use a molex -> pci-e power cable.

    Edited:

    As for the FPS problems, sounds like something may be overheating, run a temperature monitoring program (HW Monitor) while you play, and after a while check the max temperatures. If that doesn't seem to be the problem, it might be something else like HDD being accessed, page file usuage, etc. How much RAM do you have? And are you currently using the 6870? It should be fine with a CX 430.

  5. Post #5
    Support TheBroHouse!
    AlexGT's Avatar
    January 2011
    1,259 Posts
    Yeah it'll work, but it only has one PCI-E power cord, so you'll need to use a molex -> pci-e power cable.

    Edited:

    As for the FPS problems, sounds like something may be overheating, run a temperature monitoring program (HW Monitor) while you play, and after a while check the max temperatures. If that doesn't seem to be the problem, it might be something else like HDD being accessed, page file usuage, etc. How much RAM do you have? And are you currently using the 6870? It should be fine with a CX 430.
    I AM using the 6870 as of now, and I applied thermal paste before I sandwiched the fucker of a cooling fan onto the processor. I have 4 gigabytes of RAM which seems sufficient, but I'm not sure. I also think that something might be related because I flashed before I put the processor in, but I don't think flashing my mobo again would work, and I think it would brick it.

  6. Post #6
    Cake like Lady Gaga
    Shadaez's Avatar
    December 2005
    16,012 Posts
    Are you using the stock cooler, and you added thermal paste, too? It comes with some pre-applied, so you could be using too much. Just check the temps while you play games to rule that out.

  7. Post #7
    Support TheBroHouse!
    AlexGT's Avatar
    January 2011
    1,259 Posts
    Are you using the stock cooler, and you added thermal paste, too? It comes with some pre-applied, so you could be using too much. Just check the temps while you play games to rule that out.
    The processor I had, came with NO thermal paste pre-applied and it didn't come with any so I had to go buy some.


    And I will, make sure to look at the thread, I'll post the temperatures.

    Edited:

    Holy shit, it's a bit hot, even while playing Just Cause 2 on low settings.


    All 4 cores are currently at 84 degrees celsius, with JC2 running in the background.

  8. Post #8
    Cake like Lady Gaga
    Shadaez's Avatar
    December 2005
    16,012 Posts
    The processor I had, came with NO thermal paste pre-applied and it didn't come with any so I had to go buy some.


    And I will, make sure to look at the thread, I'll post the temperatures.

    Edited:

    Holy shit, it's a bit hot, even while playing Just Cause 2 on low settings.


    All 4 cores are currently at 84 degrees celsius, with JC2 running in the background.
    It comes on the heatsink. And 84 is way too hot for the Phenom II line, make sure it's properly latched on.

  9. Post #9
    Support TheBroHouse!
    AlexGT's Avatar
    January 2011
    1,259 Posts
    It comes on the heatsink. And 84 is way too hot for the Phenom II line, make sure it's properly latched on.

    It is, I myself was struggling with it to get it on. I didn't get a new heatsink; I used the old one.

  10. Post #10
    Juggernog's Avatar
    July 2009
    3,690 Posts
    You're not trying to fit a wrong standard heatsink onto your motherboard are you?

    What was your previous processor?

  11. Post #11
    Support TheBroHouse!
    AlexGT's Avatar
    January 2011
    1,259 Posts
    You're not trying to fit a wrong standard heatsink onto your motherboard are you?

    What was your previous processor?
    AMD Athlon 4850e Dual Core ~2.5 GHZ Processor.