1. Post #1
    LifePunch.net
    MonkeysLP's Avatar
    June 2010
    1,178 Posts
    They act really weird. Sometimes they display, sometimes it's just blank. Anyone knows what's up? Garry mentioned he would check them out on Twitter but I don't think he's fixed it yet? Or has he?

    (User was banned for this post ("Use the Help & Support section" - Orkel))
    Reply With Quote Edit / Delete Windows 7 Canada Show Events Disagree Disagree x 2 (list)

  2. Post #2
    SeveredSkull's Avatar
    October 2008
    1,316 Posts
    That's cuz theyre broken.
    Reply With Quote Edit / Delete Windows 7 United States Show Events Agree Agree x 1 (list)

  3. Post #3
    Gold Member
    PaellaPablo's Avatar
    May 2011
    206 Posts
    Garry was looking at implementing a new HTML rendering system using Awesomium.

    At the current time, they should be working at all, not sure why yours would work.

    You'll have to wait until the new renderer gets implemented for your pretty MOTD and the such to work.
    Reply With Quote Edit / Delete Windows 7 Australia Show Events

  4. Post #4
    SeveredSkull's Avatar
    October 2008
    1,316 Posts
    Garry was looking at implementing a new HTML rendering system using Awesomium.

    At the current time, they should be working at all, not sure why yours would work.

    You'll have to wait until the new renderer gets implemented for your pretty MOTD and the such to work.

    No... they work somewhat... But most of the texture rendering from HTML panels are busted to high heaven..
    Reply With Quote Edit / Delete Windows Vista United States Show Events

  5. Post #5
    LifePunch.net
    MonkeysLP's Avatar
    June 2010
    1,178 Posts
    Well, is he planning on fixing it soon or after Gmod 13, or what?
    Reply With Quote Edit / Delete Windows 7 Canada Show Events

  6. Post #6
    SeveredSkull's Avatar
    October 2008
    1,316 Posts
    Hes trying to fix it as quick as possible. I think he is more concerned about the srcds.exe messing up at the moment.
    Reply With Quote Edit / Delete Windows Vista United States Show Events

  7. Post #7
    LifePunch.net
    MonkeysLP's Avatar
    June 2010
    1,178 Posts
    Anyone has any creative temporary solution besides using forcing steam browser open?
    Reply With Quote Edit / Delete Windows 7 Canada Show Events

  8. Post #8
    Dragon Dildoes
    Dennab
    April 2009
    4,432 Posts
    Just fyi, awesomenium seems only to be implemented in gm13.

    It's still glitchy in gm12, I found a small workaround though it doesn't always work.
    Reply With Quote Edit / Delete Windows 7 Germany Show Events Dumb Dumb x 1 (list)

  9. Post #9
    Gold Member

    June 2012
    17 Posts
    I just decided to implement VGUIs for everything that was HTML panels.
    Reply With Quote Edit / Delete Windows 7 United States Show Events

  10. Post #10

    September 2010
    26 Posts
    I thinks sv_loadingurl is broken too, because is HTML right?

    Because I see my page in the console (is loaded) but its never appears...

    Sorry for my bad english
    Reply With Quote Edit / Delete Windows 7 France Show Events

  11. Post #11
    It will be fixed today.
    Reply With Quote Edit / Delete Windows 7 Germany Show Events

  12. Post #12

    September 2010
    26 Posts
    The Update is installed, but my loading screen and my HTML panel still broken...
    Reply With Quote Edit / Delete Windows 7 France Show Events Agree Agree x 1 (list)

  13. Post #13
    The Update is installed, but my loading screen and my HTML panel still broken...
    Weird. Worked fine when I tested it.
    (Didn't test the loadscreen)
    Reply With Quote Edit / Delete Windows 7 Germany Show Events

  14. Post #14
    garry's Avatar
    September 2001
    12,398 Posts
    If your loadscreen is flash you will need to make sure you have the appropriate plugin installed
    Reply With Quote Edit / Delete Windows 7 Show Events Disagree Disagree x 1Winner Winner x 1 (list)

  15. Post #15

    September 2010
    26 Posts
    I can load the page with Firefox with no error in firebug, and I see the page loading in console when i'm connecting

    Log of my console:

    Code:
    Browser Message: Uncaught SyntaxError: Unexpected identifier - (null):0
    Browser Message: Uncaught ReferenceError: DownloadingFile is not defined - (null):0
    Browser Message: Uncaught ReferenceError: SetFilesNeeded is not defined - (null):0
    Browser Message: Uncaught ReferenceError: SetFilesTotal is not defined - (null):0
    I see this error on any server I join, and each time, the loading screen not appears

    edit:
    My page: http://lostofroleplay.rd-h.fr/Page_Dl/index.php
    In gmod, I see a White page...
    Reply With Quote Edit / Delete Windows 7 France Show Events

  16. Post #16
    LifePunch.net
    MonkeysLP's Avatar
    June 2010
    1,178 Posts
    Same for us. HTML panels still a white page, we updated the servers too. We're not using flash either.
    Reply With Quote Edit / Delete Windows 7 Canada Show Events Agree Agree x 8 (list)

  17. Post #17

    October 2011
    5 Posts
    This patch works for some and not for others, what the f*ck ? =/
    Reply With Quote Edit / Delete Windows 7 France Show Events Dumb Dumb x 1 (list)

  18. Post #18
    LifePunch.net
    MonkeysLP's Avatar
    June 2010
    1,178 Posts
    It works on our development server but not on our live servers. I don't even know what's going on anymore.
    Reply With Quote Edit / Delete Windows 7 Canada Show Events

  19. Post #19
    LifePunch.net
    MonkeysLP's Avatar
    June 2010
    1,178 Posts
    garre pls fix
    Reply With Quote Edit / Delete Windows 7 Canada Show Events

  20. Post #20
    SeveredSkull's Avatar
    October 2008
    1,316 Posts
    he fixed for GM12.... I dont know about GM13
    Reply With Quote Edit / Delete Windows 7 United States Show Events Disagree Disagree x 6Dumb Dumb x 1 (list)

  21. Post #21
    LifePunch.net
    MonkeysLP's Avatar
    June 2010
    1,178 Posts
    No, it's still broken on GM12. At least sometimes. Fuck if I know. It works on our development server SOMETIMES, but everyone sees a white screen on our live servers. Same code. Makes no sense.

    Definitely not fixed.
    Reply With Quote Edit / Delete Windows 7 Canada Show Events Agree Agree x 3Informative Informative x 1 (list)

  22. Post #22
    SeveredSkull's Avatar
    October 2008
    1,316 Posts
    You might wanna take it up with him then. On garrysmod.com he says otherwise:

    http://garrysmod.com/post/26915045409/gmod-update-137
    Reply With Quote Edit / Delete Windows Vista United States Show Events

  23. Post #23
    LifePunch.net
    MonkeysLP's Avatar
    June 2010
    1,178 Posts
    Been trying to take it up with him for a while with little to no response. Not sure where the best way to contact him is.
    Reply With Quote Edit / Delete Windows 7 Canada Show Events

  24. Post #24
    SeveredSkull's Avatar
    October 2008
    1,316 Posts
    Well I am sure he isn't just sitting on his ass. But hes also trying to work towards a brand new HTML Rendering Engine called Awesomium.

    Odds are that is taking up most of his time.
    Reply With Quote Edit / Delete Windows Vista United States Show Events

  25. Post #25
    LifePunch.net
    MonkeysLP's Avatar
    June 2010
    1,178 Posts
    Well I am sure he isn't just sitting on his ass.
    Hahaha ahaha
    Reply With Quote Edit / Delete Windows 7 Canada Show Events Funny Funny x 1 (list)

  26. Post #26
    JamieH is a retarded bitch <3
    Pantho's Avatar
    July 2008
    2,197 Posts
    Hahaha ahaha
    Reply With Quote Edit / Delete Windows 7 United Kingdom Show Events Funny Funny x 1 (list)

  27. Post #27
    Gold Member
    Blasphemy's Avatar
    December 2009
    400 Posts
    It's really strange, there are certain servers where the MOTD always works, then there are ones where it never works. Anyone have any sort of roundabout way of making them work?
    Reply With Quote Edit / Delete Windows 7 United States Show Events

  28. Post #28
    SeveredSkull's Avatar
    October 2008
    1,316 Posts
    More than likely, the ones that ALWAYS work are generating it based off of a text file on your computer. The ones that DONT work are linked to an external website.
    Reply With Quote Edit / Delete Windows 7 United States Show Events

  29. Post #29
    JamieH is a retarded bitch <3
    Pantho's Avatar
    July 2008
    2,197 Posts
    Ours is linked and it works sometimes, not other times...

    Depends what mood it's in really.
    Reply With Quote Edit / Delete Windows 7 United Kingdom Show Events Agree Agree x 1Funny Funny x 1 (list)

  30. Post #30
    SeveredSkull's Avatar
    October 2008
    1,316 Posts
    Give it a box of chocolates and some flowers, maybe light a few candles, and voila!
    Reply With Quote Edit / Delete Windows 7 United States Show Events

  31. Post #31
    LifePunch.net
    MonkeysLP's Avatar
    June 2010
    1,178 Posts
    It's my birthday today and all I want is for HTML panels to be fixed.
    Reply With Quote Edit / Delete Windows 7 Canada Show Events Agree Agree x 2Friendly Friendly x 1Optimistic Optimistic x 1Dumb Dumb x 1 (list)