1. Post #1

    February 2012
    1,002 Posts
    Okay, let's give this another go.

    A few months ago, I installed an advanced camera tool from Garrysmod.org. However, the lua file of it overwrote how the default camera tool operates. Now the camera tool spawns cameras as non-physical objects. They can't be moved or adjusted with the physgun, and their placement action can't be undone with the z key on the keyboard.

    I no longer have the advanced camera lua file, and the addon has been deleted from Garrysmod.org. My big question is this:

    Is there a way that I can reset the camera's scripting to how it was originally? I'm afraid that when Gmod 13 comes that my camera will still be broken. It's frustrating trying to do screenshots like this, and I have not been able to find a solution anywhere.

    If anyone reading this has the slightest clue as to how I can fix this, please, I'd very much appreciate the help.
    Reply With Quote Edit / Delete Reply Windows Vista United States Show Events Funny Funny x 1 (list)

  2. Post #2
    Character's Avatar
    April 2011
    781 Posts
    Verify integrity of game cache.

  3. Post #3

    February 2012
    1,002 Posts
    Already tried that. It did nothing.

  4. Post #4
    Hashspy's Avatar
    January 2012
    150 Posts
    Re-install the game.

  5. Post #5

    February 2012
    1,002 Posts
    So, I figured out how to better explain my camera problem:

    http://www.garrysmod.org/downloads/?a=view&id=132240

    This tool is scripted to remove an object's physics and said object from the undo list.

    Somehow, the advanced camera lua I had did this exact same thing to the cameras the camera tool spawns.

    Does ANYBODY know how to re-add the physics to the cameras and the cameras back to the undo list?

  6. Post #6
    I bought this title for a dollar I am special
    Lolcats's Avatar
    April 2011
    428 Posts
    Did you re-install after you took out the addon? A fresh install of Garry's Mod will generally work with no addons or custom shit. Just re-add each addon until you find the one that causes your cameras to bug out, then, well, don't use it.

  7. Post #7

    February 2012
    1,002 Posts
    No, and since I don't have the lua for the advanced camera anymore, if I reinstall it should work. But first I need an external to back my stuff up onto...

  8. Post #8
    DaneSomdahl's Avatar
    April 2011
    266 Posts
    You can just delete the .lua files, since the defaults are in the GCF then those won't be overridden by any existing lua files relating to whatever you deleted and it should go back to default.
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Disagree Disagree x 1 (list)

  9. Post #9

    February 2012
    1,002 Posts
    Um....if that had worked, I wouldn't have made this thread.

    Anyhoo, my new laptop arrived today, so I'll be soon transferring all my content to an external and then to the new laptop. A fresh install should do the trick.

    Wait, if it's in the GCF, I can just extract it and place it in the folder, right? That might fix it.