1. Post #1

    April 2017
    1 Posts
    Whenever I use my Q menu and search for something, the bar freezes about 3/4's of the way through the search, and in the top left I get a script error message. My console is then spammed by this message:

    [ERROR] gamemodes/sandbox/gamemode/cl_search_models.lua:11: bad argument #1 to 'pairs' (table expected, got nil)
    1. pairs - [C]:-1
    2. GetAllFiles - gamemodes/sandbox/gamemode/cl_search_models.lua:11
    3. fn - gamemodes/sandbox/gamemode/cl_search_models.lua:32
    4. unknown - addons/ulib/lua/ulib/shared/hook.lua:105

    I have some gmod addons, I have tried reinstalling gmod, I have replaced my sandbox file with a secure one, I have rejoined the server I play on multiple times and have tried nearly every solution the admins could think of. I have typed clear into the console, and then the messages continue to flow and cover the chat.
    Reply With Quote Edit / Delete Reply Windows 7 Chrome Greece Show Events Informative Informative x 1 (list)

  2. Post #2
    Don't PM me about moderation - PM any of the mods.
    Robotboy655's Avatar
    May 2008
    15,825 Posts
    Yep, can confirm this when the file paths contain non english text characters.

    Will fix for next update.