1. Post #1

    November 2007
    5 Posts
    I started my DarkRP serevr today and joined the gundealer class. I bought a shipment of guns but cannot use them, I tried use grav gun and phys gun, they won't even move? I have DarkRP 2008 2.2 if thats any help.

  2. Post #2
    Gold Member
    FamousCra's Avatar
    September 2005
    599 Posts
    can you pick them up?

    If not, crouch and press E on them.

  3. Post #3
    Gold Member
    psp401.com's Avatar
    November 2005
    1,126 Posts
    Darkeme posted:
    I started my DarkRP serevr today and joined the gundealer class. I bought a shipment of guns but cannot use them, I tried use grav gun and phys gun, they won't even move? I have DarkRP 2008 2.2 if thats any help.
    The server is missing the CSS models.

  4. Post #4

    November 2007
    5 Posts
    Oh that mught explain it, do you know how to get them on srcds?

  5. Post #5
    Gold Member
    psp401.com's Avatar
    November 2005
    1,126 Posts
    Darkeme posted:
    Oh that mught explain it, do you know how to get them on srcds?
    Is it a rented server?

  6. Post #6

    November 2007
    5 Posts
    No I host it, its dedicated

  7. Post #7
    Gold Member
    psp401.com's Avatar
    November 2005
    1,126 Posts
    Darkeme posted:
    No I host it, its dedicated
    Just load CSS into the orangebox folder via HLDSUpdate Tool

  8. Post #8

    November 2007
    5 Posts
    Thanks for all the help it all works now!

  9. Post #9

    July 2008
    3 Posts
    I had the same problem and i couldnt move them or pick then up. Not it works fine, thanks so much.

  10. Post #10
    Gold Member
    philxyz's Avatar
    September 2007
    716 Posts
    Just a side note DarkRP 2008 is way out of date, get DarkRP 2.2.19 from Garrysmod.org

  11. Post #11

    October 2008
    1 Posts
    Hey I Have a similar problem I can not pick up droped money or pick up weapons from a shipment. I have the darkRP 2.2.14 and cs:s i'm running ded.server. It just stoped working one day. Any help would be nice.=)thx

    Edit:

    I found the problem I had. All you have to do is once the cs:s is done installing move the cstrike folder into the orangebox folder, and thats it.

  12. Post #12

    October 2008
    14 Posts
    there is a dark rp 2.2.17 avalible from garrysmod.org

    Edit:

    opps now there is 2.2.18

    rofl doesnt matter

  13. Post #13
    Gold Member
    philxyz's Avatar
    September 2007
    716 Posts
    Unless the F2 door issue becomes a massive problem, 2.2.18 is final.

    Edit: It was a problem. 2.2.19 is out now.

  14. Post #14

    April 2008
    910 Posts
    I have 2.2.19 on my server. But, I don't know what to write in the Server.cfg file to boot up a DarkRP server! HELP ME PLEASE

  15. Post #15
    Gold Member
    psp401.com's Avatar
    November 2005
    1,126 Posts
    sv_defaultgamemode "DarkRP"

  16. Post #16

    April 2008
    910 Posts
    Thanks psp401, do you know of any websites on commands or scripts for the DarkRP servers that I should put in the server.cfg folder? My problem is, I can find lots of things on running a GMOD server, but little to none on hosting a DarkRP server. Any help would be greatly appreciated.

  17. Post #17
    Yumyumbubleg's Avatar
    September 2008
    88 Posts
    Beastly_Boy posted:
    Thanks psp401, do you know of any websites on commands or scripts for the DarkRP servers that I should put in the server.cfg folder? My problem is, I can find lots of things on running a GMOD server, but little to none on hosting a DarkRP server. Any help would be greatly appreciated.
    If you go into the game and hit f2 it will bring up a list of all the commands for rp.

  18. Post #18

    April 2008
    910 Posts
    Okay, so if I add those to the server.cfg files, they will stay true to the server?

  19. Post #19
    Yumyumbubleg's Avatar
    September 2008
    88 Posts
    Beastly_Boy posted:
    Okay, so if I add those to the server.cfg files, they will stay true to the server?
    Yep, they will.

  20. Post #20

    April 2008
    910 Posts
    Okay, well I have entered sandbox commands and I'm trying to run my server as a build server, just for testing. I entered commands mentioned in this thread:

    http://forums.facepunchstudios.com/s...d.php?t=489710

    But, I cannot get my server to show up on the internet, only LAN. I have done everything mentioned in all of the guides I have read, nothing seems to work. Are there any hints on making this work? (I even did things as simple as typing "heartbeat" in the console.) All of my content for the server is located on D:\srcds\

    All of the Orange Box stuff is up there too, along with addons such as PHX and ULX.

    Anyone know what my problem may be?

  21. Post #21
    Gold Member
    philxyz's Avatar
    September 2007
    716 Posts
    If you are behind a router, you need to make sure that the router is set to change the incoming data packets (those coming in on port number 27015 or whatever your server is listening out for) so that their destination IP is now your server on the LAN (normally there is a port forwarding section on the router's built-in admin web page that allows you to enter those details.

    The router will then (normally) automatically change the address back on the way out to look like it came from your router instead of the server's LAN IP.

    That way, your server is using the router as its external IP address and it can be seen on the Intertubes.

  22. Post #22

    April 2008
    910 Posts
    Alright, I have already enabled port 27015, I could have sworn that I saw something about 27005 also? That must be the problem then. I am really getting confused with this stuff. I followed the instructions on all forums I have read, and also went to portforward.com/routers to look for info as suggested. I have unchecked the box that says something along the lines of "do not accept incoming data packets," so those should be coming through.

  23. Post #23
    Yumyumbubleg's Avatar
    September 2008
    88 Posts
    Make sure to disable any firewalls also.

  24. Post #24

    April 2008
    910 Posts
    Okay, I asked a friend of mine who hosts his own server, and somehow I got it working. I did multiple things, so I really can't state what the problem really was! Come visit me sometime at MikeGlass' RP server! Thanks for all of your help!

  25. Post #25

    February 2010
    1 Posts
    Hey i have that same problem but i don't know how to download css and i also have it installed. I just don't want my server to crash. So can somebody please help me.

  26. Post #26
    dumb ass
    RoFLWaFFLEZZ's Avatar
    April 2009
    2,582 Posts
    Hey i have that same problem but i don't know how to download css and i also have it installed. I just don't want my server to crash. So can somebody please help me.
    Way to bump a two year old thread.