1. Post #1
    coopercrue's Avatar
    January 2008
    596 Posts
    So i'm in game Gmod 10 in sandbox and i press ~ for the console but nothing happens what am i spose too do?
    Reply With Quote Edit / Delete Reply United States Show Events Dumb Dumb x 1 (list)

  2. Post #2
    Gold Member
    GiGaBiTe's Avatar
    February 2005
    3,160 Posts
    Like any other source engine game. Go into keyboard options -> advanced -> enable developer console.
    Reply With Quote Edit / Delete Reply Show Events Funny Funny x 1Agree Agree x 1Winner Winner x 1 (list)

  3. Post #3
    Zaabakka's Avatar
    May 2008
    38 Posts
    Or steam -> My games -> Garry's Mod -> (mouse2 click) Propeties -> launch propeties (it says only for advanced users) -> then type -console there.
    Reply With Quote Edit / Delete Reply Finland Show Events Disagree Disagree x 1Winner Winner x 1 (list)

  4. Post #4
    Gold Member
    amitakartok's Avatar
    September 2008
    1,061 Posts
    Steam way: opens console at startup, obscuring that nice background.

    If you still can't open the console with ~ then you are probably using a non-English keyboard layout. Numerous sites explain how to open the console on German layout. If you have Hungarian layout, then forget about opening the console in any way other than -console because ~ isn't on the keyboard (well, it is but it's AltGr-1 and it just don't work; I learned it the hard way). You can't redefine either because Source resets the console key bind on every startup.

  5. Post #5
    Gold Member

    March 2007
    1,642 Posts
    go to

    mycomputer posted:
    C:\Program Files\Steam\steamapps\YOURSTEAMACCUNTNAMEHERE\garr ysmod\garrysmod\cfg
    find the text doc con fig and add

    mycomputer posted:
    bind "`" "toggleconsole"
    you can replace "`" with any key on your keyboard like "l"

    save and load up Garry's mod

  6. Post #6
    weed 420 - hi mom - games r 4 nerds - i own - $WAG - *tips fedora* - do u lift?
    Elexar's Avatar
    October 2007
    12,263 Posts
    amitakartok posted:
    You can't redefine either because Source resets the console key bind on every startup.
    What if you bind it to 2 keys? 1 (~) and 1 (') for example. Then I guess source would say it's alright and won't bother about the secondary bind
    Reply With Quote Edit / Delete Reply Netherlands Show Events Useful Useful x 1 (list)

  7. Post #7
    Gold Member
    amitakartok's Avatar
    September 2008
    1,061 Posts
    No, I mean if I modify the original line of the bind, Source rewrites it. And if I bind it to another key (so it has multiple binds), that key doesn't work either. Summary: the only way to open the console is -console or -dev. If I accidentally close it, I have to restart <Source game here> or I'll have to live without console.
    I suppose the problem is with the default keyboard language. Windows defaults all programs to Hungarian and even if I change that, clicking on <Source game here>'s window resets the layout to HU, not EN (changing one program's layout doesn't affect the others'). And I can't change the default language to EN because I don't have the slightest idea how to do that; I can't delete HU layout either because it's the default. [/rant]

  8. Post #8
    Gold Member
    ReaperSWE's Avatar
    January 2005
    73 Posts
    Say in chat:
    Code:
    ";con_enable 1; bind F12 toggleconsole;
    Make sure you include the ";
    Reply With Quote Edit / Delete Reply Show Events Informative Informative x 1Dumb Dumb x 1Agree Agree x 1 (list)

  9. Post #9
    Tomppaduulis's Avatar
    September 2008
    17 Posts
    You can use say to use console commands? Never knew that before. I usually just set the -console launch option and then "bind f10 toggleconsole". That just usually makes me press f10 in any sourcegame when I try to open console. If I have forgotten to bind it, it will make me quit the game.

  10. Post #10
    Gold Member
    amitakartok's Avatar
    September 2008
    1,061 Posts
    To clarify: if I do that and press F12 (or whatever key I used), nothing happens. If the console is open and it's language is EN, the key will close it but it won't open again.

  11. Post #11
    Altninja's Avatar
    April 2008
    2 Posts
    For some reason toggleconsole doesn't work for me, so I use "showconsole"

  12. Post #12
    T2DM's Avatar
    January 2008
    273 Posts
    Try this, it has worked for me, so I think it will work for anyone else:

    1. Go to C:\Program Files\Steam\Steamapps\Your Username\Garrysmod\Garrysmod\cfg

    2. Open the file called config.cfg in notepad

    3. find the console line and change the bind to any key you want then proceed to save the file.

    4. Right click on the same file, go to properties, and tick the box that says "Read Only"

    5. Open up Garry's Mod, wait until it finishes loading then close it.

    6. Go back to the config.cfg file, right click -> Properties, then untick the Read Only box.

    Now you can start the game and you are good to go.
    Reply With Quote Edit / Delete Reply Argentina Show Events Agree Agree x 1 (list)

  13. Post #13
    SilVeR's Avatar
    July 2006
    11 Posts
    Thanks for the help. I was looking for a fix like this.

  14. Post #14
    I LIKE BIG DUCKS AND I CANNOT LIE, YOU OTHER QUACKS CAN'T DENY
    Wootman's Avatar
    December 2008
    13,341 Posts
    Why the hell are you guys posting these useless commands when the first post explained it.
    Reply With Quote Edit / Delete Reply United States Show Events Dumb Dumb x 2Disagree Disagree x 1 (list)

  15. Post #15
    Gold Member
    amitakartok's Avatar
    September 2008
    1,061 Posts
    Update: I since discovered that the reason why I couldn't bring up the console was that the console key doesn't work in the menu. If I press it in-game, it pauses the game and brings up the console. Yay!

  16. Post #16
    General Lee's Avatar
    April 2009
    507 Posts
    Something went horribley wrong for me, i cannot open console, at all, no matter what. Also, i cannot use backspace in text. i think i picked up some little lua virus, but i havent downloaded anything in ages,
    this goes for both singleplayer and multiplayer.

  17. Post #17
    Gold Member
    CoolCorky's Avatar
    February 2009
    17,398 Posts
    Chances are your keyboard's broken.

    At least your "bump thread" key is working fine.

  18. Post #18
    |FlapJack|'s Avatar
    July 2009
    6,138 Posts
    @ General Lee: Alt tab out and back in.