1. Post #201
    BloodShed's Avatar
    April 2005
    62 Posts
    Hmm, I am mistaken, you are correct. Thanks.
    No Problem :D

  2. Post #202
    gemmeg1's Avatar
    April 2008
    47 Posts
    Hey I was wondering would it be possible to make a program that opens an RT camera screen on the monitor? It would be perfect for security systems.
    So what do you think of this idea or is it not possible?

  3. Post #203
    Gold Member
    thomasfn's Avatar
    July 2008
    2,954 Posts
    Would be a simple addition to AlarmZ, which I am going to release in the next update.

  4. Post #204
    Gold Member

    July 2006
    1,951 Posts
    Have you gotten to configuring the cursor coordinates for my monitor yet? No offence, but I found that way too difficult, and some instructions would have been nice.

  5. Post #205
    Gold Member
    thomasfn's Avatar
    July 2008
    2,954 Posts
    Sorry, been kinda distracted recently.

    I've been doing a massive model make-over tonight and I will be aswell tommorow, adding in new models for everything and your model is on the list. Will look into cursor coords now.

    Edit:
    Ok I took a look, and you have your model rotated 90 degrees sideways. If you add the model to the pcspawn_monitor stool, you'll know what I mean. This means the cursor is always rotated 90 degrees aswell, and it appears inverted. Also, the origin appears offset - the screen is floating about 16 units above where the object position is reported. Move the screen down into the middle of the grid in your modelling program.

    So:
    1) Rotate your model the same way the CSS monitor is rotated
    2) Move the screen into the middle, not floating above

    Otherwise, great work.

  6. Post #206

    April 2007
    23 Posts
    Well, I have downloaded the latest SVN using tortoise.. Installed PC mod on almost clean gmod install. When I'm trying to use Chatserv I get an error, second time 3 of 4 times my whole Gmod freezez and crashes.. Anyone? Tried the version on gmod.org aswell. :/

  7. Post #207

    February 2009
    5 Posts
    This needs documentation about how to use a server.

    Yes, I've read the thread.

  8. Post #208
    Gold Member
    thomasfn's Avatar
    July 2008
    2,954 Posts
    Well, I have downloaded the latest SVN using tortoise.. Installed PC mod on almost clean gmod install. When I'm trying to use Chatserv I get an error, second time 3 of 4 times my whole Gmod freezez and crashes.. Anyone? Tried the version on gmod.org aswell. :/
    Tell Me The Error Message.

    Thank you, goodbye.

  9. Post #209
    Imazombie's Avatar
    February 2008
    2 Posts
    ERROR: GAMEMODE:'ScoreboardHide' Failed: pcmod/cl_gui.lua:152: attempt to index field 'Gui' (a nil value)

    I get that in console whenever i try to open my scoreboard...what would cause that and how can i fix it?

  10. Post #210
    Choppie's Avatar
    January 2007
    81 Posts
    ERROR: GAMEMODE:'ScoreboardHide' Failed: pcmod/cl_gui.lua:152: attempt to index field 'Gui' (a nil value)

    I get that in console whenever i try to open my scoreboard...what would cause that and how can i fix it?
    It happened to me, and I found its because I had PCMod 2 and the server had PCMod 1. Unless you go on single player, I'd suggest deleting you PCMod folder, then it won't happen and you can use whatever version of PCMod the server has.

  11. Post #211
    Chipstik's Avatar
    September 2008
    165 Posts

  12. Post #212
    Gold Member

    July 2006
    1,951 Posts
    I just broke my computer, so it may take some time until I finish the monitors. Just letting you know.

  13. Post #213
    Valeour's Avatar
    October 2007
    176 Posts
    Dark banned? This i must look into!


    Banned for "Why Reply?", Wow, Mahalis (or however it's spelt, i forget.) was on a banning spree in that thread...

  14. Post #214
    mbainrot's Avatar
    August 2008
    178 Posts
    First impulse: oooh shiney models

    second impulse... OMFG ITS A MAC ewww! :P

    kidding, its actually quite nice, keep up the great work

  15. Post #215
    Looks good but don't like the mac.

  16. Post #216
    chicob's Avatar
    April 2008
    76 Posts
    Burn the mac model please

  17. Post #217

    June 2008
    10 Posts
    People are to harsh on Mac's. They are good for some things...
    Like cooking eggs on and making movies...
    And pretty much nothing else...
    Heh Heh, Cry some more...
    P.S I like "..."s

  18. Post #218
    mbainrot's Avatar
    August 2008
    178 Posts
    and wasting money lol

  19. Post #219
    Valeour's Avatar
    October 2007
    176 Posts
    I've never used a mac or actually seen one in person. x3. But i like the look of my PC, it's awesome and shiney.

  20. Post #220
    www.bff-hab.de
    Dennab
    February 2009
    7,832 Posts
    Please do me a favor and make the sweps appear in a different category, not in the first. It's just plain annoying, why won't you put it in the second or third?

  21. Post #221
    Valeour's Avatar
    October 2007
    176 Posts
    What? What category? There's millions of different categorys, Narrow it down or screenshot or summat.

  22. Post #222
    Gold Member

    July 2006
    1,951 Posts
    I think that he means the first slot in the weapon selection.

  23. Post #223
    garrettair's Avatar
    November 2007
    12 Posts
    First impulse: oooh shiney models

    second impulse... OMFG ITS A MAC ewww! :P

    kidding, its actually quite nice, keep up the great work
    Wow, thats creepy same speakers I use, except PCmod is Insignia.

  24. Post #224
    Valeour's Avatar
    October 2007
    176 Posts
    Ooooh, Yeah, i don't like it in the first weapon slot either, the toolgun slot is more suited i think, personally anyway.

  25. Post #225
    Gold Member
    thomasfn's Avatar
    July 2008
    2,954 Posts
    Update is here.

    [release]Download:


    Changelog:
    Code:
    [ 28th February 2009 ][ thomasfn ]
    ADD: AlarmZ program
    ADD: Global entity limits
    FIX: Added extra prevention measures to stop error spam with scoreboard and other gui stuff in DarkRP
    ADD: Infinite loop protection to networking, should stop server crashing for now
    ADD: Network tester swep (handy!)
    FIX: The port selection menu that opens with the wire tool should be ALOT less laggier now
    ADD: Direct keyboard input via your real-life keyboard
    FIX: Some errors with the HD copier
    ADD: Laptop entity
    ADD: Power toggle button to the lock menu
    [/release]

    Edit:
    Turns out the info.txt file went missing.

    If you are installing from scratch, add a new file: garrysmod/addons/pcmod2/info.txt and inside it fill in:
    Code:
    "AddonInfo"
    {
    	"name"				"PCMod 2"
    	"version"			"2.0.2"
    	"up_date"			""
    	"author_name"			"[GU]thomasfn"
    	"author_email"			""
    	"author_url"			""
    	"info"				"PCMod 2"
    	"override"			"0"
    }

  26. Post #226
    Dennab
    November 2007
    2,807 Posts
    Sweet! Going to upload it to my server now!

  27. Post #227
    Gold Member

    July 2006
    1,951 Posts
    Sweet, direct keyboard input. But it turned out that I've totally fried my computer except for the harddrives, and I'm getting new one by tuesday, so it may take some time with the models.

  28. Post #228
    Valeour's Avatar
    October 2007
    176 Posts
    Epic, Well done you guys. If this mod has taught me anything, it is that i fail at modeling. And that i procrastinate, ALOT. x3.

  29. Post #229
    Gold Member
    yuki's Avatar
    December 2006
    4,209 Posts
    2 things:
    1. I got a subnet is a boolean value error when trying to connect routers to anything. (I just updated, this might be gone now)

    2. Can anyone create something that adds Portal models to this? It has a great keyboard and PC.

  30. Post #230

    September 2008
    93 Posts
    can you change the model for the paper that comes out of the printer ? if you need a model I can make one but I dont know how to make it work in Garrys mod

  31. Post #231
    Lancelot's Avatar
    January 2009
    164 Posts
    I agree with Yuki. The portal models are awesome.

  32. Post #232
    Ryo Ohki's Avatar
    March 2008
    1,416 Posts
    I've been looking around the thread but couldn't find anything. Does the save button of the notepad work on MP with the new patch? It didn't seem work on 2.0

    amazing work, expecially with the keyboard

  33. Post #233
    Gold Member
    thomasfn's Avatar
    July 2008
    2,954 Posts
    I can't seem to find the problem with the save button. It works fine on my server, even with 8+ other players.

  34. Post #234
    Dennab
    November 2007
    2,807 Posts
    I've been looking around the thread but couldn't find anything. Does the save button of the notepad work on MP with the new patch? It didn't seem work on 2.0

    amazing work, expecially with the keyboard
    Seemingly, no.

  35. Post #235

    January 2009
    1 Posts
    I cant get it to work, i downloaded the svn(which im assuming is 2.0.2) and placed it in addons folder called "PCMod2" it wont work with rp mod for me. i am running 2.3.5 :/


    EDIT: It works 50%, It didnt add a job so no one can buy a pc there is no pc programmer of anything of that nature :/

  36. Post #236

    February 2009
    5 Posts
    Okay so I have PCMod2, properly installed on my DarkRP 2.3.5 server.

    Everything works except 3 things:
    - The notepad is unable to save anything (i press save and nothing happens)
    - Printers always print out blank pages
    - I've never been able to set up a router network no matter what I tried

  37. Post #237
    Rob2006's Avatar
    December 2005
    2 Posts
    I installed the PCmod2.0.2 and i made the info.txt file like someone wrote it here.
    But i don't see the PCmod Button in Gmod.
    What made i wrong?


  38. Post #238
    cyberpunk's Avatar
    June 2005
    100 Posts
    would it be possible to get the io to refresh automatically? and will there be another stargate dialing program for this? aVoN has just redone the system the gates dial with.

  39. Post #239
    Ryo Ohki's Avatar
    March 2008
    1,416 Posts
    I can't seem to find the problem with the save button. It works fine on my server, even with 8+ other players.
    I've tried and in your server works fine, in others it doesn't. Could it be you forgot to put a file needed for servers into the release? I'm just picking a guess i don't know anything about lua

  40. Post #240
    BloodShed's Avatar
    April 2005
    62 Posts
    How does AlarmZ work?