1. Post #361
    Ronster's Avatar
    June 2007
    16 Posts
    Sorry if i have missed it in a previous post, but i am having two more problems :(.
    I have DarkRP and New Admin installed

    1. When a computer tech is present, everyone else can still buy computer parts (not spawn).

    2. No one can interact or use other peoples PCs or read print offs

    Unfortunately i can't fix it myself, but i have tried. There are no error messages or anything else, just plain and simply how i have put it.

    Any help appreciated. Thanks :)

  2. Post #362
    Ronster's Avatar
    June 2007
    16 Posts
    Sorry if i have missed it in a previous post, but i am having two more problems :(.
    I have DarkRP and New Admin installed

    1. When a computer tech is present, everyone else can still buy computer parts (not spawn).

    2. No one can interact or use other peoples PCs or read print offs

    Unfortunately i can't fix it myself, but i have tried. There are no error messages or anything else, just plain and simply how i have put it.

    Any help appreciated. Thanks :)

  3. Post #363
    Gold Member
    thomasfn's Avatar
    July 2008
    2,960 Posts
    There seems to be something with NewAdmin that stops you from using other people's entity - at least, either it's NewAdmin, or it's the prop protection you use.

    As for the computer tech thing, ensure that you have the latest PCMod version (2.0.4) and that the DarkRP plugin is installed in the correct place. (addons/pcmod2/lua/pcmod/plugins/)

  4. Post #364
    Ronster's Avatar
    June 2007
    16 Posts
    Thanks :)

    And by the looks of it, its the prop protection that comes with DarkRP because when i disable the gamemode, i no longer get that problem.

    Note: sorry for the double post

  5. Post #365
    chicob's Avatar
    April 2008
    76 Posts
    new problem i get these now

    ULib/server/hook.lua:139: attempt to index local 'gm' (a nil value)

    when i save and

    pcmod/ssdevices/dev_win_printloc.lua:36: attempt to index field '?' (a nil value)

    when i print
    Reply With Quote Edit / Delete Reply United States Show Events Lua Helper Lua Helper x 1 (list)

  6. Post #366
    Gold Member
    thomasfn's Avatar
    July 2008
    2,960 Posts
    Update your ULX to the latest, it's fixed in that. It might also fix the printing thing, not sure.

  7. Post #367
    infinitywrai's Avatar
    December 2007
    539 Posts
    in the chatserv, if you connect a new computer to an existing network that has chat in it, the old chat is in the window and any new chat is overwritten on it...

  8. Post #368
    Valeour's Avatar
    October 2007
    176 Posts
    NewAdmin is really restrictive over entities, if you have no priviledges in NewAdmin, you can't spawn entities.

  9. Post #369
    DevonX's Avatar
    November 2007
    29 Posts
    When i try to type in my password this happends

    pcmod/ssdevices/dev_win_password.lua31: atempt to call method 'draw buttons' (a nill value)

    loops
    and the map breaks

  10. Post #370
    Gold Member
    thomasfn's Avatar
    July 2008
    2,960 Posts
    Get the SVN version, the fix is in that.

  11. Post #371
    Blt950's Avatar
    November 2008
    391 Posts
    This PCmod 2 is awsome, but it of cource needs some fixes as all things and addons need.

    It wuld be great to have a software that you can install at PCs there you can restrict things at PC. So example it removes "Toggle Power", point with that is that you can make Cafè PC's, that example people need to pay for to use (RP) and then you turn on PC.

    Btw: Is it wire output that you can turn on/off pc?

  12. Post #372
    Valeour's Avatar
    October 2007
    176 Posts
    Not that i know of. But you can just use a Wire User. You could do what they do in game stores and keep the computer case in a glass case so people can't touch it, and use a wire user to turn it on.

  13. Post #373
    Gold Member

    August 2006
    766 Posts
    When i try to type in my password this happends

    pcmod/ssdevices/dev_win_password.lua31: atempt to call method 'draw buttons' (a nill value)

    loops
    and the map breaks
    I got that to so i tried to use No password at all, and then it worked.
    Reply With Quote Edit / Delete Reply Sweden Show Events Lua King Lua King x 1 (list)

  14. Post #374
    ogradyc's Avatar
    July 2007
    3 Posts
    When i try to type in my password this happends

    pcmod/ssdevices/dev_win_password.lua31: atempt to call method 'draw buttons' (a nill value)

    loops
    and the map breaks
    I have a very similar problem to this one when i was playing on my friends server and i opened the print dialogue, something like atempt to call something '?' and the map thing would happen thats when the printer wasn't connected properley. Then i tried it again with the printer connected and it crashed the server. Then i tried in single player, it froze my gmod and i had to kill task.
    Reply With Quote Edit / Delete Reply United Kingdom Show Events Lua King Lua King x 1 (list)

  15. Post #375

    August 2007
    152 Posts
    Get the latest SVN and tell the server owner to do so too
    Reply With Quote Edit / Delete Reply United States Show Events Lua King Lua King x 1 (list)

  16. Post #376
    ogradyc's Avatar
    July 2007
    3 Posts
    Get the latest SVN and tell the server owner to do so too
    I have just got latest svn and when on flatgrass it works it prints fine but if i am on RP_evocity_v2d it does this map thing and gives me this error pcmod/ssdevices/dev_win_printloc.lua:36: attempt to index field '?' (a nil value)
    then when i put in IP address and press print it freezes i have ULX and it does it but my friend has newadmin and that one does it to
    Reply With Quote Edit / Delete Reply United Kingdom Show Events Lua King Lua King x 1 (list)

  17. Post #377

    August 2007
    152 Posts
    ok. will look into it
    Reply With Quote Edit / Delete Reply United States Show Events Lua King Lua King x 1 (list)

  18. Post #378

    March 2009
    2 Posts
    Hello ThomasFn!

    Sorry if i will say this but on my previous gameplay i can use my pc made from this mod but this time it does not zoom in to the monitor and the mouse wont move Please Help me



    One More Thing it also appears in my error of lua ovveride please help
    Reply With Quote Edit / Delete Reply Philippines Show Events Informative Informative x 1 (list)

  19. Post #379
    Valeour's Avatar
    October 2007
    176 Posts
    Try to copy and paste the error into this forum, it will give Thomas (and other) a clear idea... If you don't know how to copy the error, open up the console when you do get the error and it will be in there.

    I'm also guessing you don't know what a console is, so go to the main menu, options, Keyboard, Advance, and tick the developer console, then press okay, and when you get the error, press ` (left of the number 1, just under escape) and you'll be able to copy from there.
    Reply With Quote Edit / Delete Reply United Kingdom Show Events Artistic Artistic x 1 (list)

  20. Post #380

    August 2007
    152 Posts
    Ok i have looked into the 2 problems above. The dev_win_password one can be solved by getting the latest SVN revision. The dev_win_printloc one can be solved by editing the file and adding the following to the bottom of the function DEV:Initialize
    	if(!PCMod.SDraw.DevParams[ self.EntID ]) then
    		PCMod.SDraw.DevParams[ self.EntID ] = {}
    	end
    	if(!PCMod.SDraw.DevParams[ self.EntID ][ "window_printloc" ]) then
    		PCMod.SDraw.DevParams[ self.EntID ][ "window_printloc" ] = {}
    	end
    Reply With Quote Edit / Delete Reply United States Show Events Winner Winner x 1 (list)

  21. Post #381
    Gold Member
    thomasfn's Avatar
    July 2008
    2,960 Posts
    Ok I commited the fix to the SVN. Update your SVNs to the latest.

    (Oh yeah and gmt, get a new avatar please -_-)

  22. Post #382

    August 2007
    152 Posts
    me no choose avatar. it is default ^_^

  23. Post #383
    Gold Member
    thomasfn's Avatar
    July 2008
    2,960 Posts
    Well at least change it to something better than the default lol.

  24. Post #384
    Gold Member
    Jimmy422's Avatar
    March 2007
    1,737 Posts
    How do you change the color of the BIOS and the text it displays? I can't find it in any of the configs.
    Anyone?

  25. Post #385
    Gold Member
    thomasfn's Avatar
    July 2008
    2,960 Posts
    The colour is defined in pcmod2/lua/pcmod/ssdevices/dev_bios.lua, or something like that. Just look for the Color keyword, probably in the DEV:Paint function. The text is defined in a mixture of places, not really easy to edit that. Look at the bios driver (pcmod2/lua/pcmod/drivers/bios.lua), and in the baseconfig file's codes table.

  26. Post #386
    infinitywrai's Avatar
    December 2007
    539 Posts
    in the chatserv, if you connect a new computer to an existing network that has chat in it, the old chat is in the window and any new chat is overwritten on it...
    Was this fixed? Sorry for hard to read sentence but it's a very annoying bug!

    Also if you walk away from a comptuer while it's booting, it gets stuck!

    Custom songs aren't working (tried in all of the last 3 versions)

    Also
    pcmod/cl_2d3d.lua:332: attempt to compare nil with number

  27. Post #387
    Gold Member

    August 2006
    766 Posts
    How do i put my Own music in the "Custom" tab? Or is it possible you can add Team Fortress 2 To the Media Player? :p

    UI\gamestartup1.mp3
    UI\gamestartup2.mp3
    UI\gamestartup3.mp3

    Are the Path to them.

  28. Post #388
    Valeour's Avatar
    October 2007
    176 Posts
    Sorry Gripen, I don't speak lazy. Read the thread and ask again later.

  29. Post #389
    Wickedgenius's Avatar
    November 2007
    407 Posts
    Because I am a little too lazy to read all 10 pages of this thread, has anyone made any applications yet?

  30. Post #390
    Gold Member
    thomasfn's Avatar
    July 2008
    2,960 Posts
    Not that I know of.

  31. Post #391
    ogradyc's Avatar
    July 2007
    3 Posts
    I have applied SVN update in my addons. I now get a new error when attempting to print, it does the map thing on a normal PC but not on a Laptop this is the error
    pcmod/cl_2d3d.lua:486: attempt to compare nil with number
    There are also some other errors in the console but they don't spam me
    11pcmod/ssdevices/dev_win_printloc.lua:32: table index is nil
    86: attempt to compare nil with number.

    I'm starting to feel like I'm nagging for fixes but I am just reporting bugs I suppose.

    Edit : Also the print dialouge does not show in notepad

  32. Post #392
    Valeour's Avatar
    October 2007
    176 Posts
    Hmm... Applications to make custom music... This is relevant to my interests... When i get back from college today, i'll look into it. Unless i forget. I need more practice with VB 'coz we're learning it in college. Although, the tasks in college just take the piss. "Type this and you're done, you're now a programmer! Hurray!" And yet, all i made was the form print "hello". Anyway, i'll have a looksie.

  33. Post #393
    mbainrot's Avatar
    August 2008
    178 Posts
    Hmm... Applications to make custom music... This is relevant to my interests... When i get back from college today, i'll look into it. Unless i forget. I need more practice with VB 'coz we're learning it in college. Although, the tasks in college just take the piss. "Type this and you're done, you're now a programmer! Hurray!" And yet, all i made was the form print "hello". Anyway, i'll have a looksie.
    LOL!

    Reminds me of the good 'ol days with C and "Hello World!"

  34. Post #394
    Valeour's Avatar
    October 2007
    176 Posts
    Tell me about it. >.<

  35. Post #395
    Lancelot's Avatar
    January 2009
    164 Posts
    Good ol' C,

    There actually was a tutorial out there that played a joke on that went something like:

    stdio.h

    printf("Goodbye Cruel World!")

  36. Post #396
    Valeour's Avatar
    October 2007
    176 Posts
    Speaking of Tutorial, has anyone actually made a tutorial on how to add custom music? I've looked through the thread and haven't found one, and on the last page, someone pointed out the baseconfig and config are the same and adding it to config doesn't work. I've tried it on both and it isn't working for me. So, a tutorial might be a good idea.

  37. Post #397
    Choppie's Avatar
    January 2007
    81 Posts
    We need a PCMod 2 laptop bag, its very annoying having to carry the laptop around with the grav gun on RP when people keep accessing it

  38. Post #398
    Valeour's Avatar
    October 2007
    176 Posts
    Can you use GMans brief case? That'd look cool carry around. xD

  39. Post #399
    Grocel's Avatar
    October 2008
    1,227 Posts
    Can you add a 2d3d Internet Browser and Text To Speech Program via dll modules?

    For the 2d3d Internet Browser dll module look here:
    http://www.facepunch.com/showthread.php?p=14009381

    For the Text To Speech dll module look here:
    http://www.facepunch.com/showthread.php?t=718033

  40. Post #400
    chainn's Avatar
    February 2009
    40 Posts
    Hi all, great mod by the way Thomasfn!. But i have a slight problem, my friend and i are trying to put some music in custom music section of the pc mod. we have the music able to show up in the custom tab, however it will not play. Can you please explain how to do this. PS. i have read the other posts... its just not like a step by step guide and it gets kinda confusing in the end. Thanks!