1. Post #161

    March 2007
    12 Posts
    You use the wrong URL.
    This here is the correct one: http://gmodmodules.googlecode.com/svn/trunk/gm_chrome/
    Reply With Quote Edit / Delete Reply Germany Show Events Disagree Disagree x 1 (list)

  2. Post #162
    alexojm's Avatar
    May 2009
    3,387 Posts
    MrIQ i tried that and still same problem

    Edited:

    oh and mine said something about path not found ???
    Reply With Quote Edit / Delete Reply United Kingdom Show Events Agree Agree x 1 (list)

  3. Post #163
    tidus_david's Avatar
    June 2009
    8 Posts
    Hmm for me the browser opens fine, but when I try to write text on the textbox of google, it won't "get" the key from the keyboard, I mean it's not reading the keys I wrote... so i cannot navigate inside the page, althought I can change the http://... anyone knows how to fix it? I downloaded http://www.garrysmod.org/downloads/?a=view&id=80178 Lua Chrome Browser

  4. Post #164
    sekuza009's Avatar
    August 2009
    74 Posts
    Do I need all 3 gm_chrome files or only the .dll?

  5. Post #165
    Gold Member
    mastersrp's Avatar
    October 2005
    1,733 Posts
    Do I need all 3 gm_chrome files or only the .dll?
    Just the dll.

  6. Post #166
    sekuza009's Avatar
    August 2009
    74 Posts
    Ok thanks =)

  7. Post #167
    BMCHa's Avatar
    August 2007
    853 Posts
    Hmm for me the browser opens fine, but when I try to write text on the textbox of google, it won't "get" the key from the keyboard, I mean it's not reading the keys I wrote... so i cannot navigate inside the page, althought I can change the http://... anyone knows how to fix it? I downloaded http://www.garrysmod.org/downloads/?a=view&id=80178 Lua Chrome Browser
    I've found that you need to click somewhere on the page before it accepts key input.
    Reply With Quote Edit / Delete Reply United States Show Events Agree Agree x 1Disagree Disagree x 1 (list)

  8. Post #168
    alexojm's Avatar
    May 2009
    3,387 Posts
    Oh i want to use this so bad but the links just arent working for my tortoise svn :(

    For now i gota stick to Firebox_v03 witch is ok cos youtube works on it but this looks way beter.
    Reply With Quote Edit / Delete Reply United Kingdom Show Events Funny Funny x 1 (list)

  9. Post #169
    BMCHa's Avatar
    August 2007
    853 Posts
    http://gmodmodules.googlecode.com/sv.../gm_chrome.dll


    Place it in garrysmod\garrysmod\lua\includes\modules
    Reply With Quote Edit / Delete Reply United States Show Events Disagree Disagree x 1 (list)

  10. Post #170
    alexojm's Avatar
    May 2009
    3,387 Posts
    i tried that BMCHa and still not working. Oh i so need a new pc.
    Reply With Quote Edit / Delete Reply United Kingdom Show Events Agree Agree x 1 (list)

  11. Post #171
    Reply With Quote Edit / Delete Reply United States Show Events Dumb Dumb x 1Informative Informative x 1 (list)

  12. Post #172
    alexojm's Avatar
    May 2009
    3,387 Posts
    None of the links that have been provided to me seem to work so im going to give up and just use firebox cos it does do the same thing realy.
    Reply With Quote Edit / Delete Reply United Kingdom Show Events Dumb Dumb x 1Agree Agree x 1 (list)

  13. Post #173
    Imme224's Avatar
    October 2009
    1 Posts
    No offense, but there isn't really a point to this. You can just open the steam web browser.
    But the steam browser is slow and crap!!
    Reply With Quote Edit / Delete Reply United States Show Events Late Late x 6Dumb Dumb x 2Agree Agree x 1 (list)

  14. Post #174
    tidus_david's Avatar
    June 2009
    8 Posts
    I have already clicked somewhere else in the page and it didn't worked... BMCHa but thanks anyway for trying to help me :)

  15. Post #175
    Quidsy the Squidsy's Avatar
    February 2009
    275 Posts
    Console error on singleplayer startup:

    error loading module 'chrome' from file 'c:\program files\steam\steamapps\*username*\garrysmod\garrysm od\lua\includes\modules\gm_chrome.dll':
    The specified procedure could not be found.

    :( Any help?

    I'm trying to use this addon by the way:
    http://www.garrysmod.org/downloads/?a=view&id=80178

  16. Post #176
    Maxaxle's Avatar
    March 2009
    400 Posts
    Console error on singleplayer startup:

    error loading module 'chrome' from file 'c:\program files\steam\steamapps\*username*\garrysmod\garrysm od\lua\includes\modules\gm_chrome.dll':
    The specified procedure could not be found.

    :( Any help?

    I'm trying to use this addon by the way:
    http://www.garrysmod.org/downloads/?a=view&id=80178
    Ditto. No clue what to do, already put it in Addons and installed Chrome (a vain attempt to make it work).

  17. Post #177
    Gold Member
    blackops7799's Avatar
    December 2006
    1,714 Posts
    Ditto. No clue what to do, already put it in Addons and installed Chrome (a vain attempt to make it work).
    That's your problem right there.
    Reply With Quote Edit / Delete Reply United States Show Events Disagree Disagree x 1 (list)

  18. Post #178
    Maxaxle's Avatar
    March 2009
    400 Posts
    That's your problem right there.
    !

    But it said to put it into addons...and is has an info.txt...

  19. Post #179
    Jvs
    PENISCorp's First Employee
    Jvs's Avatar
    June 2009
    1,597 Posts
    !

    But it said to put it into addons...and is has an info.txt...
    The addon,not the dll,the dll goes here "garrysmod\lua\includes\modules"
    Reply With Quote Edit / Delete Reply Italy Show Events Agree Agree x 1 (list)

  20. Post #180
    Maxaxle's Avatar
    March 2009
    400 Posts
    The addon,not the dll,the dll goes here "garrysmod\lua\includes\modules"
    .dll? Where?
    Reply With Quote Edit / Delete Reply United States Show Events Dumb Dumb x 3 (list)

  21. Post #181
    Quidsy the Squidsy's Avatar
    February 2009
    275 Posts
    I've put the 'google_chrome.dll' in 'garrysmod\lua\includes\modules', and i've put the ADDON in question in ADDONS folder. And then i get the aforementioned error.

    :(

  22. Post #182
    Maxaxle's Avatar
    March 2009
    400 Posts
    Durr I don't know what to do at all. Give me a link.

    durr herp derp.

  23. Post #183
    Gold Member
    blackops7799's Avatar
    December 2006
    1,714 Posts
    For the dumb asses who can't figure out how to install the dlls.



    Lol chome. Whoops.
    Reply With Quote Edit / Delete Reply United States Show Events Bad Spelling Bad Spelling x 1Dumb Dumb x 1Lua Helper Lua Helper x 1 (list)

  24. Post #184
    Quidsy the Squidsy's Avatar
    February 2009
    275 Posts
    Ok, even though to me it seemed i already had all the .dlls like that, its working now. Thanks for the help.

  25. Post #185
    Maxaxle's Avatar
    March 2009
    400 Posts
    For the dumb asses who can't figure out how to install the dlls.



    Lol chome. Whoops.
    Thank you. A lot.
    Reply With Quote Edit / Delete Reply United States Show Events Dumb Dumb x 2Funny Funny x 1 (list)

  26. Post #186
    Whitewater's Avatar
    December 2008
    190 Posts
    I found that a remarkable majority of people couldn't click-drag some files or unrar a file, so I made this
    *Disabled* See below for fix.
    It is a compiled autohotkey file (source included) that directs you to select your username folder (starts in steamapps, almost foolproof!) and then puts the files in the appropriate place.
    Reply With Quote Edit / Delete Reply United States Show Events Friendly Friendly x 2Dumb Dumb x 1 (list)

  27. Post #187

    July 2009
    5 Posts
    I really hate to ask this but I seriously read all of the thread. I downloaded multiple times after scouring the SVN repo. I then saw the drag and drops I did that. Then I saw the auto install and I did that. I cleared garry's mod of everything 3 times...

    Basically I'm asking how you spawn it. I tried ent_create google as I saw a couple pages back.. I can't find it anywhere in either my tool gun or my entity's spawn.

    Just a bit of help for some one who needs a bit of catching up.

  28. Post #188
    Gold Member
    Crazy Quebec's Avatar
    May 2008
    2,449 Posts
    I really hate to ask this but I seriously read all of the thread. I downloaded multiple times after scouring the SVN repo. I then saw the drag and drops I did that. Then I saw the auto install and I did that. I cleared garry's mod of everything 3 times...

    Basically I'm asking how you spawn it. I tried ent_create google as I saw a couple pages back.. I can't find it anywhere in either my tool gun or my entity's spawn.

    Just a bit of help for some one who needs a bit of catching up.
    This module is intended for use by developers. It doesn't give you anything that you can "spawn".

  29. Post #189

    July 2009
    5 Posts
    Yeah I understand it's in use for developers. Fine we can play this game.

    Hey I'm having trouble implementing this module into game-play I was wondering if anyone could help me out.

    I see that it's a functional demonstration and I was wondering if I could maby jump into lua coding from this. It's something I'm obviously avid about since I just spent the last 4 hours trying to figure out how to do this on my own.

    So I ask again. Could anyone help me out in putting this into actual game-play.


    ---EDIT---
    And honestly if it's just for developers maby those developers should learn how to use a SVN trunk and follow directions installing librarys so other developers can work on developing instead of making compiled autohotkey files.
    Reply With Quote Edit / Delete Reply United States Show Events Optimistic Optimistic x 1Dumb Dumb x 1Agree Agree x 1 (list)

  30. Post #190
    Whitewater's Avatar
    December 2008
    190 Posts
    Yeah I understand it's in use for developers. Fine we can play this game.

    Hey I'm having trouble implementing this module into game-play I was wondering if anyone could help me out.

    I see that it's a functional demonstration and I was wondering if I could maby jump into lua coding from this. It's something I'm obviously avid about since I just spent the last 4 hours trying to figure out how to do this on my own.

    So I ask again. Could anyone help me out in putting this into actual game-play.


    ---EDIT---
    And honestly if it's just for developers maby those developers should learn how to use a SVN trunk and follow directions installing librarys so other developers can work on developing instead of making compiled autohotkey files.
    I know nothing about lua; I just made a small file to install the dlls for those who couldn't figure it out. Though it may be broken... I'll see if I can include gm_bass and the example from the SVN (3d2d browser) from a few pages back, if I can. (I'll ask for permission.)

    EDIT----
    Great news, its finished.
    It doesn't include the 3d2d browser and radio, but thats a simple download anyway.
    However, it does include gm_bass and gm_chrome, and the related files.
    Additionally, the file size is greatly reduced, because it pulls the files from the svn. (Conviently doubles as an updater?)
    Again, not ENTIRELY foolproof, as I haven't found a method to just pull your username folder out, but, its the best I can do.
    *Disabled*
    I also added a little gui front end, so you know what you are getting into.

    EDIT2---
    Finished again!
    Thanks to the permission I got, now it downloads the 3d2d browser and radio as well.
    Filesize went up due to having to include the svn folders, but it was worth it. (Still doubles as an updater.)
    Foolproofness isn't complete yet.
    Excluded the source, but you can unpack the code yourself.
    Improved the GUI a little bit.
    Bugs- I have noticed that sometimes the svn folder doesn't get deleted from your desktop. I can't fix this, so just do it yourself. There is a reason why I put them on the desktop people!

    EDIT3---
    Major bugfix.
    Bass actually works now! :D
    Everything remained the same, it just retrieves one more file.

    If you ran it before, run it again to get bass fixed and all the dlls.
    Reply With Quote Edit / Delete Reply United States Show Events Dumb Dumb x 1Funny Funny x 1 (list)

  31. Post #191
    Gold Member
    Crazy Quebec's Avatar
    May 2008
    2,449 Posts
    And honestly if it's just for developers maby those developers should learn how to use a SVN trunk and follow directions installing librarys so other developers can work on developing instead of making compiled autohotkey files.
    There's no real need to host and maintain a SVN for a simple file that's not going to get updates frequently, if at all.

    Like Whitewater said examples have been posted earlier in the thread.

  32. Post #192

    July 2009
    5 Posts
    -snip-

  33. Post #193
    Grocel's Avatar
    October 2008
    1,234 Posts
    It's nice. But you should read this (outdated-link)
    some dlls must to be moved to work. :)

  34. Post #194
    Whitewater's Avatar
    December 2008
    190 Posts
    I literally just fixed that.
    I deleted all the relevant dlls and reloaded, and bass wasn't working. Found the problem. I missed bass.dll
    Thanks anyway.
    BTW, if you downloaded before November 13th, you will need to run this once again. I failed badly, and had the wrong bass.dll. SHOULD be fixed. I'm getting so tired of fixing this thing.

  35. Post #195
    foxcock
    Bletotum's Avatar
    June 2008
    6,873 Posts
    This thing is awesome. I'm posting from it right now :D.

  36. Post #196
    Pilotclan9404's Avatar
    January 2009
    813 Posts
    This thing is awesome. I'm posting from it right now :D.
    Neat - How DID you open it?

  37. Post #197
    foxcock
    Bletotum's Avatar
    June 2008
    6,873 Posts
    Thanks for reading the post RIGHT before mine...

  38. Post #198
    Grocel's Avatar
    October 2008
    1,234 Posts
    Why does the setvolume function of the gm_bass module not work correctly, setvolume take a float number according to the documentation, but when I give the function a 0.5 or below then you can hear nothing but when you give a number that's higher then 0.5 then you hear it like full volume.

  39. Post #199
    Levybreak's Avatar
    March 2008
    718 Posts
    Why does the setvolume function of the gm_bass module not work correctly, setvolume take a float number according to the documentation, but when I give the function a 0.5 or below then you can hear nothing but when you give a number that's higher then 0.5 then you hear it like full volume.
    Indeed, I have experienced this before as well. Is not not actually a SNDLVL_ eneum like in some other things for gmod, instead?

  40. Post #200
    foxcock
    Bletotum's Avatar
    June 2008
    6,873 Posts
    Can this module give what the currently loaded page is to lua? How about for any given player? (Detect serverside.) I'd like to know, because if so I could make myself a basic page-synchronization.
    Reply With Quote Edit / Delete Reply United States Show Events Dumb Dumb x 1Agree Agree x 1 (list)