1. Post #1
    1337asian's Avatar
    February 2009
    168 Posts
    Recently I got a old G3 from a friend and in the setpoint software it allows me to select the report rate at 1000.

    All the reviews say the the G3 has a report rate of 500 but I can turn it to 1000.

    What do I do? Keep at 500 or go for 1 ms response, 1000 hz.

  2. Post #2

  3. Post #3
    1337asian's Avatar
    February 2009
    168 Posts
    You sure? I need to ask some that really knows because I can't find any sure info from Logitech's site.

  4. Post #4
    Collin665's Avatar
    January 2008
    2,339 Posts
    Set it to 2000...

  5. Post #5
    1337asian's Avatar
    February 2009
    168 Posts
    Set it to 2000...
    This is polling rate not dpi

  6. Post #6
    Collin665's Avatar
    January 2008
    2,339 Posts
    Set it to 1000 and 2000.

    (I actually meant 2000 for the polling rate but I was kidding)

  7. Post #7
    It's not going to harm the mouse.

  8. Post #8
    1 Dollar
    Bonzai11's Avatar
    June 2005
    1,893 Posts
    Use google.
    You seriously think someones just gonna happen to have done the same thing and will help you?
    Also you can Oc through usb bus and driver mods, but judging by your inability to think I'd say don't try it.

  9. Post #9
    www.lmgtfy.com/?q=Logitech+G3+report+rate+1000hz

    (User was banned for this post ("Unhelpful reply" - Rusty100))

  10. Post #10
    I survived Camp FP 2010
    apwd007's Avatar
    July 2005
    634 Posts
    Why the fuck can't you people give a normal google link instead of that shit, it's fucking dumb

  11. Post #11
    www.bff-hab.de
    Dennab
    February 2009
    7,832 Posts
    Why the fuck can't you people give a normal google link instead of that shit, it's fucking dumb
    http://lmgtfy.com/?q=Why+the+fuck+ca...d+of+that+shit

  12. Post #12
    Wektron's Avatar
    June 2009
    138 Posts
    Why the fuck can't you people give a normal google link instead of that shit, it's fucking dumb
    No it isn't, it makes the poster feel stupid. "Oh, right, I could've just googled. Silly me"

    Just sending a google link won't help.

  13. Post #13
    I survived Camp FP 2010
    apwd007's Avatar
    July 2005
    634 Posts
    No it isn't, it makes the poster feel stupid. "Oh, right, I could've just googled. Silly me"

    Just sending a google link won't help.
    No it doesn't

  14. Post #14
    www.bff-hab.de
    Dennab
    February 2009
    7,832 Posts
    No it doesn't
    Yes it does.

  15. Post #15
    ninjia's Avatar
    June 2008
    133 Posts
    Yes it does.

  16. Post #16
    Gold Member
    reapaninja's Avatar
    November 2008
    8,118 Posts
    No it doesn't it just makes you look like an elitist prick

  17. Post #17

  18. Post #18
    Cynical Moderator
    birkett's Avatar
    July 2005
    1,342 Posts
    Short answer: Yes.
    Longer answer: It makes the poster look a cunt.

    Back on topic.
    I've never noticed any difference between 1 and 2ms response times. For the sake of numbers, put it at 1000hz, and be dissapointed that you cant get any extra frags.