1. Post #1
    Codename 47's Avatar
    March 2008
    1,845 Posts
    Often when I turn on my computer, Steam seems to start with it. But I can't find any Steam program running. And when I try to start a new one, it says that Steam is already running.

    The only way to fix this (temporarily), that I know, is to eliminate the process named "Steam 732897", and then restarting Steam. But when I turn on my computer again, the problem returns.

    Does anyone know a permanent solution?

    P.S. I have encountered this problem on two computers, one with Vista and one with Windows 7.
    Reply With Quote Edit / Delete Denmark Show Events Agree Agree x 2 (list)

  2. Post #2
    MAspiderface's Avatar
    July 2009
    9,938 Posts
    Ctrl+alt+del
    Processes.
    Click on Steam.exe
    End Process
    Reply With Quote Edit / Delete United States Show Events Agree x 9Bad Reading x 4Dumb x 1Informative x 1Useful x 1 (list)

  3. Post #3
    Gold Member
    stea1th's Avatar
    December 2008
    2,566 Posts
    Stop steam from opening at start up and activate it manually when you want to play.
    Reply With Quote Edit / Delete Singapore Show Events Agree Agree x 2Informative Informative x 1Disagree Disagree x 1 (list)

  4. Post #4
    Codename 47's Avatar
    March 2008
    1,845 Posts
    Is that really the only option?
    Reply With Quote Edit / Delete Denmark Show Events

  5. Post #5
    Gold Member
    CoolCorky's Avatar
    February 2009
    17,481 Posts
    Is it really that much of a trauma to double-click an icon?
    Reply With Quote Edit / Delete United Kingdom Show Events Agree Agree x 2Bad Spelling Bad Spelling x 1Bad Reading Bad Reading x 1Dumb Dumb x 1 (list)

  6. Post #6
    Gold Member
    ica|kvantum's Avatar
    August 2008
    3,805 Posts
    Ctrl+alt+del
    Processes.
    Click on Steam.exe
    End Process
    I have the same problem sometimes and i do this ^

    Try run msconfig maby and fix your start programs?
    Reply With Quote Edit / Delete Sweden Show Events Agree Agree x 1 (list)

  7. Post #7
    Codename 47's Avatar
    March 2008
    1,845 Posts
    Is it really that much of a trauma to double-click an icon?
    Double click an icon? If double click the Steam icon, it says it's already running.
    Then I have to eliminate the process manually, which gets pretty annoying over time.

    I have the same problem sometimes and i do this ^

    Try run msconfig maby and fix your start programs?
    Messing with my start programs doesn't help; if I don't start Steam on Windows startup, the next time I run it it says that it could not connect to Steam. Then, when I try to run the program again, it says it's already running, and so on.
    Reply With Quote Edit / Delete Denmark Show Events

  8. Post #8
    Gold Member
    CoolCorky's Avatar
    February 2009
    17,481 Posts
    Double click an icon? If double click the Steam icon, it says it's already running.
    Then I have to eliminate the process manually, which gets pretty annoying over time.
    I meant if you have it not start on computer startup.
    Reply With Quote Edit / Delete United Kingdom Show Events

  9. Post #9
    Codename 47's Avatar
    March 2008
    1,845 Posts
    I meant if you have it not start on computer startup.
    What
    Reply With Quote Edit / Delete Denmark Show Events Dumb Dumb x 1 (list)

  10. Post #10
    Killed postal with a fart once.
    gk99's Avatar
    December 2007
    8,183 Posts
    Uninstall => Reinstall

    It could help.
    Reply With Quote Edit / Delete United States Show Events Dumb Dumb x 8 (list)

  11. Post #11
    Gold Member
    Zackin5's Avatar
    May 2008
    4,854 Posts
    Steam is set to start once you start the computer. but it hangs so it does not fully start up, so you have to end the process and double click the shortcut to start it.

    But if you set it not to start on startup then it won't hang and you just need to use the shortcut to run it.
    Reply With Quote Edit / Delete United States Show Events

  12. Post #12
    dzonint's Avatar
    March 2010
    3,792 Posts
    Uninstall => Reinstall

    It could help.
    The fuck?
    You are 10 year old furry?

    (User was banned for this post ("Trolling" - Jaanus))

    (User was banned for this post ("" - Jaanus))

    (User was banned for this post ("Trolling" - Jaanus))
    Reply With Quote Edit / Delete Serbia Show Events Funny Funny x 6Agree Agree x 3Dumb Dumb x 1 (list)

  13. Post #13
    anarcheril's Avatar
    April 2009
    210 Posts
    All right, even though the fix has already been stated, I will give a fuller tutorial, also explaining why this happens. When you try to start steam and you get the message telling you steam is already running, and you can clearly see its not, its because you steam app id isn't logged in but your steam client is running. As far as fixing goes there are a couple ways of doing things, Vista is a very unstable operating system, and windows 7 is a little new on the block, so these errors are much more common on them rather than in XP. So to start... as previously mentioned the quick fix is to end the steam process ( Ctrl+Alt-Del, open task manager, go to the process tab, look for "steam.exe" and end it ) and then re-open steam. If you want to prevent this from ever happening, you wont, now and then it will always do this on any PC. But to do the best you can you should start by taking it off your program start up list ( Open steam settings and go to the Interface tab and near the bottom, uncheck "Run Steam when Windows Starts". This means you will manually have to start it up when you start up your PC. As for when you run it, things always run better and avoid errors when you run them in compatibility mode, and as admin. So on your steam shortcut, right click and go to preferences and set the compatibility mode to windows XP sp2. Click apply or Ok, then right click the shortcut and run as admin. Running it compatibility mode should take care of any Windows related problems that are stopping the steam client from doing its business.

    Have a good one, I'm off to have some Nachos,
    Reply With Quote Edit / Delete Canada Show Events Informative Informative x 2 (list)

  14. Post #14
    Gold Member
    AlfieSR's Avatar
    April 2009
    4,569 Posts
    (User was banned for this post ("Trolling" - Jaanus))

    (User was banned for this post ("" - Jaanus))

    (User was banned for this post ("Trolling" - Jaanus))
    What? 3 bans at once?

    To OP, disable steam starting at startup, restart, then re-enable it. If that doesn't fix the problem, reinstall.
    Reply With Quote Edit / Delete United Kingdom Show Events Late Late x 1Agree Agree x 1Funny Funny x 1 (list)

  15. Post #15
    TacticalSanta's Avatar
    January 2010
    274 Posts
    Ctrl+alt+del
    Processes.
    Click on Steam.exe
    End Process
    I don't know if it's windows 7 or not, but I find myself having to do this just about every time I close Firefox, and every once and a while steam.

    Know that I think about it. It usually only does this if I close a program and re open it within a minute. Probably has something to do with firefox caching stuff before it terminates. idk.
    Reply With Quote Edit / Delete United States Show Events

  16. Post #16
    Codename 47's Avatar
    March 2008
    1,845 Posts
    All right, even though the fix has already been stated, I will give a fuller tutorial, also explaining why this happens. When you try to start steam and you get the message telling you steam is already running, and you can clearly see its not, its because you steam app id isn't logged in but your steam client is running. As far as fixing goes there are a couple ways of doing things, Vista is a very unstable operating system, and windows 7 is a little new on the block, so these errors are much more common on them rather than in XP. So to start... as previously mentioned the quick fix is to end the steam process ( Ctrl+Alt-Del, open task manager, go to the process tab, look for "steam.exe" and end it ) and then re-open steam. If you want to prevent this from ever happening, you wont, now and then it will always do this on any PC. But to do the best you can you should start by taking it off your program start up list ( Open steam settings and go to the Interface tab and near the bottom, uncheck "Run Steam when Windows Starts". This means you will manually have to start it up when you start up your PC. As for when you run it, things always run better and avoid errors when you run them in compatibility mode, and as admin. So on your steam shortcut, right click and go to preferences and set the compatibility mode to windows XP sp2. Click apply or Ok, then right click the shortcut and run as admin. Running it compatibility mode should take care of any Windows related problems that are stopping the steam client from doing its business.

    Have a good one, I'm off to have some Nachos,
    Wow, thanks dude. That was really useful, and I think I've fixed it now. I hope you enjoyed your nachos, and I hope you read this and feel cool :c00l:

    Thanks again!
    Reply With Quote Edit / Delete Denmark Show Events

  17. Post #17

    September 2011
    1 Posts
    All right, even though the fix has already been stated, I will give a fuller tutorial, also explaining why this happens. When you try to start steam and you get the message telling you steam is already running, and you can clearly see its not, its because you steam app id isn't logged in but your steam client is running. As far as fixing goes there are a couple ways of doing things, Vista is a very unstable operating system, and windows 7 is a little new on the block, so these errors are much more common on them rather than in XP. So to start... as previously mentioned the quick fix is to end the steam process ( Ctrl+Alt-Del, open task manager, go to the process tab, look for "steam.exe" and end it ) and then re-open steam. If you want to prevent this from ever happening, you wont, now and then it will always do this on any PC. But to do the best you can you should start by taking it off your program start up list ( Open steam settings and go to the Interface tab and near the bottom, uncheck "Run Steam when Windows Starts". This means you will manually have to start it up when you start up your PC. As for when you run it, things always run better and avoid errors when you run them in compatibility mode, and as admin. So on your steam shortcut, right click and go to preferences and set the compatibility mode to windows XP sp2. Click apply or Ok, then right click the shortcut and run as admin. Running it compatibility mode should take care of any Windows related problems that are stopping the steam client from doing its business.

    Have a good one, I'm off to have some Nachos,


    OMG thank you i was rely woried because i have got a new computer a week ago and today steam kept on stuffing up like this so i searched google and you were the only one (that i got to look at) that acualy explaind how to fix the problem so THANK_YOU!!!!!!!!!!!!!!!!!!!!!!!!!!!1!!!

    (User was banned for this post ("Dumb bump" - Orkel))
    Reply With Quote Edit / Delete Windows 7 Australia Show Events Dumb Dumb x 5 (list)

  18. Post #18
    killkill85's Avatar
    February 2009
    2,740 Posts
    OMG thank you i was rely woried because i have got a new computer a week ago and today steam kept on stuffing up like this so i searched google and you were the only one (that i got to look at) that acualy explaind how to fix the problem so THANK_YOU!!!!!!!!!!!!!!!!!!!!!!!!!!!1!!!


    Seriously,the last post here was a year ago and didn't you notice how everyone else in the entire thread used perfect grammar?Facepunch isn't the forum for you,either get out or just lurk,observe and don't post until you know how to act more maturely on the internet.

    (User was banned for this post ("Image macro/complaining about a bump" - Orkel))
    Reply With Quote Edit / Delete Windows 7 United Arab Emirates Show Events Dumb Dumb x 2 (list)