1. Post #521
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    Did it a few posts ago :)
    Ok.
    Can you please download GCFScape and open the files steamapps/common/left 4 dead 2/left4dead2/pak01_dir.vpk and pak02_dir.vpk.

    Check both for the folder "models/survivors/gambler/" and tell me, in which one it is. For me, it's in the pak01.

  2. Post #522
    morten8035's Avatar
    December 2006
    58 Posts
    It's in pack01_dir.
    I assume you want the vmt?
    gambler_eyeball_L - gambler_eyeball_R are exactly like gambler_eyeball_L.

  3. Post #523
    Gold Member
    Lite :3's Avatar
    August 2009
    669 Posts
    Not to my knowledge. Post a condump on pastebin please, because it seems like there are textures missing. I'd like to add them/fix it. But since I don't have this issue, I can't fix it so I need you.

    Edited:



    Start L4D2, make it update, check for integrity - Like Readme.txt tells you. Try again.

    Also: Supply the crashmessage (open it and post the info on "extended")
    I'm guessing you want the crash logs? I'll just leave these here - http://www.mediafire.com/?zzinrmmmzml

    Also, tried verifying, making L4D2 update, etc. Still no progress.

    Edit: Good news, a clean reinstall of Gmod + L4D2 fixed it. :smug: Sorry for the trouble.

  4. Post #524
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    It's in pack01_dir.
    I assume you want the vmt?
    gambler_eyeball_L - gambler_eyeball_R are exactly like gambler_eyeball_L.
    No, I just needed to know if it's in 01, because I only mount 01.

    Can you look at your Graphic-Settings/Shader Quality. Or better: Print a screenshot of your Graphic Settings screens.

  5. Post #525
    morten8035's Avatar
    December 2006
    58 Posts
    Sure.

  6. Post #526
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    Can you switch everything to High/Ultra High and enable DirextX 9 please? Use -dxlevel 90.

  7. Post #527
    morten8035's Avatar
    December 2006
    58 Posts
    Well. The game crashed when i sett anti aliasing on more than 8x CSAA, So I stick to 8x CSAA as the "highest" setting. And It looks like the game crashes when sync is on. Odd, I can swear I have had all settings on max before. (Because of -dxlevel 90 maybe?) Here is a screenshot of the settings. Ever odder, I can run the game without lag with these setting :D
    And it looks like the survivors have got their eyes back :D The annoying this is that every time I start gmod with -dxlevel 90, all settings it reseted, So I guess I need to make a config for that? :(
    Thanks anyway almighty aVoN McKay. :)
    Reply With Quote Edit / Delete Reply Norway Show Events Bad Spelling Bad Spelling x 1 (list)

  8. Post #528
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    Ok, so the solution for the eyes is really running on DirextX 9.0 how it seems.

  9. Post #529
    morten8035's Avatar
    December 2006
    58 Posts
    Yeah. I also got dynamic light/shadows back too ♥.
    Every time I change a setting, gmod crashes. I tried to google to find some answers to that without success.

  10. Post #530
    E-102 Gamma's Avatar
    February 2010
    2,697 Posts
    Dxlevel should be 95 or 98, not 90, unless you have a REALLY low-end DX9 card, and even then you should at least try setting it to 95.

  11. Post #531
    morten8035's Avatar
    December 2006
    58 Posts
    Well, I have NVIDIA GeForce 8600M GT. I will try out 95 instead of 90 later :)
    EDIT:
    I still crashes with 95 and 98.

  12. Post #532
    raubana's Avatar
    April 2009
    655 Posts
    Hey, I know this is pretty much dead by now, but Garry changed the extensions thing, so now the gmount thing doesn't work...can you fix it plz?
    Reply With Quote Edit / Delete Reply United States Show Events Dumb Dumb x 1 (list)

  13. Post #533
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    Hey, I know this is pretty much dead by now, but Garry changed the extensions thing, so now the gmount thing doesn't work...can you fix it plz?
    GM_Mount2 still works. It's not under "GMod Settings" anymore, it's now under "Extensions/Games".

  14. Post #534
    three wieners
    SuperEmoBros's Avatar
    August 2009
    908 Posts
    I fixed 2 things for you aVoN.

    The problem for why it wasn't loading was the module. It was in lua/include/modules, when it should have been in lua/includes/modules.

    Also, I noticed you missed out quite a few source mods that are on Steam, so I have edited one of the .luas to fix it. Here is the chunk that I edited:
    -- Currently copy & paste from the old  enhanced-gm_mount by SteveUk. later my addon will find all your games dynamically
    local AdditionalContent = {
    	ageofchivalry = {title = "Age of Chivalry",depotid = 17510},
    	mm = {title = "Dark Messiah",depotid = {2100,2130}},
    	diprip = {title = "D.I.P.R.I.P. Warm Up",depotid = 17530},
    	dystopia = {title = "Dystopia",depotid = 17580},
    	esmod = {title = "Eternal Silence",depotid = 17550},
    	insurgency = {title = "Insurgency Modern Infantry Combat",depotid = 17700},
    	left4dead = {title = "Left 4 Dead",depotid = 500,vpk = "pak01_dir.vpk"},
    	left4dead2 = {title = "Left 4 Dead 2",depotid = 550,vpk = "pak01_dir.vpk"},
    	pvkii = {title = "Pirates, Vikings, and Knights II",depotid = 17570},
    	se1 = {title = "SiN Episodes",depotid = 1300},
    	smashball = {title = "Smashball",depotid = 17730},
    	synergy = {title = "Synergy",depotid = 17520},
    	ship = {title = "The Ship",depotid = 2400},
    	zps = {title = "Zombie Panic! Source",depotid = 17500},
    }

    That goes into mount2.lua, and I think you can tell where in it.
    What about Fortress Forever?

    Edited:

    Oh snap. Didn't even notice that. Sweet.

    Edit:

    Potential problem?
    i imagine if you were to check that box it would cause a time paradox
    Reply With Quote Edit / Delete Reply United States Show Events Funny Funny x 4Dumb Dumb x 1 (list)

  15. Post #535
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    What about Fortress Forever?

    Edited:



    i imagine if you were to check that box it would cause a time paradox
    Why do you reply to things which are months old and got fixed ages ago?


    [list][*]Fortress Forever is a sourcemod. Every sourcemod can be mounted. Just games sold on Steam must be present in that file (btw: That file does not exist anymore). This has already been answered in this thread. Even the OP says that.[*]Mounting GMod in GMod got fixed ages ago. And not a "timeparadox". Fucking dumb meme-reply[*]Why do I reply to a troll-post?[/list]
    Reply With Quote Edit / Delete Reply Germany Show Events Funny Funny x 1Disagree Disagree x 1Dumb Dumb x 1 (list)

  16. Post #536
    Gold Member
    Omolong's Avatar
    December 2007
    7,520 Posts
    That reminds me aVoN, Dystopia doesn't seem to be mountable any more, and the Counter-Strike Beta isn't listed in the mount menu.

  17. Post #537
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    That reminds me aVoN, Dystopia doesn't seem to be mountable any more, and the Counter-Strike Beta isn't listed in the mount menu.
    CS:S Beta should be just "Counter-Strike". And Dystopia should be started at least once before you can mount it.

  18. Post #538
    Gold Member
    Omolong's Avatar
    December 2007
    7,520 Posts
    CS:S Beta should be just "Counter-Strike". And Dystopia should be started at least once before you can mount it.
    I have started Dystopia at least once. Still got the problem.

  19. Post #539
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    I have started Dystopia at least once. Still got the problem.
    Strange. I'll look further into it.

  20. Post #540
    Gold Member
    Wizey!'s Avatar
    October 2008
    2,064 Posts
    I have none at all. Every mod i have can be mounted with no problems at all.
    Reply With Quote Edit / Delete Reply United Kingdom Show Events Dumb Dumb x 1 (list)

  21. Post #541
    LOLDUDE's Avatar
    April 2010
    226 Posts
    I will be extremely pleased if the following are mountable:
    Dystopia
    HL2 SMod

  22. Post #542
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    I will be extremely pleased if the following are mountable:
    Dystopia
    HL2 SMod
    SMod can already be mounted.....
    Also: I found the problem with Dystopia. Update coming any minute.

    Edited:

    Fix uploaded. Dystopia can be mounted again.

  23. Post #543
    ninjasniper's Avatar
    January 2010
    5 Posts
    when i try to install it it says copy failed, what do i do or what did i do?

  24. Post #544
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    when i try to install it it says copy failed, what do i do or what did i do?
    Used the installer or direct-copy? If you used the installer: Try manually installing it (regarding the instructions in the Readme). Looks like a permission-problem to me.

  25. Post #545
    morphhh's Avatar
    December 2007
    42 Posts
    mount2.zip link is broken again.
    Edit:
    Nevermind

    Edited:

    I need more information:

    [LIST][*]Hardware Specs[*]DirectX Mode[*]Used version of gm_mount2[*]Is really everything installed correctly? (Addons/Left 4 Dead and Addons/Left 4 Dead 2 must be present).[*]Tried gm_mount without any other addons installed (but the one of gm_mount2)?[*]Tried on clean gmod?[/LIST]
    Edited:



    I can't understand, why this happens to you. I just had this one time because steam somehow has "uninstalled" my game (doh). So I just had to start it one more time and it was present and selectable in the menu again.
    AMD Phenom™ 9650 Quad-Core ~2.3 GHz
    ASUS M2N-MX SE Plus
    SAMSUNG HD103SJ SCSI 1 TB 7200 RPM SATA II
    Satellite 600W PSU
    Microsoft Windows 7 Ultimate x64
    2x2 GB Kingston DDR2
    XFX ATi Radeon HD4890 1 GB GDDR 5
    dxlevel 90

    mount2 version 1.0.40
    Yes, I installed them correctly, there's both addons\Left 4 Dead and addons\Left 4 Dead 2 folders and I opened these games (I PLAY them)
    I tried to clean my gmod, then I installed mount2 (and no other addons) and still crashes when I try to spawn Bill's model

  26. Post #546

    May 2010
    10 Posts
    EDIT: Nevermind.

  27. Post #547
    ivkos's Avatar
    April 2010
    12 Posts
    Hello,
    I need some help with mounting Orange Box GCFs to Garry's Mod Dedicated Server.
    I used HLDS Update Tool to get the SRCDS binaries but I don't want to download other game content using the same tool as I own Orange Box GCFs on my primary computer and copied them to the server computer.

    Let's say I want to mount these two to the dedicated server:
    E:\GCFs\team fortress 2 content.gcf
    E:\GCFs\episode two content.gcf

    How do I do that using gm_mount2?

    Thank you.

  28. Post #548
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    Hello,
    I need some help with mounting Orange Box GCFs to Garry's Mod Dedicated Server.
    I used HLDS Update Tool to get the SRCDS binaries but I don't want to download other game content using the same tool as I own Orange Box GCFs on my primary computer and copied them to the server computer.

    Let's say I want to mount these two to the dedicated server:
    E:\GCFs\team fortress 2 content.gcf
    E:\GCFs\episode two content.gcf

    How do I do that using gm_mount2?

    Thank you.
    Unpack them to a folder so it looks like
    <The Folder>/episodic/

    Make episodic available under <srcds>/orangebox/ so the path there is <srcds>/orangebox/episodic/ (Use e.g. symbolic links or copy it in directly)

    Note: srcds doesn't use gcf.
    Reply With Quote Edit / Delete Reply Germany Show Events Informative Informative x 1 (list)

  29. Post #549
    GameAdict's Avatar
    May 2008
    811 Posts
    SVN deleted G_Mount2 from Addons...I'm sad :(

  30. Post #550
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    SVN deleted G_Mount2 from Addons...I'm sad :(
    First: It's gm_mount2, not "G"_Mount2.
    Second: The folder "mount2" in /addons is not required anymore (because garry blocked a routine in GMod some time ago)

  31. Post #551
    Gold Member
    noobcake's Avatar
    November 2006
    3,648 Posts
    Ok, I'm trying to get this to work on my dedicated, but thanks to aVoN's Engrish, it was a little hard to understand. From what I gather, I'm supposed to create a folder entitled left4dead2 inside my orangebox folder aside my garrysmod and other such folders. Then inside it I'm supposed to place the gameinfo.txt taken from the actual game (Left 4 Dead 2). But this isn't working. It works fully on my client but getting it to work on my server remains enigmatic.

  32. Post #552
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    I assume, you installed left4dead to
    /scrds_l4d/
    and gmod to
    /scrds_gmod/

    The gamefolder (the folder, which contains the gameinfo.txt) of GMod is then in
    /scrds_gmod/orangebox/garrysmod

    and the gamefolder (the folder, which contains the gameinfo.txt) of L4D is then in
    /scrds_l4d/left4dead/left4dead

    Copy (or link it with Link Shell Extension as symbolic link) to
    /scrds_gmod/orangebox/left4dead

    so the following path is valid

    /scrds_gmod/orangebox/left4dead/gameinfo.txt

    Code:
    If you now have Left 4 Dead 1/2 or any other non-default-sourceengine game installed,
    make sure you implement it's "game-folder" which contains the "gameinfo.txt"
    to <srcds>/orangebox. Example. Let's assume you have an L4D server
    
    /<left4dead>
      /left4dead				###### This is the folder which has to be available in <srcds>/orangebox/
        gameinfo.txt
        ...
      /left4dead_german
    		...
    
    Then either copy or link it (with e.g. symbolic links - For NTFS, you can use this program http://schinagl.priv.at/nt/hardlinks...kshellext.html)
    to the orangebox-folder, so it looks like this
    
    /<scrds>
      /hl2mp
        gameinfo.txt
        ...
      /cstrike
        gameinfo.txt
        ...
      /orangebox
        /left4dead/ 		###### The game has to be added here
        gameinfo.txt
        ...
        /episodic
          gameinfo.txt
          ...
        /garrysmod
          gameinfo.txt
          ...
        ...
    ...
    That's what this paragraph was saying. I also marked the important folders in the readme and bolded them in this post.

  33. Post #553
    Gold Member
    noobcake's Avatar
    November 2006
    3,648 Posts
    I'm actually adding the hardlink source from my client installation of L4D2, because I don't have a L4D2 server.

  34. Post #554
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    Don't use Hard Links, you better use Symbolic Links. They are generally safer.
    Client installation should be sufficient too. You only need to make the folder of l4d which contains the gameinfo.txt available in the orangebox folder and mount2 is doing the remaining stuff.

  35. Post #555
    zantetzou's Avatar
    June 2009
    9 Posts
    It may just be me failing epicly, but i copied the l4d/l4d2 folders to gmod and the dedicate server console says they are mounted
    yet i cannot spawn any of the content from either game.
    I probably missed something stupidly simple somewhere, but its late so il try again tommorow.

  36. Post #556
    Gold Member
    noobcake's Avatar
    November 2006
    3,648 Posts
    Don't use Hard Links, you better use Symbolic Links. They are generally safer.
    Client installation should be sufficient too. You only need to make the folder of l4d which contains the gameinfo.txt available in the orangebox folder and mount2 is doing the remaining stuff.
    Eh forget it. I got the stuff I needed from the L4D2 model pack.

    Thanks for trying to help, though. It works great in SP.

    EDIT: I retract that remark it didn't contain the models I need.

  37. Post #557
    Gold Member
    thomasfn's Avatar
    July 2008
    2,959 Posts
    What order does this mount stuff in? Would content added by the server (resource.AddFile) override content mounted on the client from a sourcemod?

  38. Post #558
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    Ressource.addfile has nothing to do with mounting.

    Order:
    Gmod
    Stuff mounted by gmod like hl2
    Gmod addons
    Mount2 high-priority content (by now, just l4d2)
    Mount2 content

    Edited:

    Ressource.addfile has nothing to do with mounting.

    Order:
    Gmod
    Stuff mounted by gmod like hl2
    Gmod addons
    Mount2 high-priority content (by now, just l4d2)
    Mount2 content
    Reply With Quote Edit / Delete Reply Germany Show Events Optimistic Optimistic x 1 (list)

  39. Post #559
    Mr. Massacre's Avatar
    April 2010
    789 Posts
    I upgraded to the new, fixed version and the models work, but the icons are still all ERRORs...

  40. Post #560
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    Rebuild the icons.