1. Post #81
    jack254's Avatar
    January 2010
    1,385 Posts
    this thread is fairly slow, perhaps it would be better not under entities?


    also, could tiberium in groups of 3 become one entity? (to help fight lag)

  2. Post #82
    oficcerthegeek's Avatar
    January 2009
    532 Posts
    perhaps it would be better not under entities?
    Perhaps you remember he history before asking for this?

    I belive we all said a nice "NO!".

  3. Post #83
    jack254's Avatar
    January 2010
    1,385 Posts
    No,i dont, now please spread knowledge before hate.

  4. Post #84
    CRAP AT GEOGRAPHY
    Telepethi's Avatar
    June 2005
    6,285 Posts
    Tiberium is a scripted entity, scripted entities is where it goes.

  5. Post #85
    Gold Member
    Kialtia's Avatar
    April 2009
    2,187 Posts
    I think i have an idea on how to reduce lag, i can make Tiberium crystals "retire", so that if they can't grow another crystal within lets say 2 minutes it stops trying to grow completely, however it does get a boost to the maximum amount of Tiberium it can hold (Lets say 1000), what do you guys think?
    Reply With Quote Edit / Delete Reply Netherlands Show Events Agree Agree x 1 (list)

  6. Post #86
    Gold Member
    Jeffman12's Avatar
    July 2005
    467 Posts
    Do it, anything to improve upon its function.

  7. Post #87
    scratch (nl)'s Avatar
    January 2010
    9,519 Posts
    I think i have an idea on how to reduce lag, i can make Tiberium crystals "retire", so that if they can't grow another crystal within lets say 2 minutes it stops trying to grow completely, however it does get a boost to the maximum amount of Tiberium it can hold (Lets say 1000), what do you guys think?
    that's what lynix did too for the biggest part, that's the fact why i don't like the lynix version... (for a big part)

    jack's idea did sound pretty too, when 3 crystals are near eachother they form 1 larger crystal, making 3 entities to 1 (lets say, a field of 60 crystals, when they all change from 3 to 1 entitie/crystal you only have 20 left)

  8. Post #88
    Gold Member
    Jeffman12's Avatar
    July 2005
    467 Posts
    But wouldn't they need to constantly check to tell if they can form a larger crystal, causing more lag?
    Given there's a solution to it, that's not such a bad idea. It would let a field spread more with less entities and bring back the neat look in TS of larger crystals towards the center of the field.

    that's what lynix did too for the biggest part, that's the fact why i don't like the lynix version... (for a big part)
    Wait, what? As I recall it just stopped growing past the set amount, there wasn't anything else to it.
    Reply With Quote Edit / Delete Reply United States Show Events Agree Agree x 1 (list)

  9. Post #89
    Gold Member
    Kialtia's Avatar
    April 2009
    2,187 Posts
    If i would to merge 3 crystals into 1 (Still drawing a total of 3 crystals) i would still have to preform the same checks every think, the lag would be just about the same (Might lag a tiny bit less due to source also updating the entities) but it would require me to completely recode the Tiberium crystals.

  10. Post #90
    jack254's Avatar
    January 2010
    1,385 Posts
    oh when i meant it shouldent be under entities, i meant this thread should be under lua releases, not lua releases\scripted entities

  11. Post #91
    LokiSan's Avatar
    July 2008
    795 Posts
    oh when i meant it shouldent be under entities, i meant this thread should be under lua releases, not lua releases\scripted entities
    Tiberium is a scripted entity. This is exactly where it should be.

  12. Post #92
    HanBammer's Avatar
    May 2009
    88 Posts
    Tiberium is a scripted entity. This is exactly where it should be.
    I agree, and kialtia, how goes progress on different missile types? Maybe a factory ent to make it?

  13. Post #93
    Gold Member
    Kialtia's Avatar
    April 2009
    2,187 Posts
    I agree, and kialtia, how goes progress on different missile types? Maybe a factory ent to make it?
    I am currently working on a factory.

  14. Post #94
    Gold Member
    Kialtia's Avatar
    April 2009
    2,187 Posts
    I just committed the factory, currently it is using a SBEP prop but my modeler is working on a new model that should be completed soon, the factory only spawns a single prop as example, tell me what you guys think about it so far.

  15. Post #95
    Gold Member
    Kialtia's Avatar
    April 2009
    2,187 Posts
    More updates released to the Factory, this will be the last update for a week orso, i am going on a vacation, cya guys then.

  16. Post #96
    HanBammer's Avatar
    May 2009
    88 Posts
    More updates released to the Factory, this will be the last update for a week orso, i am going on a vacation, cya guys then.
    See ya, does the factory still use an SBEP model? I dont have SBEP.

  17. Post #97
    Gold Member
    Kialtia's Avatar
    April 2009
    2,187 Posts
    See ya, does the factory still use an SBEP model? I dont have SBEP.
    No, i included the new model, the collisions are fucked up atm however, if anyone knows how to fix it refer to this thread : http://www.facepunch.com/showthread.php?t=931142

  18. Post #98
    Balduran's Avatar
    May 2008
    361 Posts
    No, i included the new model, the collisions are fucked up atm however, if anyone knows how to fix it refer to this thread : http://www.facepunch.com/showthread.php?t=931142
    I'll fix that eventually. Worst case scenario i'll make it completelty flat.
    Also, warrior is going to be AFK for about a week.

  19. Post #99
    Dj Reflex's Avatar
    March 2010
    312 Posts
    Why isnt tortoise svn working for me? Doesnt it work for vista?
    I mean, I installed it correctly and all but when I open the context menu I see nothing that has to do with tortoise svn :P

  20. Post #100
    LokiSan's Avatar
    July 2008
    795 Posts
    Why isnt tortoise svn working for me? Doesnt it work for vista?
    I mean, I installed it correctly and all but when I open the context menu I see nothing that has to do with tortoise svn :P
    It works fine in vista, just remember to restart your computer before you go trying to use Trotoise =p.

    The option should be "svn checkout".

  21. Post #101
    scratch (nl)'s Avatar
    January 2010
    9,519 Posts
    My factory only can make a tiberium harvester (medium) does everyone else have that too? (just wanna know so i know if something failed or just because it isn't done yet)

  22. Post #102
    BloodyRain's Avatar
    February 2010
    11 Posts
    About the script checks that cause lag, isn't it possible to add a little delay in there so it doesn't check 10 times a sec but only 1 time a sec?

  23. Post #103
    Sjogras's Avatar
    July 2009
    75 Posts
    I'm using svn, and the addon isn't wroking, it's giving errors constantly during a game or when I spawn a tib.

  24. Post #104
    LokiSan's Avatar
    July 2008
    795 Posts
    I'm using svn, and the addon isn't wroking, it's giving errors constantly during a game or when I spawn a tib.
    What error? ctrl+v

  25. Post #105
    Gold Member
    Kialtia's Avatar
    April 2009
    2,187 Posts
    My factory only can make a tiberium harvester (medium) does everyone else have that too? (just wanna know so i know if something failed or just because it isn't done yet)
    The factory is not done, i only added the harvester to test it with.

    Edited:

    Also, i am only temoarly online, i am still away from home for another ~3 days.

  26. Post #106

    November 2005
    66 Posts
    I'm a bit curious.
    You only required RD2 for this right? Not Life Support 2?

  27. Post #107
    Gold Member
    Kialtia's Avatar
    April 2009
    2,187 Posts
    I'm a bit curious.
    You only required RD2 for this right? Not Life Support 2?
    Life Support 2 is not needed.

  28. Post #108
    Sjogras's Avatar
    July 2009
    75 Posts
    Timer Error: autorun/server/sv_wtiberium.lua:117: attempt to call global 'DamageInfo' (a table value)

    entities/wtib_tiberium_base/init.lua:94: attempt to call global 'DamageInfo' (a table value)

    Are the two errors. The first one keeps going on and on the whole game session. The second only happens when I spawn tib.

  29. Post #109
    LokiSan's Avatar
    July 2008
    795 Posts
    I think the latest update broke a huge chunk of addons, including this.

  30. Post #110
    Gold Member
    Kialtia's Avatar
    April 2009
    2,187 Posts
    I am back from vacation so i'll check out what is wrong.

  31. Post #111
    Gold Member
    Kialtia's Avatar
    April 2009
    2,187 Posts
    Timer Error: autorun/server/sv_wtiberium.lua:117: attempt to call global 'DamageInfo' (a table value)

    entities/wtib_tiberium_base/init.lua:94: attempt to call global 'DamageInfo' (a table value)

    Are the two errors. The first one keeps going on and on the whole game session. The second only happens when I spawn tib.
    Works fine for me.

  32. Post #112
    Sjogras's Avatar
    July 2009
    75 Posts
    Well, I reinstalled it 3 times so far, still keep getting that so, just get the orginal?

  33. Post #113
    Gold Member
    Kialtia's Avatar
    April 2009
    2,187 Posts
    Well, I reinstalled it 3 times so far, still keep getting that so, just get the orginal?
    What original, also do this in your console and give me the results :

    Code:
    lua_run print(DamageInfo())

  34. Post #114
    Sjogras's Avatar
    July 2009
    75 Posts
    > print(DamageInfo())...
    :1: attempt to call global 'DamageInfo' (a table value)

  35. Post #115
    Gold Member
    Kialtia's Avatar
    April 2009
    2,187 Posts
    Whoeps, i mean this :

    lua_run print(DamageInfo)

    And also post this result :

    lua_run PrintTable(DamageInfo)

    Also, i've updated the factory again.

  36. Post #116
    Sjogras's Avatar
    July 2009
    75 Posts
    > PrintTable(DamageInfo)...
    FallMultiplier = 100
    FallModeVarName = sm_falldamage_mode
    MaxFallScale = 1300
    MinFallVelocity = 1800

  37. Post #117
    Gold Member
    Kialtia's Avatar
    April 2009
    2,187 Posts
    > PrintTable(DamageInfo)...
    FallMultiplier = 100
    FallModeVarName = sm_falldamage_mode
    MaxFallScale = 1300
    MinFallVelocity = 1800
    Well that shouldn't happen, or you've got an older version of GMod (Pirated?) or you've got an addon that is fucking shit up.

  38. Post #118
    Sjogras's Avatar
    July 2009
    75 Posts
    No no no, I bought GMod, I would never even think of ever stealing a game, what addons would you think would mess with it?
    Reply With Quote Edit / Delete Reply United States Show Events Disagree Disagree x 1 (list)

  39. Post #119
    Gold Member
    Kialtia's Avatar
    April 2009
    2,187 Posts
    No no no, I bought GMod, I would never even think of ever stealing a game, what addons would you think would mess with it?
    I have no idea, post your addon list.

  40. Post #120

    September 2009
    97 Posts
    I got an error when using the tib power plant. and I am using the latest revision.


    Code:
    entities/wtib_powergen_medium/init.lua:67: attempt to call method 'GetTypeString' (a nil value)