1. Post #721
    Gold Member
    hamberglar's Avatar
    April 2005
    2,928 Posts
    Ah what the shit
    Now with music:
    Reply With Quote Edit / Delete United States Show Events Funny Funny x 6 (list)

  2. Post #722
    Gold Member
    Metroid48's Avatar
    February 2007
    1,007 Posts
    The ending is much better with music. Music sells it really.

    Edited:

    Perfect for watching at nearly 1 AM!
    Reply With Quote Edit / Delete Canada Show Events Friendly Friendly x 1Agree Agree x 1Funny Funny x 1 (list)

  3. Post #723
    Gold Member
    hamberglar's Avatar
    April 2005
    2,928 Posts
    I'll be the guy that makes scary videos with the filmmaker. That'll be my thing. Yeah. That's it.

    EDIT

    Um.. I seem to be having some sort of trouble..

    I'm sure most of you know there's supposed to be doors and a some lockers and stuff. Well even more of you probably notice that they.. Uh.. Aren't there. Puppets don't show up either.

    It only happens when I'm looking through the work camera or active camera. If I'm running around as a player, everything is fine.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  4. Post #724
    Gold Member
    Metroid48's Avatar
    February 2007
    1,007 Posts
    Silly question, but you have made at least one recording that included "record world," right?

    Edit: Oh, you can still see puppets from the player cam? Not sure then. Ignore this.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  5. Post #725
    Gold Member
    Darkomni's Avatar
    August 2007
    2,370 Posts
    Right click your screen.

    There should be two menu thingies, one saying "Draw recorded entities" and "draw game entities". Go to draw recorded entities and check off the bottom/top three, I forget which.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  6. Post #726
    Gold Member
    hamberglar's Avatar
    April 2005
    2,928 Posts
    Right click your screen.

    There should be two menu thingies, one saying "Draw recorded entities" and "draw game entities". Go to draw recorded entities and check off the bottom/top three, I forget which.
    And that fixed it. Thanks man.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  7. Post #727
    Gold Member
    Darkomni's Avatar
    August 2007
    2,370 Posts
    im just awesome like that :c00lbert:
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  8. Post #728
    Gold Member
    hamberglar's Avatar
    April 2005
    2,928 Posts
    im just awesome like that :c00lbert:
    Indeed you are.

    Reply With Quote Edit / Delete United States Show Events Artistic Artistic x 1 (list)

  9. Post #729
    OrangeL's Avatar
    January 2010
    68 Posts
    I hate this...
    I can use this tool so well, but I have NO IDEAS! Like, no creativity whatsoever.... Hm...
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  10. Post #730
    Gold Member
    Markntosh's Avatar
    April 2008
    2,963 Posts
    Is anybody else having this problem where, when you transform a camera to make it move, it does so from the origin of the map? I can't get mine to work properly.

    I also don't have the phenomes for characters that was shown in the 4th tutorial.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  11. Post #731
    Gold Member
    Metroid48's Avatar
    February 2007
    1,007 Posts
    Haven't had the first issue, though I have had really odd transitions if I try to paste the new position (with falloff) instead of animating it manually.

    One the second issue, I believe the phenomes vary depending on if you're using HWM models or not.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  12. Post #732
    Gold Member
    hamberglar's Avatar
    April 2005
    2,928 Posts
    I'm so far behind everybody else.
    Reply With Quote Edit / Delete United States Show Events Funny Funny x 4 (list)

  13. Post #733
    OrangeL's Avatar
    January 2010
    68 Posts
    Is anybody else having this problem where, when you transform a camera to make it move, it does so from the origin of the map? I can't get mine to work properly.

    I also don't have the phenomes for characters that was shown in the 4th tutorial.
    (You can click on my name in the quote to see the whole tutorial)
    ____VV(here)
    13) The camera will reset itself to 0X 0Y 0Z on the map. Move it to where you want it to be for the waypoint. This may be a little time consuming if your scene is far away from 0 0 0.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  14. Post #734
    Gold Member
    TheDKer's Avatar
    September 2008
    1,587 Posts
    Another much easier way is to extend the animation thing so it's green. Then simply click you camera once in the engine preview window and it'll stick to that position for as as long as you made the animation thing.

    .........Green square above^
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Denmark Show Events

  15. Post #735
    Gold Member
    Markntosh's Avatar
    April 2008
    2,963 Posts
    (You can click on my name in the quote to see the whole tutorial)
    ____VV(here)
    Ah, thanks. I'll try that.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  16. Post #736
    Gold Member
    TheDKer's Avatar
    September 2008
    1,587 Posts
    Does that thing have a name cause i'm really tired of calling it a thing
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Denmark Show Events

  17. Post #737
    Gold Member
    Metroid48's Avatar
    February 2007
    1,007 Posts
    The animation thing? No idea. They use the terms handles and falloff area for its effects but I haven't actually seen the area named. I'd go with time selection/selector, maybe?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  18. Post #738
    Couple o' ideas:

    Scout exits spawn. (blue)

    Scout goes to battlements. (blue)

    Camera switches to other base. (red)

    One scout goes out and exits the camera screen, then all of a sudden what appears to be a mass of scouts runs out and goes to the battlements. (red)

    Camera goes to battlements at the lone scout's face. He's all "D:" as the millions of scouts race across the bridge in 2fort to rape his face. (red)

    Then a heavy is shown and goes "Is good time to run cowards" and everyone just explodes.

    The end.



    Second idea:

    Red pyro is in lose animation with spies running after him. They proceed to corner him by spycrabbing, which then they feast on him.

    Then comes along the odd scout.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United Kingdom Show Events

  19. Post #739
    effin's Avatar
    April 2010
    9 Posts
    Couple o' ideas:

    Scout exits spawn. (blue)

    Scout goes to battlements. (blue)

    Camera switches to other base. (red)

    One scout goes out and exits the camera screen, then all of a sudden what appears to be a mass of scouts runs out and goes to the battlements. (red)

    Camera goes to battlements at the lone scout's face. He's all "D:" as the millions of scouts race across the bridge in 2fort to rape his face. (red)

    Then a heavy is shown and goes "Is good time to run cowards" and everyone just explodes.

    The end.



    Second idea:

    Red pyro is in lose animation with spies running after him. They proceed to corner him by spycrabbing, which then they feast on him.

    Then comes along the odd scout.
    I hate every single person who ends a tf2 video with everyone exploding.

    I hate you so much.
    Reply With Quote Edit / Delete New Zealand Show Events Agree Agree x 2Dumb Dumb x 1 (list)

  20. Post #740
    OrangeL's Avatar
    January 2010
    68 Posts
    I used to use Flash and UT3's editor, which had an animator called "Matinee" (I called it Manatee). Both times my teachers used "Keyframe selector," so I'm guessing Green Box can be the Frame Selector or something.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  21. Post #741
    Gold Member
    TheDKer's Avatar
    September 2008
    1,587 Posts
    I used to use Flash and UT3's editor, which had an animator called "Matinee" (I called it Manatee). Both times my teachers used "Keyframe selector," so I'm guessing Green Box can be the Frame Selector or something.
    Yeah that would be logical, it just doesn't use keyframes, which sucks so much dick.
    I found out you can kinda simulate that by holding down tab and moving the "keyframe selector", and it'll kinda work though.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Denmark Show Events

  22. Post #742
    Gold Member
    Markntosh's Avatar
    April 2008
    2,963 Posts
    Dammit, Premiere Pro is being an ass again and exporting all my video in shit quality. Premiere CS4 is a load of shit, I hope CS5 is better.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  23. Post #743
    Gold Member
    Darkomni's Avatar
    August 2007
    2,370 Posts
    Use virtualdub + xvid codec.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  24. Post #744
    Gold Member
    Markntosh's Avatar
    April 2008
    2,963 Posts
    Use virtualdub + xvid codec.
    That still requires me to put the clips into Premiere to edit. The AVI files exported from Source Filmmaker look fine (except for some slight stretching). They even look fine in Adobe Premiere Pro's preview window, though that may not count for much.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  25. Post #745
    Gold Member
    Darkomni's Avatar
    August 2007
    2,370 Posts
    You don't need to put anything into premiere, you can add audio and string clips together all in SFM.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  26. Post #746
    Gold Member
    hamberglar's Avatar
    April 2005
    2,928 Posts
    You don't need to put anything into premiere, you can add audio and string clips together all in SFM.
    Wait, really? So I've been using Audacity and Windows Movie Maker all this time for no reason?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  27. Post #747
    Gold Member
    Darkomni's Avatar
    August 2007
    2,370 Posts
    Yeah.

    Edited:

    Convert the sound to .wav, put in SFM directory anywhere. Go into SFM. Record anything. Right click the timeline, zoom in. Right click a clip. Press "Add clip", add Audio, name it anything. Open up the clip you added the audio clip to with the arrow at the left side of the timeline. Right click the audio clip you just added, and again, "add clip". Search for your audio file. Once found, press OK and your audio will be right in there, you can manipulate positioning along the timeline, length, pitch, volume, etc. This is best if you want to lipsync, or do anything timed to music.
    Reply With Quote Edit / Delete Canada Show Events Friendly Friendly x 1 (list)

  28. Post #748
    Gold Member
    Markntosh's Avatar
    April 2008
    2,963 Posts
    You don't need to put anything into premiere, you can add audio and string clips together all in SFM.
    I'm completely new to SFM and I'm just trying to get the basics down. I don't really want to go through hell quite yet.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  29. Post #749
    Gold Member
    hamberglar's Avatar
    April 2005
    2,928 Posts
    Yeah.

    Edited:

    Convert the sound to .wav, put in SFM directory anywhere. Go into SFM. Record anything. Right click the timeline, zoom in. Right click a clip. Press "Add clip", add Audio, name it anything. Open up the clip you added the audio clip to with the arrow at the left side of the timeline. Right click the audio clip you just added, and again, "add clip". Search for your audio file. Once found, press OK and your audio will be right in there, you can manipulate positioning along the timeline, length, pitch, volume, etc. This is best if you want to lipsync, or do anything timed to music.
    This will be massively handy. Just as soon as I can figure out how the fuck to facepose.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  30. Post #750
    Ukuku's Avatar
    July 2009
    240 Posts
    This will be massively handy. Just as soon as I can figure out how the fuck to facepose.
    Don't forget that traditional methods apply, too. You can use Source SDK Faceposer for face posing and then rebuild scenes.image, copy the scenes to your TF2 beta and change the <class>.txt in scripts/talker so that it plays your own scene instead of voice commands.

    Just a thought, ask more if you need precise advice.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Finland Show Events

  31. Post #751
    Gold Member
    TheDKer's Avatar
    September 2008
    1,587 Posts
    Dammit, Premiere Pro is being an ass again and exporting all my video in shit quality. Premiere CS4 is a load of shit, I hope CS5 is better.
    Uhh no, you're just doing it wrong. Works fine for me

    Edited:

    no meme intended

    Edited:

    This will be massively handy. Just as soon as I can figure out how the fuck to facepose.
    Pandamobile made some tutorials:

    Edited:

    Just beware, if you've saved your facepose and load it up again you'll not be able to facepose most of the face, only the jaw i think, and maybe a couple other things like nose and eye stuff.
    Reply With Quote Edit / Delete Denmark Show Events Late Late x 1 (list)

  32. Post #752
    Gold Member
    thisguy123's Avatar
    August 2008
    8,480 Posts
    Here is my first crappy attemt at SFM.

    When it exported the end got chopped off but it's still ok..... ish.

    Reply With Quote Edit / Delete United Kingdom Show Events Funny Funny x 6 (list)

  33. Post #753
    Gold Member
    Darkomni's Avatar
    August 2007
    2,370 Posts
    nice WHATer.

    i'm thinking of making the water texture go like 90% slower so it goes at a decent speed for rendering.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  34. Post #754
    Gold Member
    Markntosh's Avatar
    April 2008
    2,963 Posts

    Is it shit? Yah. But it's my first movie, I'm just learning the basics. I like how it turned out, though.
    Reply With Quote Edit / Delete United States Show Events Funny Funny x 5 (list)

  35. Post #755
    Gold Member
    Appolox's Avatar
    December 2008
    3,596 Posts
    Oh God Heavy's final expression made me chuckle.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United Kingdom Show Events

  36. Post #756
    Gold Member
    hamberglar's Avatar
    April 2005
    2,928 Posts


    Pandamobile made some tutorials:

    Edited:

    Just beware, if you've saved your facepose and load it up again you'll not be able to facepose most of the face, only the jaw i think, and maybe a couple other things like nose and eye stuff.
    OK, so I'm trying to follow the tutorial but I've hit a snag. I figure I'll get an answer faster if I post here, rather than on Youtube.

    Basically, I've imported my clip into the SFM, but when I start trying to lip sync, it doesn't make any sound. I haven't done anything different than what was in the video but.. Yeah.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  37. Post #757
    Gold Member
    Darkomni's Avatar
    August 2007
    2,370 Posts
    Woah, how'd you fix the water? It usually doesn't change speed with the rendering time, making it waaaaaaay faster than normal in any render.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  38. Post #758
    Gold Member
    Markntosh's Avatar
    April 2008
    2,963 Posts
    Woah, how'd you fix the water? It usually doesn't change speed with the rendering time, making it waaaaaaay faster than normal in any render.
    If you're talkin' to me, I did nothing different from any of the other clips. Recorded as normal, rendered as normal. Though I did start a brand new file, if that matters, for each shot.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  39. Post #759
    Gold Member
    TheDKer's Avatar
    September 2008
    1,587 Posts
    I think it depends on how many puppets you have. You only had the Scout for the water scenes right Markntosh?
    Also unrelated, i remember you from the Whitehawk productions some time ago, how did that end up?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Denmark Show Events

  40. Post #760
    Gold Member
    Metroid48's Avatar
    February 2007
    1,007 Posts
    You know, if it is due to overlapping water brushes (which can be quickly tested!) then it's probably possible to just remove them with the Dme Element Editor.

    Also, has anyone tried recording a scene in nucleus? I used a console command to extend the bridges, but they didn't show up in the recording.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events