1. Post #1481
    Gold Member

    July 2010
    5,040 Posts
    When i click 'file > export > movie', set my settings, and click export, nothing happens. How can i fix this?
    Make sure to type sv_cheats 1 into the console, export has been known to act oddly with sv_cheats on 0 (which it is by default).
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  2. Post #1482
    Captain Om Nom's Avatar
    January 2010
    792 Posts
    Make sure to type sv_cheats 1 into the console, export has been known to act oddly with sv_cheats on 0 (which it is by default).
    Tried it, still didn't work.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  3. Post #1483
    Croshi's Avatar
    April 2009
    1,750 Posts
    I followed your tutorial, but...

    So close!
    Oh yeah I forgot

    The hats aren't perfectly aligned on their bip_head. Almost all of them, the bip_head are a little above their orgin, so they will be levitating. Just use the animation editor.
    Reply With Quote Edit / Delete United States Show Events Informative Informative x 2 (list)

  4. Post #1484
    Gold Member
    TheDKer's Avatar
    September 2008
    1,587 Posts
    Tried it, still didn't work.
    A picture i made for another guy, but guess it's your case too.


    Edited:

    And what's with all you people telling people to turn on sv_cheats? It works perfectly fine wihtout it.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Denmark Show Events

  5. Post #1485
    Gold Member

    July 2010
    5,040 Posts
    And what's with all you people telling people to turn on sv_cheats? It works perfectly fine wihtout it.
    Sometimes sv_cheats 0 will screw up rendering; it can give you odd export numbers of mess up the render all together. Isn't always needed but it's not a bad idea to turn sv_cheats on.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  6. Post #1486
    wait.. using [color] tags counts towards characters used? fuck. I have like 4 spa
    LasGunz's Avatar
    June 2005
    8,893 Posts
    so do you absolutely need the beta for this or is there a way to run it on regulard tf2? or even something similar or whatever

    this shit looks really fun/funny, i wanna try it out.
    Reply With Quote Edit / Delete United Kingdom Show Events Bad Reading Bad Reading x 1 (list)

  7. Post #1487
    Gold Member
    Razi The Red's Avatar
    June 2010
    1,029 Posts
    Add me on steam, bbcakes.
    Need a name because I thought the last part of that sentence might be the name I was looking for, but I'm afraid not. Might just be easier for you to look up "Goemon Impact".
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  8. Post #1488
    Captain Om Nom's Avatar
    January 2010
    792 Posts
    so do you absolutely need the beta for this or is there a way to run it on regulard tf2? or even something similar or whatever

    this shit looks really fun/funny, i wanna try it out.
    As of right now the only way to run SFM is by obtaining TF2 beta.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  9. Post #1489
    Gold Member
    Vegg's Avatar
    October 2009
    1,716 Posts
    I was told to put this in this thread.

    I probably seem like an idiot for asking this, but I tried to get Source Filmmaker, following this tutorial:

    But after installing the TF2 beta and trying to open it, I get this:
    First this comes up:


    When I click okay, it comes up again, when I click okay, it comes up again, then when I click it again the TF2 window goes away, then this one comes up:


    Then when I click okay on that I'm just on my desktop again.

    I did everything the tutorial said.

    I really want to try out SFM, so if anybody could help, or suggest a better tutorial, that'd be awesome.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  10. Post #1490
    Gold Member
    Darkomni's Avatar
    August 2007
    2,379 Posts
    You forgot to install the patches, or you installed them in the wrong order.

    Edited:

    Need a name because I thought the last part of that sentence might be the name I was looking for, but I'm afraid not. Might just be easier for you to look up "Goemon Impact".
    dude

    the ONE time i don't point to the button under my post count leading to my steam page
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  11. Post #1491
    Gold Member
    Vegg's Avatar
    October 2009
    1,716 Posts
    Okay, I'll try again.

    EDIT:

    Well, I got it working. Sort of.

    When I launch it I get this error message:

    But when I click okay, I can still use the filmmaker:


    And, I can't click the continue button when I load a map, so I can't play:


    Help, again, please.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  12. Post #1492
    Gold Member
    Razi The Red's Avatar
    June 2010
    1,029 Posts
    dude

    the ONE time i don't point to the button under my post count leading to my steam page
    Must be my browser because that never works for me.

    EDIT:
    Swapped over to my laptop and that did the trick.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  13. Post #1493
    Captain Om Nom's Avatar
    January 2010
    792 Posts


    And, I can't click the continue button when I load a map, so I can't play:


    Help, again, please.
    See that "active camera" button? click it, you will start being able to use the camera.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  14. Post #1494
    Ukuku's Avatar
    July 2009
    240 Posts
    And, I can't click the continue button when I load a map, so I can't play.

    On the top-right corner of the window you can see Source Filmmaker: Tool Mode [ F10 - Switch mode ] [ F11 - Full Screen ]

    Just press F10 and F11 to go to fullscreen game mode and it is just like regural TF2.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Finland Show Events

  15. Post #1495
    Gold Member
    Vegg's Avatar
    October 2009
    1,716 Posts
    Just press F10 and F11 to go to fullscreen game mode and it is just like regural TF2.
    Oh, thanks, it worked.
    One more noob question, I saw in a video a guy opened the console and typed the explode command, but I can't open the console, would you happen to know why?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  16. Post #1496
    Captain Om Nom's Avatar
    January 2010
    792 Posts
    Oh, thanks, it worked.
    One more noob question, I saw in a video a guy opened the console and typed the explode command, but I can't open the console, would you happen to know why?
    Is there a "-console" parameter in you TF2 beta shortcut?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  17. Post #1497
    Gold Member
    Vegg's Avatar
    October 2009
    1,716 Posts
    Is there a "-console" parameter in you TF2 beta shortcut?
    No, can I just add one at the end?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  18. Post #1498
    99% More Fail's Avatar
    October 2009
    783 Posts
    ANIMATING A PROP
    0. Type in console 'listmodels' if you do not know the file locations. Not all custom models will come up.
    1. To create a prop, type 'prop_dynamic_create X' (x for the pyro would be player/pyro)
    2. While looking at the model, type in console 'ent_setname name' Name can be anything)
    3. Type 'ent_fire name setanimation X', X being the name of the animation sequence (like 'ent_fire name setanimation taunt06')
    4. Type 'ent_fire name setdefaultanimation x', x being the animation you want the model to return to after you do step 3.
    OPTIONAL: If you want to change the skin of the model, type 'ent_fire name skin <number>', the number being the number of the skin. BLU Pyro would be 'ent_fire

    PARENTING:
    1. To name yourself, type 'ent_fire !self addoutput "targetname me"' (you can change me to anything, but me is the easiest and shortest)
    2. To actually parent the prop to yourself, type 'ent_fire name setparent me'. If you want to attach the prop to another prop, replace me with the name of the parent prop.
    3. This is an important step if you are parenting to yourself. 'ent_fire name disablecollision' This will make the prop not collide with you. If you do not do this, you will not be able to move.
    4. This is another important step. 'ent_fire name setparentattachment attachment X' Look at Source SDK, in the tab for 'attachments', on the left column you can see what you can set the attachment for the parent. For TF2 models, the attachments are 'head', 'flag', and 'partyhat'. If you do not do this, the prop will just be attached to you in whatever angle you were in while you parented it.

    I hope this is more informative.
    I keep trying to use prop_dynamic_create, but whatever I use shows up as an error. What am I doing wrong here?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United Kingdom Show Events

  19. Post #1499
    Ukuku's Avatar
    July 2009
    240 Posts
    I keep trying to use prop_dynamic_create, but whatever I use shows up as an error. What am I doing wrong here?
    Make sure the path and filename of the model are right.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Finland Show Events

  20. Post #1500
    Captain Om Nom's Avatar
    January 2010
    792 Posts
    No, can I just add one at the end?
    Yep. -fixed-

    Edited:

    I keep trying to use prop_dynamic_create, but whatever I use shows up as an error. What am I doing wrong here?
    Check to make sure the model exists in TF2 beta, since most of the current TF2 models didn't exist in the beta. Also don't add "models/" to the beginning.
    (Example: props_hydro/barricade)
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  21. Post #1501
    Gold Member
    Vegg's Avatar
    October 2009
    1,716 Posts
    Hey, I added the -console at the end and now I don't get the error message on launch, thanks.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  22. Post #1502
    Captain Om Nom's Avatar
    January 2010
    792 Posts
    Ok i fixed my previous problem, but now i have a new one, I go to my animation set editor so i can lip sync my character but theres no sliders under "Lower Face" (If it helps I'm using the heavy.) What can i do?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  23. Post #1503
    Josher's Avatar
    July 2010
    129 Posts
    Ok i fixed my previous problem, but now i have a new one, I go to my animation set editor so i can lip sync my character but theres no sliders under "Lower Face" (If it helps I'm using the heavy.) What can i do?
    Make sure mp_usehwmmodels and mp_usehwmvcds are both set to 1 before you record.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  24. Post #1504
    Ukuku's Avatar
    July 2009
    240 Posts
    I go to my animation set editor so i can lip sync my character but theres no sliders under "Lower Face" (If it helps I'm using the heavy.) What can i do?
    The regural models have their face sliders under "Unknown".
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Finland Show Events

  25. Post #1505
    Gold Member
    Shounic's Avatar
    May 2010
    1,987 Posts
    The regural models have their face sliders under "Unknown".
    it's only expressions. not lip sync.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Hong Kong Show Events

  26. Post #1506
    Ukuku's Avatar
    July 2009
    240 Posts
    it's only expressions. not lip sync.
    There are all the "AA" "OA" "MB" etc. sliders.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Finland Show Events

  27. Post #1507
    99% More Fail's Avatar
    October 2009
    783 Posts
    Check to make sure the model exists in TF2 beta, since most of the current TF2 models didn't exist in the beta. Also don't add "models/" to the beginning.
    (Example: props_hydro/barricade)
    If I do that it doesn't show up at all. I am using props_gameplay/orange_cone001.mdl, by the way. It definitely exists, I checked and its there. I must be doing something different to everyone else, but I cant put my finger on it.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United Kingdom Show Events

  28. Post #1508
    Gold Member
    AlfieSR's Avatar
    April 2009
    4,970 Posts
    Try removing the .mdl

    prop_dynamic_create props_gameplay/orange_cone001
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United Kingdom Show Events

  29. Post #1509
    wait.. using [color] tags counts towards characters used? fuck. I have like 4 spa
    LasGunz's Avatar
    June 2005
    8,893 Posts
    I'm not asking for it but is it safe to assume that owning the TF2 beta as of now is illegal? Or atleast using this is risky?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United Kingdom Show Events

  30. Post #1510
    Gold Member
    AlfieSR's Avatar
    April 2009
    4,970 Posts
    I'm not asking for it but is it safe to assume that owning the TF2 beta as of now is illegal? Or atleast using this is risky?
    Debatable.
    Using betas after the final has been released is a legal grey area regardless, but Valve doesn't even seem to care that much.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United Kingdom Show Events

  31. Post #1511
    wait.. using [color] tags counts towards characters used? fuck. I have like 4 spa
    LasGunz's Avatar
    June 2005
    8,893 Posts
    If one were to use it though.. would it be advisable to just keep Steam shut off anyway?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United Kingdom Show Events

  32. Post #1512
    Captain Om Nom's Avatar
    January 2010
    792 Posts
    If one were to use it though.. would it be advisable to just keep Steam shut off anyway?
    It doesn't matter, I've been using it with steam open and nothing's happened.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  33. Post #1513
    Gold Member
    Metroid48's Avatar
    February 2007
    1,007 Posts
    Not really. Steam is definitely aware of it, as you can unlock achievements playing the beta, but several people have been using it since it was discovered with Steam running in the background with no issues.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  34. Post #1514
    Gold Member
    Razi The Red's Avatar
    June 2010
    1,029 Posts
    Some of us have simply backed up the beta from back in the day obviously that's how someone came across it.

    The only thing I notice is that it affects TF2's window size when I just want to play. Aside from that there are no other reprecussions I'm aware of.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  35. Post #1515
    wait.. using [color] tags counts towards characters used? fuck. I have like 4 spa
    LasGunz's Avatar
    June 2005
    8,893 Posts
    I'm really thinking about trying this out. I know it's pretty irrational but I'm just so paranoid about my account, I may just keep Steam shut off anyway while using it.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United Kingdom Show Events

  36. Post #1516
    Gold Member
    AlfieSR's Avatar
    April 2009
    4,970 Posts
    You won't lose your Steam account, Valve really doesn't care.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United Kingdom Show Events

  37. Post #1517
    Gold Member
    TheDKer's Avatar
    September 2008
    1,587 Posts
    I'm really thinking about trying this out. I know it's pretty irrational but I'm just so paranoid about my account, I may just keep Steam shut off anyway while using it.
    I've had SFM since January and i've always had Steam open when using SFM, and nothing has happened to my account.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Denmark Show Events

  38. Post #1518
    OrangeL's Avatar
    January 2010
    68 Posts
    I still can't get hats to work... BLARGH! I mean I could spawn it but I can't parent it to myself. Do my crosshairs have to be on it the whole time?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  39. Post #1519
    Gold Member

    July 2010
    5,040 Posts
    I'm really thinking about trying this out. I know it's pretty irrational but I'm just so paranoid about my account, I may just keep Steam shut off anyway while using it.
    I use it with Steam both on and off. I know due to the console that when Steam is on, SFM will connect to your Steam account and VAC, which can cause you to gain achievements or mess up your video settings for regular TF2. There aren't really any consequences past that though, and even Robin has at times given praise to work done in SFM. You should be safe.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  40. Post #1520
    Gold Member
    Jojje's Avatar
    January 2005
    6,680 Posts

    sneak preview of my latest shit ajfdshsdf
    i had to halt production cuz i accidentally hit escape and the hud disappeared and i couldn't switch class

    i have to redo the cameras anyway they're a bit stiff

    also they look like they run faster than usual in the beginning dunno whats up with that
    Reply With Quote Edit / Delete Show Events Artistic Artistic x 1Bad Spelling Bad Spelling x 1 (list)