1. Post #1601
    Gold Member
    Jojje's Avatar
    January 2005
    6,653 Posts
    How to make moving cameras.
    and
    How you kill your other recorded selves.

    Now explain this voodoo magic to me, pretty please.
    well the way I did it was to make bots with bot -team red -class heavyweapons as an example and bot_teleport to put them where I wanted. Get the teleport arguments with getpos

    then bot_forcefireweapon tf_weapon_minigun to get the heavy to shoot

    a good example of the above is the part where he gets headshotted, that was a bot i shot
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Sweden Show Events

  2. Post #1602
    :-)
    Phycosymo's Avatar
    December 2007
    4,384 Posts
    So youtube finally uploaded my first SFM video.
    Reply With Quote Edit / Delete United States Show Events Late Late x 1Informative Informative x 1 (list)

  3. Post #1603
    Gold Member
    Shounic's Avatar
    May 2010
    1,987 Posts
    Okay, since a complete noob at this I want to know 2 things:

    How to make moving cameras.
    and
    How you kill your other recorded selves.

    Now explain this voodoo magic to me, pretty please.
    look at pandamobile's tutorials, and be a tad more polite next time.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Hong Kong Show Events

  4. Post #1604
    The King Of Zing
    minilandstan's Avatar
    September 2009
    12,766 Posts
    Does anyone have the answer to my question?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  5. Post #1605
    Gold Member
    Razi The Red's Avatar
    June 2010
    1,027 Posts
    Okay, since a complete noob at this I want to know 2 things:

    How to make moving cameras.
    and
    How you kill your other recorded selves.
    Bind "kill" or "explode" to a key and kill yourself with it.

    Does anyone have the answer to my question?
    The only idea I have is that you mistyped the line you needed to add somehow.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  6. Post #1606
    The King Of Zing
    minilandstan's Avatar
    September 2009
    12,766 Posts
    I copied and pasted from the wiki.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  7. Post #1607
    Gold Member
    big_brother's Avatar
    October 2005
    157 Posts
    mini, is it possible you didn't install the engine tools in the bin folder, that's what I did wrong the first time ._.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  8. Post #1608
    The King Of Zing
    minilandstan's Avatar
    September 2009
    12,766 Posts
    Alright...nothing different.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  9. Post #1609
    Rig
    Rig's Avatar
    March 2010
    27 Posts
    Alright...nothing different.
    You sure it was Team Fortress 2\bin and not Team Fortress 2\tf\bin?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  10. Post #1610
    The King Of Zing
    minilandstan's Avatar
    September 2009
    12,766 Posts
    Yeah.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  11. Post #1611

    October 2009
    23 Posts
    Man that's awesome. Might help me in my future projects. I just thought the animation would fuck up in some weird way cause their rigs aren't identical.
    more like we should all get together and make one video. I am still practicing my animation skill so i dont mind animating more characters (esp fighting scene). Time to talk !!!! how about a meet-the-team kinda scene ?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  12. Post #1612
    Gold Member
    Pandamobile's Avatar
    January 2009
    3,519 Posts
    Does anyone know if SFM runs in a more stable condition on different OS's? Mine starts to leak and crash after I record more than 5 or 6 puppets, or record more than 30-40 seconds of a single puppet, which really limits what I can do.

    I'm on Windows 7 64 bit. Does anyone know if it runs any better on say 32 bit XP or something?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  13. Post #1613
    Gold Member
    Razi The Red's Avatar
    June 2010
    1,027 Posts
    Does anyone know if SFM runs in a more stable condition on different OS's? Mine starts to leak and crash after I record more than 5 or 6 puppets, or record more than 30-40 seconds of a single puppet, which really limits what I can do.

    I'm on Windows 7 64 bit. Does anyone know if it runs any better on say 32 bit XP or something?
    Actually SFM has been working MARVELLOUSLY lately, I managed about 6 hours of messing around with it before I saved and went off to do other things Sunday.

    I use Vista 32 bit and my latest project has 13 bots and 1 puppet (which is used in conjunction with the bots across like 20-30 clips?).

    I know I definitely have sequences longer than 30-40 seconds, but still: no problems.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  14. Post #1614
    Gold Member
    Markntosh's Avatar
    April 2008
    2,963 Posts
    I have no problems with SFM on Windows 7 64-bit.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  15. Post #1615
    wait.. using [color] tags counts towards characters used? fuck. I have like 4 spa
    LasGunz's Avatar
    June 2005
    8,893 Posts
    I have no problems with SFM on Windows 7 64-bit.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United Kingdom Show Events

  16. Post #1616
    Gold Member
    TheDKer's Avatar
    September 2008
    1,587 Posts
    On Vista 32-bit
    I've noticed that if my saves are over 60 mb in size, they'll crash SFM. I can record +60 secs, though it'll crash shortly after. I don't have alot of crashes actually.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Denmark Show Events

  17. Post #1617
    Gold Member
    Markntosh's Avatar
    April 2008
    2,963 Posts
    My SFM is fairly crash-resistant. It has some other weird glitches an issues, but overall it's pretty stable.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  18. Post #1618
    Gold Member
    tomoom165's Avatar
    March 2009
    1,592 Posts
    So youtube finally uploaded my first SFM video.
    dude wat
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  19. Post #1619
    Ukuku's Avatar
    July 2009
    240 Posts
    On Vista 32-bit
    I've noticed that if my saves are over 60 mb in size, they'll crash SFM. I can record +60 secs, though it'll crash shortly after. I don't have alot of crashes actually.
    The .dmx file of my "We need a dispenser right here." is 204 mb big.

    You can cut down the size of the files by removing unneeded props with the DME Element Editor. Just go to session - clipBin - sequence - subClipTrackGroup - tracks - Film - children - shot - scene - children - and there you can remove anything you want.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Finland Show Events

  20. Post #1620
    Any way I can fix the heavy's mini-gun particle
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Australia Show Events

  21. Post #1621
    Gold Member
    Shounic's Avatar
    May 2010
    1,987 Posts
    Any way I can fix the heavy's mini-gun particle
    use a bot. it's demonstrated in "making of amazing kill streak."
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Hong Kong Show Events

  22. Post #1622
    Bah i hate bots
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Australia Show Events

  23. Post #1623
    Ukuku's Avatar
    July 2009
    240 Posts
    Bah i hate bots
    It is the only way. Valve hasn't even fixed the bug in later builds of TF2.

    Unless you set up Hamachi and get some people to assist you.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Finland Show Events

  24. Post #1624
    Gold Member
    TheDKer's Avatar
    September 2008
    1,587 Posts
    The .dmx file of my "We need a dispenser right here." is 204 mb big.

    You can cut down the size of the files by removing unneeded props with the DME Element Editor. Just go to session - clipBin - sequence - subClipTrackGroup - tracks - Film - children - shot - scene - children - and there you can remove anything you want.
    I am aware of that and i do it all the time. Can you open that 204 mb save?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Denmark Show Events

  25. Post #1625
    Ukuku's Avatar
    July 2009
    240 Posts
    I am aware of that and i do it all the time. Can you open that 204 mb save?
    Yeah, it opens. It just takes a long time of hl2.exe not responding.

    It is very unstable,though.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Finland Show Events

  26. Post #1626
    Gold Member
    Razi The Red's Avatar
    June 2010
    1,027 Posts
    Yeah, it opens. It just takes a long time of hl2.exe not responding.

    It is very unstable,though.
    From what I've done with that kind of stuff (i.e big files) it seems like opening SFM, loading the level the saved scene takes place on, and THEN choosing to open the scene makes it work more often.

    Only had the "Not responding" bug happen to me once doing that.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  27. Post #1627
    Croshi's Avatar
    April 2009
    1,749 Posts
    doo dooo dooooo snip
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  28. Post #1628
    Gold Member
    Pandamobile's Avatar
    January 2009
    3,519 Posts
    You should probably snip that.

    On topic, does anyone know how to get a file from Maya 2011 into 2009.

    I'm trying to do some Motionbuilder animations, but I'm stuck in a loop. When I export FBX files from MotionBuilder 2011, I can't open them in Maya 2009. They work fine in Maya 2011, but the Source Engine plugins do not.

    Anyone know?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  29. Post #1629
    Reemix's Avatar
    January 2010
    245 Posts
    get 2010! :x
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  30. Post #1630
    Gold Member
    Pandamobile's Avatar
    January 2009
    3,519 Posts
    get 2010! :x
    MotionBuilder 2010?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  31. Post #1631
    Gold Member
    Jojje's Avatar
    January 2005
    6,653 Posts
    Hey, I replaced some .vcd's and such and it works good but the actors have the constant angry expression on. How do I get rid of that, anyone know?
    I made the flexes in the .vcd itself because it was easier
    Maybe I just have to bite the bullet and make the flexes in-game again
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Sweden Show Events

  32. Post #1632
    OrangeL's Avatar
    January 2010
    68 Posts
    Sigh... just got Maya 2011 only to realize that the source plugins only work on 2009 or below... well back to the "store..."
    Reply With Quote Edit / Delete United States Show Events Dumb Dumb x 1 (list)

  33. Post #1633
    HCallahan's Avatar
    June 2010
    5 Posts
    Hey, I replaced some .vcd's and such and it works good but the actors have the constant angry expression on. How do I get rid of that, anyone know?
    Try hitting the red circle near the top (not the regular record, but the animation record), select your section, highlight the Upper and Mid Face in your Animation set editor (if you've made one for your character), and use the "Default" slider. That should return your character's expression to the blank default face.

    Picture below


    Reply With Quote Edit / Delete United States Show Events Useful Useful x 1 (list)

  34. Post #1634
    Gold Member
    -Vista's Avatar
    August 2009
    383 Posts

    I fail at lip syncing, could have done with a better sound file too. :smith:
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United Kingdom Show Events

  35. Post #1635
    Josher's Avatar
    July 2010
    129 Posts
    nvm
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  36. Post #1636
    Gold Member
    Jojje's Avatar
    January 2005
    6,653 Posts
    Try hitting the red circle near the top (not the regular record, but the animation record), select your section, highlight the Upper and Mid Face in your Animation set editor (if you've made one for your character), and use the "Default" slider. That should return your character's expression to the blank default face.

    Picture below


    Yeah, I know about that, but I would expect that to reset all the flexes from the .vcd, but oh well, I guess I'll have to remake 'em.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Sweden Show Events

  37. Post #1637
    Gold Member
    Darkomni's Avatar
    August 2007
    2,370 Posts

    200 subscribers :froggonk:

    also filler video for my bigger stuff lol
    Reply With Quote Edit / Delete Canada Show Events Funny Funny x 2 (list)

  38. Post #1638
    primaryartemis's Avatar
    June 2009
    12 Posts
    BTW an idea, for timing explosions with puppets and so on couldn't you use the slow down time method that you use with camera work to give you more time to line it up?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  39. Post #1639
    Gold Member
    lew06's Avatar
    October 2006
    1,171 Posts
    My first SFM video, and also my apologies (And thanks to helping me) to Darkomni for asking you so much:


    The SFM amuses me.
    Reply With Quote Edit / Delete United Kingdom Show Events Funny Funny x 1Optimistic Optimistic x 1 (list)

  40. Post #1640
    Gold Member
    Cl0ud's Avatar
    May 2005
    100 Posts
    Hey, I replaced some .vcd's and such and it works good but the actors have the constant angry expression on. How do I get rid of that, anyone know?
    I made the flexes in the .vcd itself because it was easier
    Maybe I just have to bite the bullet and make the flexes in-game again
    there's a default vcd that always plays to make the char look angry, find it and delete it. its one that has no voice in it.

    Edited:

    Try hitting the red circle near the top (not the regular record, but the animation record), select your section, highlight the Upper and Mid Face in your Animation set editor (if you've made one for your character), and use the "Default" slider. That should return your character's expression to the blank default face.
    It's better to drag the upper angry slider all the way to the left.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United Kingdom Show Events