1. Post #1761
    Gold Member
    AlfieSR's Avatar
    April 2009
    4,950 Posts
    It's the $detail line in the VMT file.
    Remove it, it's for Jarate.
    Reply With Quote Edit / Delete United Kingdom Show Events Useful Useful x 1 (list)

  2. Post #1762
    Gold Member
    Shounic's Avatar
    May 2010
    1,987 Posts
    and make sure the VTF tpye is 2.0 or below? i think. can't remember.
    Reply With Quote Edit / Delete Hong Kong Show Events Useful Useful x 1 (list)

  3. Post #1763
    sometimes I feel like going into a spastic rage so I can get a cool title but then it would be a bad title, and it wouldnt be cool
    VenomousBeetle's Avatar
    January 2010
    14,435 Posts
    Ill be sure to try that, thanks a ton!

    Edited:

    Did you literally mean $detail?

    this is all thats in the file for me:

    Code:
    VertexLitGeneric
    {
    	"$basetexture" "models\player\spy\stylish_spy_red"
    	"$bumpmap" "models/player/spy/stylish_spy_normal"
    	// Cloaking
    	"$cloakPassEnabled" "1"
    	"Proxies"
    	{
    		"vm_invis"
    		{
    		}
    		"ModelGlowColor"
    		{
    			"resultVar" "$glowcolor"
    		}
    		"Equals"
    		{
    			"srcVar1"  "$glowcolor"
    			"resultVar" "$selfillumtint"
    		}
    		"Equals"
    		{
    			"srcVar1"  "$glowcolor"
    			"resultVar" "$color2"
    		}
    	}
    }
    Edited:

    and make sure the VTF tpye is 2.0 or below? i think. can't remember.
    It should be fine, considering some of the newest textures work fine, such as lever rifle.

    It's the damned vmt stuff. Only on player models.

    I expected it to be something there, but not sure which to remove, and dont plan on removing something to make it worse, so you guys have any idea?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  4. Post #1764
    sometimes I feel like going into a spastic rage so I can get a cool title but then it would be a bad title, and it wouldnt be cool
    VenomousBeetle's Avatar
    January 2010
    14,435 Posts
    If you dont know how, at least bump this so someone who does see's it.

    Edited:

    Oh well there we go
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  5. Post #1765

    October 2009
    23 Posts
    Black Playermodels and Hats

    This is due to the introduction of Jarate. To fix this, you need to remove every instance of

    "$yellow" "0"

    within the playermodels' .vmt files in root/tf/materials/models/player/<class>/ (where root is the root folder of your SFM directory). You can do this using Notepad. The files that have the line are:

    * <class>_blue.vmt
    * <class>_red.vmt
    * <class>_head_blue.vmt
    * <class>_head_red.vmt

    You will need to do this for all 9 classes. The same bug exists for all hats - find the hat's individual vmt, most likely located in root/tf/materials/models/player/items/<class>, and remove that same line.




    source origin:
    http://sourcefilmmaker.wikia.com/wik...d_Other_things
    Reply With Quote Edit / Delete Canada Show Events Friendly Friendly x 1 (list)

  6. Post #1766
    sometimes I feel like going into a spastic rage so I can get a cool title but then it would be a bad title, and it wouldnt be cool
    VenomousBeetle's Avatar
    January 2010
    14,435 Posts
    Uh there isnt a $yellow in the thing I posted.'

    and only custom models do that.


    I think you guys dont understand me now.

    Edited:

    Okay, found one in my heavy vmt. but cant seem to find it in my Stylish spy one.

    Edited:

    Yeah that fixed it. Now about the spy..
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  7. Post #1767
    sometimes I feel like going into a spastic rage so I can get a cool title but then it would be a bad title, and it wouldnt be cool
    VenomousBeetle's Avatar
    January 2010
    14,435 Posts
    Dont let this thread fall far.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  8. Post #1768
    Gold Member
    Metroid48's Avatar
    February 2007
    1,007 Posts
    Okay, found one in my heavy vmt. but cant seem to find it in my Stylish spy one.
    You're looking at tf/materials/models/player/stylish/stylish_spy_red.vmt when you should be looking at tf/materials/models/player/spy/stylish_spy_red.vmt. The correct file is something like twice as long as the one you're posting.
    Reply With Quote Edit / Delete Canada Show Events Useful Useful x 3 (list)

  9. Post #1769
    sometimes I feel like going into a spastic rage so I can get a cool title but then it would be a bad title, and it wouldnt be cool
    VenomousBeetle's Avatar
    January 2010
    14,435 Posts
    You're looking at tf/materials/models/player/stylish/stylish_spy_red.vmt when you should be looking at tf/materials/models/player/spy/stylish_spy_red.vmt. The correct file is something like twice as long as the one you're posting.
    Oh I see. BRB gotta try.

    Edited:

    That did it,

    Edited:

    For about everyone on this page but me
    Reply With Quote Edit / Delete United States Show Events Useful Useful x 1 (list)

  10. Post #1770
    Natalia's Avatar
    August 2010
    6 Posts
    I have two sound files made by me with the same characteristics: 16 bit PCM 44100 Hz wav.
    I placed phonemes into both files by faceposer, but the first file I made a year ago, and the second today. Both files excellent play with faceposer.
    I replaced two sound files of tf2 beta (scout_thanks01.wav and scout_thanks02.wav) with my files. And when I use voicemenu (Z+2), my scout says all phonemes during the playback of my first sound file and none phonemes during the playback of the second sound file :(

    Any suggestions? I restarted the game ten thousand times and made ten thousand records, but one file playes fine and the second without phonemes though they present in the file.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Russian Federation Show Events

  11. Post #1771
    Ukuku's Avatar
    July 2009
    240 Posts
    Problem - Any suggestions?
    Make own sound files and custom .vcds for the sounds and edit "Response PlayerThanksScout" in tf/scripts/talker/Scout.txt to use your vcd instead, i.e. comment out stock lines (add // before them) and add "scene "scenes/customsound01.vcd"" after them.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Finland Show Events

  12. Post #1772
    milesaaway's Avatar
    September 2010
    28 Posts
    a friend gave me his USB with the thing, but AVG detected RUN_TF2.exe as a virus. is that real?
    i would think it was due to the way it was no-steam patched, or the compression used on it, that it would flag up like that, certain A/Vs flag up at certain ways of compressing EXE's.

    EDIT: Well, it's not compressed, but it's coded weird, that's might what might be doing it.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United Kingdom Show Events

  13. Post #1773
    Gold Member
    Razi The Red's Avatar
    June 2010
    1,027 Posts
    Am I the only person who things animating non character props is a pain in the ass? Perhaps there's a method to easing that pain I overlooked? Would spawining a dynamic prop and then recording in scene along with whatever else make it easier to move/animate/whatever?

    It always seems jerky and certainly doesn't seem to move around right.

    Example: I was working with a Sniper gib I spawned earlier and I wanted it to fall into the shot on to the character's feet and then have him kick it off (a la "Meet the Engineer"). So I'd spawn it (via "Create Animation Set" and "add model") and animate it to fall to the ground. upon trying to get the character to kick it I could move the prop again, but the gib's landing spot earlier in the shot would change and was noticably higher and not at all on the character's foot.

    My animation range (the green zone) was properly moved before the next step of animation, so I can't really understand what's up with that...
    Reply With Quote Edit / Delete United States Show Events Bad Spelling Bad Spelling x 1 (list)

  14. Post #1774
    Ukuku's Avatar
    July 2009
    240 Posts
    the gib's landing spot earlier in the shot would change
    That is very annoying. To avoid it deselect roottransform and move the prop only using the other bone.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Finland Show Events

  15. Post #1775
    Gold Member

    October 2009
    10,577 Posts
    I hope in the new TF2 beta it will contain SFM.

    Then I will be happy happy joy joy
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  16. Post #1776
    Croshi's Avatar
    April 2009
    1,749 Posts
    I hope in the new TF2 beta it will contain SFM.

    Then I will be happy happy joy joy
    You do realise SFM will be in all Source games right?

    EDIT: wait no that makes sense

    Probably not because Valve enjoys community videos and they won't let anybody do it!!!
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  17. Post #1777
    Gold Member
    Razi The Red's Avatar
    June 2010
    1,027 Posts
    That is very annoying. To avoid it deselect roottransform and move the prop only using the other bone.
    I was using the other bone.
    ._.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  18. Post #1778
    milesaaway's Avatar
    September 2010
    28 Posts
    Am I the only person who things animating non character props is a pain in the ass? Perhaps there's a method to easing that pain I overlooked? Would spawining a dynamic prop and then recording in scene along with whatever else make it easier to move/animate/whatever?

    It always seems jerky and certainly doesn't seem to move around right.

    Example: I was working with a Sniper gib I spawned earlier and I wanted it to fall into the shot on to the character's feet and then have him kick it off (a la "Meet the Engineer"). So I'd spawn it (via "Create Animation Set" and "add model") and animate it to fall to the ground. upon trying to get the character to kick it I could move the prop again, but the gib's landing spot earlier in the shot would change and was noticably higher and not at all on the character's foot.

    My animation range (the green zone) was properly moved before the next step of animation, so I can't really understand what's up with that...
    i had the same problem with a similar situation with the briefcase. I never was able to get it to look right, so it ended up just not being uploaded.

    I FEEL YOUR PAIN BROTHER ;~;

    also, i think this is the 6th animation i've done with SFM now.

    http://www.youtube.com/watch?v=2bO85...eature=channel
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United Kingdom Show Events

  19. Post #1779
    cyber-core_360's Avatar
    December 2009
    47 Posts
    :P After effects can make color correction look real ggggggggggooooooooooooodddddddddddd...............

    [url]
    :D
    Reply With Quote Edit / Delete India Show Events Dumb Dumb x 3Funny Funny x 1 (list)

  20. Post #1780
    Gold Member
    Smashman's Avatar
    September 2009
    11,898 Posts
    :P After effects can make color correction look real ggggggggggooooooooooooodddddddddddd...............
    :D
    Filter rape.
    Also, we have emotes.
    Reply With Quote Edit / Delete United Kingdom Show Events Friendly Friendly x 1 (list)

  21. Post #1781
    Buy Some Apples
    Dennab
    April 2008
    6,490 Posts
    It sucks that SFM is pretty much illegal to get unless you got the tools legally. I've been dying to try it out.
    It sucks it's illegal unless you got them legaly? Yeah I would have to agree.
    Reply With Quote Edit / Delete Sweden Show Events Informative Informative x 2 (list)

  22. Post #1782
    The Cold Wind Of France
    Dennab
    November 2008
    18,714 Posts
    :P After effects can make color correction look real ggggggggggooooooooooooodddddddddddd...............

    [url]
    :D
    dear god this looks awful
    Reply With Quote Edit / Delete France Show Events Agree Agree x 7 (list)

  23. Post #1783
    Gold Member
    Cl0ud's Avatar
    May 2005
    100 Posts
    Reply With Quote Edit / Delete United Kingdom Show Events Artistic Artistic x 9Funny Funny x 1Winner Winner x 1 (list)

  24. Post #1784
    Gold Member

    October 2009
    10,577 Posts
    Uhh dance off?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  25. Post #1785
    Gold Member
    bigbadbarron's Avatar
    February 2008
    2,029 Posts
    There should be a SFM to "safety dance" Sense the artist is men without hats.
    Reply With Quote Edit / Delete United States Show Events Funny Funny x 2 (list)

  26. Post #1786

    October 2009
    23 Posts
    do you guys believe that tf2 beta(aka the SFM) supports jiggle bones?

    whats with that....
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  27. Post #1787
    Gold Member

    October 2009
    10,577 Posts
    There should be a SFM to "safety dance" Sense the artist is men without hats.
    That was going to be my first SFM
    Reply With Quote Edit / Delete Canada Show Events Optimistic Optimistic x 2 (list)

  28. Post #1788
    Natalia's Avatar
    August 2010
    6 Posts
    Make own sound files and custom .vcds...
    thanks, it works. :)


    But I have another question.
    Is it possible to link some model to another model in SFM? Or something like constraints in 3ds max? For example a hat to a character's head?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Russian Federation Show Events

  29. Post #1789
    Gold Member
    Razi The Red's Avatar
    June 2010
    1,027 Posts
    But I have another question.
    Is it possible to link some model to another model in SFM? Or something like constraints in 3ds max? For example a hat to a character's head?
    Didn't somebody find that like 4-6 pages back or so?

    The TF2 models have like 3 attachment properties or something don't they?
    "Flag" (which is their back) and 2 others, one of which is the head.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  30. Post #1790
    Gold Member
    Onirik's Avatar
    October 2007
    2,810 Posts
    thanks, it works. :)


    But I have another question.
    Is it possible to link some model to another model in SFM? Or something like constraints in 3ds max? For example a hat to a character's head?
    I do believe max of s2d did it. At least for GMod.

    Edited:

    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. France Show Events

  31. Post #1791
    Gold Member
    Appolox's Avatar
    December 2008
    3,596 Posts
    Is there a good way to make the characters animate to pick something up so it attached to their hand and animates with them? I want for example: the engineer to pick up the wrench from the ground, or a tool box.

    Also video.

    I animated the thing is sfm.

    Also the depth of field effect I made in sony vegas using gaussian blur and a cookie cutter effect, then I rendered the video loaded it again and made colour corrections.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United Kingdom Show Events

  32. Post #1792

    September 2010
    1 Posts
    I have a slight problem. When I try to export something, the export options window just closes. This may be because that it asked me if I wanted to connect to the p4 server, and I say yes, and it says that could not connect to the server. It never asks me now, and the export options window just keeps closing.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  33. Post #1793
    Gold Member
    Razi The Red's Avatar
    June 2010
    1,027 Posts
    That is very annoying. To avoid it deselect roottransform and move the prop only using the other bone.
    Alright I'm finding new use in this info. Originally I just selected the animation set and tried to move the "polymsh", but encountered the error, but by selecting the "unknown" section where "polymsh" ("staticprop" if you're using someother item I imagine) is the only bone selectable, the gib/prop seems to move as I want without moving around earlier in the set.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. United States Show Events

  34. Post #1794
    wari65's Avatar
    August 2009
    1,429 Posts

    I thought role reversal of this:
    Would be funny...


    Also:
    Reply With Quote Edit / Delete United States Show Events Artistic Artistic x 1 (list)

  35. Post #1795
    iSonic's Avatar
    September 2010
    15 Posts
    Is there any way to import a .Dem file?

    Also, why can't I see the AVI codec window?
    All I see is this:
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Israel Show Events

  36. Post #1796
    Minigunx's Avatar
    September 2010
    49 Posts
    dear god this looks awful
    "Jimbomcb banned Max of S2D for 1 Month" agree
    Reply With Quote Edit / Delete Germany Show Events Dumb Dumb x 3 (list)

  37. Post #1797
    Gold Member
    Razi The Red's Avatar
    June 2010
    1,027 Posts
    "Jimbomcb banned Max of S2D for 1 Month" agree
    ...?

    Was there any real reason to comment on that, especially since they were probably unrelated issues.

    And aside from that, the video DID look like trash.
    Reply With Quote Edit / Delete United States Show Events Agree Agree x 2 (list)

  38. Post #1798
    Gold Member
    Pandamobile's Avatar
    January 2009
    3,519 Posts
    Anyone know why when I import a MotionBuilder file into Maya, it shortens it?

    The original FBX file is 60 frames long, but when I import it into Maya, it's only 48. The framerates and everything are the same, and I've checked through most of the import/export settings.

    Anyone have a fix for this?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events

  39. Post #1799
    Natalia's Avatar
    August 2010
    6 Posts
    Anyone know why when I import a MotionBuilder file into Maya, it shortens it?

    The original FBX file is 60 frames long, but when I import it into Maya, it's only 48.
    I had the same problem. It caused by Maya used 24 fps for work (3ds max and motion builder use 30 fps).
    Go to window-settings-preferences on maya, check Settings section and change Working units from time Film (24fps) to NTSC (30 fps)
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Russian Federation Show Events

  40. Post #1800
    Gold Member
    Pandamobile's Avatar
    January 2009
    3,519 Posts
    I had the same problem. It caused by Maya used 24 fps for work (3ds max and motion builder use 30 fps).
    Go to window-settings-preferences on maya, check Settings section and change Working units from time Film (24fps) to NTSC (30 fps)
    Ah, thank you :)
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Canada Show Events