1. Post #681
    Gold Member
    Appolox's Avatar
    December 2008
    3,596 Posts
    I'll give it a test then with animation sets enabled. There might be a channel that's overriding the value with a logged value.

    Also, was just trying something with the sniper and found that the medic's domination lines seem to have replaced his. Likely my mistake (though not sure how), but funny nonetheless.

    Edit: Got it. It's exactly what I expected - a channel logged a single skin value and is then overriding the version in all other locations. I expect that you could change the value, then add an animation set and it'd work, but it's easy enough to do even after adding the animation set. I'll write up a full tutorial in a minute as the explanation is a bit long.
    Thank you, it is another step forward for me and for many at this point.

    Edited:

    I'm gonna wait for tutorial.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  2. Post #682
    Gold Member
    Markntosh's Avatar
    April 2008
    2,963 Posts
    Hmm. I've come across a bit of a problem.


    Whenever I start up SFM, I'm greeted by a dialogue box that reads
    Dialogue Box posted:
    The procedure entry point ?TryLock@CThreadFastMutex@@QCE_NXZ could not be located in the dynamic link library tier0_s.dll

    SFM then crashes soon after. This has happened to me multiple times. Anyone know what's up?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  3. Post #683
    Gold Member
    Dennab
    December 2009
    3,573 Posts
    Hmm. I've come across a bit of a problem.


    Whenever I start up SFM, I'm greeted by a dialogue box that reads



    SFM then crashes soon after. This has happened to me multiple times. Anyone know what's up?
    Looks like a corrupted .dll file?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  4. Post #684
    Gold Member
    Metroid48's Avatar
    February 2007
    1,007 Posts
    This will also be of use to other people, so listen up! If you don't care about the (short) explanation just follow the navigation prompts two paragraphs down.

    When you add an animation set to a player model, it creates a lot of channels. Channels are effectively elements that record a list of time-value pairs, which are frames of animation. They are stored in ChannelsClips, which are the things you are actually looking at when you zoom in on a shot. They constantly copy these values to another element. You can easily add new value pairs to this list, meaning you can manually animate values such as the character skin (ex. toggle uber effects without a medic), the position, or really anything you can see in the Dme editor. Manual animation can be tedious, but it's perfectly possible. This is in fact exactly what the Animation Set Editor is changing - technically an animation set is just a specialized version of all this!



    In this case we have a spy model that was added via Create Animation Set. Navigate to clipBin/sequence/subClipTrackGroup/tracks/Film/children/shot/trackGroups/. This is where the track groups are stored - the one you want is channelTrackGroup. Expand it, then tracks/animSetEditorChannels/children. Then expand the name of the animation set (ex. "spy"). Then channels. In here, you'll find EVERY bit of animation data for that model, including some pieces you can't access with the animation set editor. Scroll down to "models\player\spy_skin channel" and expand it. Then expand log\layers\int log\values and there should be one entry. Change it to whatever you want the skin to be.




    Want to have easier access to the skin value? Delete the "models\player\spy_skin channel" channel and you should be able to edit the DmeGameModel's skin value again, as it's no longer being overridden. Want to make the skin change during the recording? Right click times->Add Item. Right click values->Add Item. Then just change them accordingly. Note that the times are in tenths of thousandths of seconds - that is, 10000 = 1 second. Why they didn't choose milliseconds I don't know.

    Want to animate values that aren't already setup? You'll have to add the channel manually. It's easy, but I'm out of time right now so I'll do a write up later.
    Reply With Quote Edit / Delete Canada Show Events Informative Informative x 1 (list)

  5. Post #685
    Gold Member
    Markntosh's Avatar
    April 2008
    2,963 Posts
    Looks like a corrupted .dll file?
    Guess I should just re-install, then.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  6. Post #686
    Gold Member
    Dennab
    December 2009
    3,573 Posts
    Guess I should just re-install, then.
    Well I'm just sort of guessing. But since it says it's the .dll that's messing it up, something bad happened.

    So if you're gonna reinstall it, I'd make a different install, so you can still tinker with the broken one and see if you can find out what changed. It might be something good, it might be nothing. Who knows?
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  7. Post #687
    Gold Member
    Metroid48's Avatar
    February 2007
    1,007 Posts
    I'll just comment that I get the same dll message sometimes when starting. It's stopped recently, but even when it was appearing SFM continued to work fine, so that may not be the cause of your crashes.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  8. Post #688
    Gold Member
    RivaGe's Avatar
    January 2010
    3,231 Posts
    Oh what the hell
    I've finished creating my movie earlier today and decided to render it tonight. I launch SFM and see broken spawn door and flaming textures on my characters! Everything was great in the morning :argh:
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  9. Post #689
    Gold Member
    Dennab
    December 2009
    3,573 Posts
    Oh what the hell
    I've finished creating my movie earlier today and decided to render it tonight. I launch SFM and see broken spawn door and flaming textures on my characters! Everything was great in the morning :argh:
    If you saved it, and closed SFM, then reopened the project, that's probably why. I've had nothing but issues with saving projects, so I have to do the entire thing without closing SFM whenever I make anything.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  10. Post #690
    Gold Member
    RivaGe's Avatar
    January 2010
    3,231 Posts
    Wow it's broken completely, lips don't move and all of my custom animations are gone. Sweet!

    Edited:

    automerge broken as well!
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  11. Post #691
    Gold Member
    Appolox's Avatar
    December 2008
    3,596 Posts
    This will also be of use to other people, so listen up! If you don't care about the (short) explanation just follow the navigation prompts two paragraphs down.

    When you add an animation set to a player model, it creates a lot of channels. Channels are effectively elements that record a list of time-value pairs, which are frames of animation. They are stored in ChannelsClips, which are the things you are actually looking at when you zoom in on a shot. They constantly copy these values to another element. You can easily add new value pairs to this list, meaning you can manually animate values such as the character skin (ex. toggle uber effects without a medic), the position, or really anything you can see in the Dme editor. Manual animation can be tedious, but it's perfectly possible. This is in fact exactly what the Animation Set Editor is changing - technically an animation set is just a specialized version of all this!



    In this case we have a spy model that was added via Create Animation Set. Navigate to clipBin/sequence/subClipTrackGroup/tracks/Film/children/shot/trackGroups/. This is where the track groups are stored - the one you want is channelTrackGroup. Expand it, then tracks/animSetEditorChannels/children. Then expand the name of the animation set (ex. "spy"). Then channels. In here, you'll find EVERY bit of animation data for that model, including some pieces you can't access with the animation set editor. Scroll down to "models\player\spy_skin channel" and expand it. Then expand log\layers\int log\values and there should be one entry. Change it to whatever you want the skin to be.




    Want to have easier access to the skin value? Delete the "models\player\spy_skin channel" channel and you should be able to edit the DmeGameModel's skin value again, as it's no longer being overridden. Want to make the skin change during the recording? Right click times->Add Item. Right click values->Add Item. Then just change them accordingly. Note that the times are in tenths of thousandths of seconds - that is, 10000 = 1 second. Why they didn't choose milliseconds I don't know.

    Want to animate values that aren't already setup? You'll have to add the channel manually. It's easy, but I'm out of time right now so I'll do a write up later.

    Thank you, it worked, now I can start some work.

    Edited:

    I have one more problem - quite major to be honest, every time I get closer with the camera to a model it disappears, when I move the camera backwards it appears again, also it does the same when I turn around with the camera.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  12. Post #692
    Gold Member
    Metroid48's Avatar
    February 2007
    1,007 Posts
    Uh oh.


    Unfortunately I can't help with that one. I've had the exact same problem crop up during my efforts to add hats - model would disappear on certain sides, would always appear if I was far enough away, sometimes would always be visible. I'm still trying to figure it out but am running out of ideas - it seems to only happen with models that are added (manually or via add new animation set) so that's something at least.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  13. Post #693
    Gold Member
    Appolox's Avatar
    December 2008
    3,596 Posts
    It must be a bug then.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  14. Post #694
    Gold Member
    Pandamobile's Avatar
    January 2009
    3,536 Posts
    Thank you, it worked, now I can start some work.

    Edited:

    I have one more problem - quite major to be honest, every time I get closer with the camera to a model it disappears, when I move the camera backwards it appears again, also it does the same when I turn around with the camera.
    I get that too when I do stuff with the Manipulation tool :(
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  15. Post #695
    effin's Avatar
    April 2010
    9 Posts
    I never bothered trying to save my session files since it had the whole 'could not connect to p4 server' (assumed it didnt work)

    I just realised it did work
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  16. Post #696
    Gold Member
    Markntosh's Avatar
    April 2008
    2,963 Posts
    Dammit. I accidentally started a new sequence and now my video is all screwed up. How do I make a clip active? I need to go back to my old active clip. It took me some time to make it.

    I apologize for all the stupid "n00b" questions, I'm just trying to find my way around this stupid thing and the search option isn't workin'.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  17. Post #697
    Gold Member
    hamberglar's Avatar
    April 2005
    2,949 Posts
    Second video I finished. Figured I'd go ahead and post it.
    Any tips on some more fluid camera movement? Or are my hands just shaky..
    Reply With Quote Edit / Delete United States Show Events Funny Funny x 1Artistic Artistic x 1Informative Informative x 1 (list)

  18. Post #698
    Croshi's Avatar
    April 2009
    1,750 Posts
    You do know it's hearing protection gear, and not a headset, right?
    I was the one who brought it up because I tried to replace one of the Engineer's weapons with the Safe'n'Sound and I chose the pistol because it fits over the Scout's head.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  19. Post #699
    99% More Fail's Avatar
    October 2009
    783 Posts
    Second video I finished. Figured I'd go ahead and post it.
    Any tips on some more fluid camera movement? Or are my hands just shaky..
    Create an animation set for the camera and smooth it down a bit. Don't go overboard, or the camera breaks sort of.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  20. Post #700
    Gold Member
    RivaGe's Avatar
    January 2010
    3,231 Posts
    Despite my SFM bitching I've managed to finish my video.
    And also made an improved version of my old creation.
    Reply With Quote Edit / Delete Russian Federation Show Events Funny Funny x 9Informative Informative x 1 (list)

  21. Post #701
    Gold Member
    Darkomni's Avatar
    August 2007
    2,381 Posts
    I see that dynamic light, RivaGe

    Also, add me on steam pls
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  22. Post #702
    Reemix's Avatar
    January 2010
    245 Posts
    My animation skills are terrible :(
    Any tips?
    I've seen the video already.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  23. Post #703
    accidentalypse's Avatar
    December 2009
    132 Posts
    My animation skills are terrible :(
    Any tips?
    I've seen the video already.
    If you continue to struggle, i suggest picking up the Animators Survival Guide. Best read on animation ever! Another suggestion would to be to learn to animate in Maya (or 3ds max i guess, but the Maya TF2 models are already rigged!) as you'll get top-notch animation results.

    EDIT: http://www.interlopers.net/tutorials/32362
    This might help some people trying to use other animations that were made on different bones work on TF2 characters and vice versa.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  24. Post #704
    Gold Member
    hamberglar's Avatar
    April 2005
    2,949 Posts
    Little animation test...
    I know it was posted before but I can't seem to find it. Could someone tell me how to move/remove the weapons so they don't just go floating along like in the video?
    Reply With Quote Edit / Delete United States Show Events Dumb Dumb x 1 (list)

  25. Post #705
    Gold Member
    Metroid48's Avatar
    February 2007
    1,007 Posts
    Little animation test...
    I know it was posted before but I can't seem to find it. Could someone tell me how to move/remove the weapons so they don't just go floating along like in the video?
    Dme Element Editor. Search for the weapon's model name. Then delete the corresponding DmeGameModel.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  26. Post #706
    OrangeL's Avatar
    January 2010
    68 Posts
    After a long SFM hiatus, I decided to give it a go. This idea was culturing inside my head for 2 weeks before I got around to actually making it work.

    http://img688.imageshack.us/img688/9...ne6thcopy2.jpg
    (Wallpaper size)
    Reply With Quote Edit / Delete United States Show Events Artistic Artistic x 15Informative Informative x 1 (list)

  27. Post #707
    Gold Member
    Pandamobile's Avatar
    January 2009
    3,536 Posts
    After a long SFM hiatus, I decided to give it a go. This idea was culturing inside my head for 2 weeks before I got around to actually making it work.
    [IMG]http:/k.us/img688/9716/june6thcopy2.jpg[/url]
    (Wallpaper size)
    That's fucking badass.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  28. Post #708
    Gold Member
    Darkomni's Avatar
    August 2007
    2,381 Posts
    Rated artisticX50000
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  29. Post #709
    Gold Member

    October 2009
    10,610 Posts
    rated artisticx50000
    x500001
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  30. Post #710
    OrangeL's Avatar
    January 2010
    68 Posts
    WAIT You guys found dynamic lighting?! Dang I've been gone for a while.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  31. Post #711
    Gold Member
    Pandamobile's Avatar
    January 2009
    3,536 Posts
    WAIT You guys found dynamic lighting?! Dang I've been gone for a while.
    Yeah, we've actually found a lot of shit in this thread.
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  32. Post #712
    Gold Member
    Darkomni's Avatar
    August 2007
    2,381 Posts
    It's basically "See what metroid48 discovered today, sometimes panda/darkomni maybe!"
    Reply With Quote Edit / Delete Canada Show Events Agree Agree x 2 (list)

  33. Post #713
    PwR

    January 2010
    27 Posts
    How's hamachi doing?

    Any way to connect?

    i guess:

    1. Both players connected, Running SFM

    2. Host checks ip adress by typing in status (i guess)

    3. Other player types in join -ip adress from host-

    What do you think, its pretty simple
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  34. Post #714
    Gold Member
    TheDKer's Avatar
    September 2008
    1,587 Posts
    WAIT You guys found dynamic lighting?! Dang I've been gone for a while.
    Check out all of Metroid's posts, they're really helpful
    Reply With Quote Edit / Delete THIS BUG NEEDS FIXING, BUT I DONT KNOW WHAT CAUSES IT, SO SHUT UP AND STOP POSTING ABOUT IT. Thanks. Show Events

  35. Post #715
    OrangeL's Avatar
    January 2010
    68 Posts
    Check out all of Metroid's posts, they're really helpful
    I've got a LOOOOT of reading to do.
    In other news, I also found out a week or so ago on how to move the camera without a player.
    Sorry, I call credit. (It was itching at me)
    Reply With Quote Edit / Delete United States Show Events Artistic Artistic x 2 (list)

  36. Post #716
    I'll Go all tadpole on you
    thefrog's Avatar
    June 2005
    1,170 Posts
    Yea... Just fucking around
    Reply With Quote Edit / Delete United States Show Events Funny Funny x 1 (list)

  37. Post #717
    [TrSB]Drako's Avatar
    October 2009
    301 Posts

    i finished this and realized that i have nothing to use it for
    0:45 = Sniper rape face.

    :O
    Reply With Quote Edit / Delete United States Show Events Funny Funny x 2 (list)

  38. Post #718
    Gold Member
    Darkomni's Avatar
    August 2007
    2,381 Posts
    I'm considering making videos in blender, just for the hell of it. What do you guys think?

    ( for sure, for nah)
    Reply With Quote Edit / Delete Canada Show Events Agree Agree x 14Disagree Disagree x 4 (list)

  39. Post #719
    Gold Member
    hamberglar's Avatar
    April 2005
    2,949 Posts
    This started as something completely different. It didn't really work out, but paved the way for this.. Thing.
    I like it.
    Reply With Quote Edit / Delete United States Show Events Dumb Dumb x 3 (list)

  40. Post #720
    Gold Member
    Pandamobile's Avatar
    January 2009
    3,536 Posts
    This started as something completely different. It didn't really work out, but paved the way for this.. Thing.
    I like it.
    Ah what the shit
    Reply With Quote Edit / Delete Canada Show Events Agree Agree x 1 (list)