1. Post #281
    SDurkee's Avatar
    July 2005
    17 Posts
    Toolgun still has no crosshair =( crosshair 1 did not restore the toolgun's crosshair it will add or remove the crosshair from everything else, except the toolgun, its quite frusterating, cant seem to figure out what is causing it!

  2. Post #282
    Gold Member
    WeltEnSTurm's Avatar
    December 2007
    1,883 Posts
    update and try again

  3. Post #283
    SDurkee's Avatar
    July 2005
    17 Posts
    update and try again
    Update fixed it.

  4. Post #284
    ElectricSquid's Avatar
    January 2010
    5,312 Posts
    Does this conflict with Neuro Planes? I think I read something recently that suggested to me that the two conflict.

  5. Post #285
    Gold Member
    AlbertWesker's Avatar
    February 2007
    344 Posts
    Sorry if this question was answered earlier, but the Pod camera doesn't seem to work. Is this due to conflicting addons? The pod camera used to work for me, but it never seemed to work for my friends on the server we have.

  6. Post #286
    Anix's Avatar
    September 2011
    8 Posts
    Thanks for the mod.
    Reply With Quote Edit / Delete Reply Windows 7 Turkey Show Events Friendly Friendly x 1 (list)

  7. Post #287
    Scootaloo's Avatar
    September 2011
    7 Posts
    If someone could give me a link to a version thats non svn if there is one i would apreciate it.

  8. Post #288
    Gold Member
    Marlwolf78's Avatar
    August 2008
    2,821 Posts
    If someone could give me a link to a version thats non svn if there is one i would apreciate it.
    A non-svn version wouldn't be consistently updated or maintained. Just download TortoiseSVN, right click your desktop, select SVN checkout, and put in WAC's SVN URL. Easy.

  9. Post #289
    Scootaloo's Avatar
    September 2011
    7 Posts
    A non-svn version wouldn't be consistently updated or maintained. Just download TortoiseSVN, right click your desktop, select SVN checkout, and put in WAC's SVN URL. Easy.
    is TortoiseSVN safe to use?

  10. Post #290

    May 2011
    20 Posts
    is TortoiseSVN safe to use?
    Obviously not.
    Reply With Quote Edit / Delete Reply Mac United States Show Events Dumb Dumb x 3 (list)

  11. Post #291
    Scootaloo's Avatar
    September 2011
    7 Posts
    Obviously not.
    was trying to be serious here buddy.
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Agree Agree x 1 (list)

  12. Post #292

    August 2011
    9 Posts
    two questions: are the weapons customizable like you can put laser dot sights and underslung
    grenade launchers like in black ops? and two is this in table format? i screwed my gmod so that
    it doesent recognize or work with table values very well.

    Edited:

    also would it be compatible scars if yes and you can put custom attachments then this stuff fucks the shit
    out of Customizable Weaponary

    Edited:

    also would it be compatible scars if yes and you can put custom attachments then this stuff fucks the shit
    out of Customizable Weaponary

    Edited:

    also would it be compatible scars if yes and you can put custom attachments then this stuff fucks the shit
    out of Customizable Weaponary
    Reply With Quote Edit / Delete Reply United States Show Events Funny Funny x 3Dumb Dumb x 1 (list)

  13. Post #293
    Gold Member
    WeltEnSTurm's Avatar
    December 2007
    1,883 Posts
    two questions: are the weapons customizable like you can put laser dot sights and underslung
    grenade launchers like in black ops?
    No.
    and two is this in table format? i screwed my gmod so that
    it doesent recognize or work with table values very well.
    EVERYTHING in Garry's Mod works with tables.

  14. Post #294
    Gold Member
    Marlwolf78's Avatar
    August 2008
    2,821 Posts
    was trying to be serious here buddy.
    Of course it is, there's no reason not to.

  15. Post #295

    March 2009
    1 Posts
    Tons of people use TortiseSVN, It's fine.

    @Welt, I've been using WAC for a pretty damn long time now and it's always worked fine up until I stopped playing a few months ago. Recently, me and some friends wanted to start up garymodding again and I updated my WACs. Nothing is spawnable and there's no WAC features. Here's a full dump of my console after booting up a local game.

    Also, you've released a couple more helicopters but they aren't in your SVN, 'sup with that?

    Garry's Mod server.dll Build #126 [Aug 17 2011 12:28:28]
    maxplayers set to 128
    Unknown command "sv_allow_wait_command"
    Steam config directory: c:\program files\steam\steamapps\[my username\garrysmod\platform\config
    CClientSteamContext logged on = 1
    Both ConVars must be marked FCVAR_REPLICATED for linkage to work (v_ipitch_level)
    Both ConVars must be marked FCVAR_REPLICATED for linkage to work (v_iroll_level)
    Both ConVars must be marked FCVAR_REPLICATED for linkage to work (v_iyaw_level)
    Both ConVars must be marked FCVAR_REPLICATED for linkage to work (v_ipitch_cycle)
    Both ConVars must be marked FCVAR_REPLICATED for linkage to work (v_iroll_cycle)
    Both ConVars must be marked FCVAR_REPLICATED for linkage to work (v_iyaw_cycle)
    Both ConVars must be marked FCVAR_REPLICATED for linkage to work (cl_bobup)
    Both ConVars must be marked FCVAR_REPLICATED for linkage to work (cl_bob)
    Both ConVars must be marked FCVAR_REPLICATED for linkage to work (cl_bobcycle)
    Hud element 'CHudVote' doesn't have an entry 'CHudVote' in scripts/HudLayout.res
    Garry's Mod client.dll Build #126 [Aug 17 2011 12:28:31]
    maxplayers set to 1
    Unknown command "cl_thirdperson"
    Unknown command "hud_showemptyweaponslots"
    Unknown command "sv_backspeed"
    Not playing a local game.
    GetAllManifestFiles: Unable to load maplist.txt
    Got toybox authentication
    maxplayers set to 1
    Browser Message: Uncaught ReferenceError: SetStatusChanged is not defined - :0Lua initialized (Lua 5.1)
    [WAC] Loading autorun/wac_loader.lua, Version 89
    [@addons\wac base\lua\autorun\wac_loader.lua:31] bad argument #1 to 'pairs' (table expected, got nil)
    ERROR! Module 'zlib_b64' not found!
    Registering gamemode 'sandbox' derived from 'base'
    ScriptEnforce is disabled
    [addons\wac base\lua\weapons\gmod_tool\stools\entity_linker.lu a:2] attempt to index field 'Names' (a nil value)
    [addons\wac base\lua\weapons\gmod_tool\stools\wac_podcamera.lu a:1] attempt to index field 'Names' (a nil value)
    [addons\wac base\lua\weapons\gmod_tool\stools\wac_rt7_tool.lua :1] attempt to index field 'Names' (a nil value)
    Couldn't include file 'entities\base_wire_entity\init.lua' (File not found) (@addons\wac base\lua\entities\wac_v_camera\init.lua (line 5))
    Couldn't include file 'entities\base_wire_entity\init.lua' (File not found) (@addons\wac base\lua\entities\wac_v_connector\init.lua (line 5))
    [addons\wac helicopter\lua\entities\wac_hc_ah1z_viper\shared.l ua:7] attempt to index field 'Names' (a nil value)
    [addons\wac helicopter\lua\entities\wac_hc_base\shared.lua:7] attempt to index field 'Names' (a nil value)
    Couldn't include file 'entities\base_wire_entity\init.lua' (File not found) (@addons\wac helicopter\lua\entities\wac_hc_base\init.lua (line 3))
    [addons\wac helicopter\lua\entities\wac_hc_base\init.lua:370] table index is nil
    [addons\wac helicopter\lua\entities\wac_hc_blackhawk_uh60\shar ed.lua:7] attempt to index field 'Names' (a nil value)
    [addons\wac helicopter\lua\entities\wac_hc_hebullet\shared.lua :5] attempt to index field 'Names' (a nil value)
    [addons\wac helicopter\lua\entities\wac_hc_littlebird_ah6\shar ed.lua:7] attempt to index field 'Names' (a nil value)
    [addons\wac helicopter\lua\entities\wac_hc_littlebird_mh6\shar ed.lua:7] attempt to index field 'Names' (a nil value)
    [addons\wac helicopter\lua\entities\wac_hc_mi28_havoc\shared.l ua:6] attempt to index field 'Names' (a nil value)
    [addons\wac helicopter\lua\entities\wac_hc_sylph_ahx1\shared.l ua:6] attempt to index field 'Names' (a nil value)
    Executing listen server config file
    Couldn't find scene 'scenes/npc/female01/question21.vcd'
    Couldn't find scene 'scenes/npc/female01/question31.vcd'
    Couldn't find scene 'scenes/npc/female01/answer35.vcd'
    Couldn't find scene 'scenes/npc/female01/gordead_ques03a.vcd'
    Couldn't find scene 'scenes/npc/female01/gordead_ques03b.vcd'
    Couldn't find scene 'scenes/npc/female01/nice.vcd'
    Couldn't find scene 'scenes/npc/male01/nice01.vcd'
    Couldn't find scene 'scenes/npc/male01/nice02.vcd'
    Couldn't find scene 'scenes/npc/female01/oneforme.vcd'
    Couldn't find scene 'scenes/npc/Barney/ba_run.vcd'
    Couldn't find scene 'scenes/npc/Barney/ba_ohshit.vcd'
    Couldn't find scene 'scenes/npc/Barney/ba_thisisbad.vcd'
    Couldn't find scene 'scenes/npc/Barney/ba_headcrabs.vcd'
    exec: couldn't exec listenserver.cfg
    Requesting texture value from var "$hdrbasetexture" which is not a texture value (material: skybox/militia_hdrrt)
    Requesting texture value from var "$hdrbasetexture" which is not a texture value (material: skybox/militia_hdrbk)
    Requesting texture value from var "$hdrbasetexture" which is not a texture value (material: skybox/militia_hdrlf)
    Requesting texture value from var "$hdrbasetexture" which is not a texture value (material: skybox/militia_hdrft)
    Requesting texture value from var "$hdrbasetexture" which is not a texture value (material: skybox/militia_hdrup)
    Requesting texture value from var "$hdrbasetexture" which is not a texture value (material: skybox/militia_hdrdn)
    Warning: using WorldTwoTextureBlend on a non-displacement surface.
    Support for this will go away soon.
    - Material : gm_essence/grass
    - Surface center : 5247 7242 64
    Warning: WorldTwoTextureBlend found on a non-displacement surface (material: gm_essence/grass). This wastes perf for no benefit.
    Lua initialized (Lua 5.1)
    [WAC] Loading autorun/wac_loader.lua, Version 89
    [@addons\wac base\lua\autorun\wac_loader.lua:31] bad argument #1 to 'pairs' (table expected, got nil)
    ERROR! Module 'zlib_b64' not found!
    Registering gamemode 'sandbox' derived from 'base'
    [addons\wac base\lua\weapons\gmod_tool\stools\entity_linker.lu a:2] attempt to index field 'Names' (a nil value)
    [addons\wac base\lua\weapons\gmod_tool\stools\wac_podcamera.lu a:1] attempt to index field 'Names' (a nil value)
    [addons\wac base\lua\weapons\gmod_tool\stools\wac_rt7_tool.lua :1] attempt to index field 'Names' (a nil value)
    [addons\wac base\lua\entities\wac_rt7_cam\cl_init.lua:61] attempt to call field 'Hook' (a nil value)
    [addons\wac helicopter\lua\entities\wac_hc_ah1z_viper\shared.l ua:7] attempt to index field 'Names' (a nil value)
    [addons\wac helicopter\lua\entities\wac_hc_base\shared.lua:7] attempt to index field 'Names' (a nil value)
    [addons\wac helicopter\lua\entities\wac_hc_blackhawk_uh60\shar ed.lua:7] attempt to index field 'Names' (a nil value)
    [addons\wac helicopter\lua\entities\wac_hc_hebullet\shared.lua :5] attempt to index field 'Names' (a nil value)
    [addons\wac helicopter\lua\entities\wac_hc_littlebird_ah6\shar ed.lua:7] attempt to index field 'Names' (a nil value)
    [addons\wac helicopter\lua\entities\wac_hc_littlebird_mh6\shar ed.lua:7] attempt to index field 'Names' (a nil value)
    [addons\wac helicopter\lua\entities\wac_hc_mi28_havoc\shared.l ua:6] attempt to index field 'Names' (a nil value)
    [addons\wac helicopter\lua\entities\wac_hc_sylph_ahx1\shared.l ua:6] attempt to index field 'Names' (a nil value)
    ERROR: Trying to derive entity gmod_xqm_wire_hydraulic from non existant entity base_wire_entity!
    Sending 379 'User Info' ConVars to server (cl_spewuserinfoconvars to see)
    Scanning for downloaded fonts..
    RunConsoleCommand blocked - sent before player spawned (ZLib_Installed)
    Redownloading all lightmaps

  16. Post #296
    Gold Member
    WeltEnSTurm's Avatar
    December 2007
    1,883 Posts
    Whoops, fixed that.

  17. Post #297
    Dennab
    October 2011
    20 Posts
    Okay, Figured out the problem. THanks for the help Welt. It ended up being that i had a bad copy of Tortise. Reinstalled, and works like a BEAUTY! CHOPPERS ARE BACK BABY!! I'd love to see more SWEPS, and still havn't quite figured out how to create or use the gravity controler yet, but I'm sure it will come to me sooner or later. again, thanks!

  18. Post #298
    Scootaloo's Avatar
    September 2011
    7 Posts
    Of course it is, there's no reason not to.
    Ok i just downloaded it and got WAC sweps it works perfectly fine
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Winner Winner x 1 (list)

  19. Post #299

    October 2011
    1 Posts
    I can't get the Black Hawk to work, it just crashes my gmod with no errors and I don't get to use it.
    but if I play online, it works a-ok

    I don't have a crash dump to show, but i'll get it in a couple of minutes
    please please please help me Ive been dying to be able o play with ALL these heli's, you did a really good job on them :)

    EDIT: I joined just to get this sorted out

  20. Post #300

    March 2011
    45 Posts
    a sugestion. i realy love those weapon entities but i was thinking: i use them to make tanks most of the time so maybe you could make some ekstra turret models that looks like they come from a tank? like the m1a1/m1a2 abrams it would be so awsome to have the turret of that tank :) or maybe a t90? just a sugestion

  21. Post #301
    Gold Member
    WeltEnSTurm's Avatar
    December 2007
    1,883 Posts
    a sugestion. i realy love those weapon entities but i was thinking: i use them to make tanks most of the time so maybe you could make some ekstra turret models that looks like they come from a tank? like the m1a1/m1a2 abrams it would be so awsome to have the turret of that tank :) or maybe a t90? just a sugestion
    I made them minimalistic so you can do it yourself.
    It's GMod, after all.

    Edited:

    I can't get the Black Hawk to work, it just crashes my gmod with no errors and I don't get to use it.
    but if I play online, it works a-ok

    I don't have a crash dump to show, but i'll get it in a couple of minutes
    please please please help me Ive been dying to be able o play with ALL these heli's, you did a really good job on them :)

    EDIT: I joined just to get this sorted out
    I'm sorry, I still don't know why spawning helicopters crashes for some people.

  22. Post #302

    October 2011
    53 Posts
    Good weapons and stuff...
    But sadly, when I click on M4A1 I just get a HL2 Pistol when I left click it says "cl.something something WAC swep blah blah" :sad:
    Stuff I don't really understand much...
    All I know is if I left click it gives me yellow text on side of screen.
    CAN YOU HELP ME???
    IF ANYONE CAN REPLY OR HELP ME OUT THAT WOULD BE GREAT!!!
    By the way I own CSS, HL2, HL2: LC, HL2: DM, DOD:S, TF2, and.... Gmod.

  23. Post #303
    Gold Member
    WeltEnSTurm's Avatar
    December 2007
    1,883 Posts
    Good weapons and stuff...
    But sadly, when I click on M4A1 I just get a HL2 Pistol when I left click it says "cl.something something WAC swep blah blah" :sad:
    Stuff I don't really understand much...
    All I know is if I left click it gives me yellow text on side of screen.
    CAN YOU HELP ME???
    IF ANYONE CAN REPLY OR HELP ME OUT THAT WOULD BE GREAT!!!
    By the way I own CSS, HL2, HL2: LC, HL2: DM, DOD:S, TF2, and.... Gmod.
    It would help if you post the full error message.

    Edited:

    Also, you've released a couple more helicopters but they aren't in your SVN, 'sup with that?
    I didn't make any helicopters without putting them in the SVN. There are a few community made ones, maybe you mean them.

  24. Post #304

    October 2011
    53 Posts
    It would help if you post the full error message.

    Edited:



    I didn't make any helicopters without putting them in the SVN. There are a few community made ones, maybe you mean them.

    It said something about.... lua/weapons/WAC/

    something along the lines of that. I don't understand...
    I copied and pasted everything into the correct folders.

  25. Post #305

    October 2011
    53 Posts
    [lua\weapons\w_wac_base\init.lua:20] attempt to call method 'CustomAttack' (a nil value)
    [lua\weapons\w_wac_base\init.lua:21] attempt to call method 'CanAct' (a nil value)

    Edited:

    Those are the error messages I got...

  26. Post #306
    Mobile_Person's Avatar
    June 2010
    621 Posts
    My WAC weapons keep bouncing around retardedly in my hands. I watched your videos and they looked fine.
    I just loaded up a new map, and now theres no bouncing at all. Or aiming. It also screwed up Customizable Weapons, so Ill see if I remove that and if it gets fixed.
    Well, it fixed the bobbing completely stopping. But my guy still has really shaky hands

  27. Post #307
    Scootaloo's Avatar
    September 2011
    7 Posts
    Well i'm currently having a problem where i have free aim on yet its not working. I'm not sure why its doing this and hopefully you guys will help me out

  28. Post #308
    augmented18's Avatar
    September 2011
    133 Posts
    how can i disable the camera shake? It fucks up playermodel animations, and most of the stuff.

  29. Post #309
    Gold Member
    WeltEnSTurm's Avatar
    December 2007
    1,883 Posts
    [lua\weapons\w_wac_base\init.lua:20] attempt to call method 'CustomAttack' (a nil value)
    [lua\weapons\w_wac_base\init.lua:21] attempt to call method 'CanAct' (a nil value)

    Edited:

    Those are the error messages I got...
    And they happen only with the M4A1? My pack contains a M4 and a M4 Aimpoint but no M4A1.

  30. Post #310
    Scootaloo's Avatar
    September 2011
    7 Posts
    Well i may of had to delete my addons folder but it was worth it to get this awesome mod
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Disagree Disagree x 1 (list)

  31. Post #311

    November 2010
    1 Posts
    IT DOSENT WORKS FOR ME
    Reply With Quote Edit / Delete Reply Windows 7 Romania Show Events Funny Funny x 2Dumb Dumb x 2 (list)

  32. Post #312
    ElectricSquid's Avatar
    January 2010
    5,312 Posts
    IT DOSENT WORKS FOR ME
    It doesn't help when you don't tell us anything other than that.

  33. Post #313
    Gold Member
    beanhead's Avatar
    May 2009
    5,051 Posts
    can i just install the sweps or do i need everything else as well

    Edited:

    nevermind, i figured it out

  34. Post #314
    Civil's Avatar
    December 2009
    3,747 Posts
    IT DOSENT WORKS FOR ME
    Pirate. Your steam leads nowhere.

    Never come back.
    Reply With Quote Edit / Delete Reply Windows 7 Sweden Show Events Dumb Dumb x 2Disagree Disagree x 1 (list)

  35. Post #315
    death9478's Avatar
    March 2009
    16 Posts
    The wrench is a little off, it doesn't show a props health if it has been Adv duped, any ideas for a fix?
    - It doesn't affect props that're spawned with no constraints.

  36. Post #316
    Uberpro's Avatar
    January 2010
    834 Posts
    Pirate. Your steam leads nowhere.

    Never come back.
    That's a pretty common error, it doesn't prove he's a pirate.

  37. Post #317
    Savannah's Avatar
    January 2012
    6 Posts
    I love the new CH-47 Chinook, It's part of the SVN, You guys should try it out!
    Also, How do I get the tank track entities to work?

  38. Post #318
    Pirate. Your steam leads nowhere.

    Never come back.
    If it doesn't work for somebody (for example, wrong installation) - he's definitely a pirate!

    Gotta love the FP GMod community.
    Reply With Quote Edit / Delete Reply Windows 7 Lithuania Show Events Agree Agree x 1 (list)

  39. Post #319
    Gold Member
    WeltEnSTurm's Avatar
    December 2007
    1,883 Posts
    I love the new CH-47 Chinook, It's part of the SVN, You guys should try it out!
    Also, How do I get the tank track entities to work?
    The Chinook is not part of the SVN.
    Tracks work with wire, 1 for forward and -1 for back.

  40. Post #320
    Lucky9Two's Avatar
    June 2008
    806 Posts
    Is there a way I can get just the damage system, spawnpoints, and tank pieces (Turret, Tracks), and cameras without having all the overhead?

    That's why I don't use WAC, there's over 1/2 of it I don't want or hate.