1. Post #401
    Juze's Avatar
    November 2011
    57 Posts
    Well, No. This still happens after the latest update of flash.. :/
    Which could exactly be your cause, of course.

  2. Post #402
    Juze's Avatar
    November 2011
    57 Posts
    Hm, weird, it seems after updating Flash, I seem to be getting similar issues to yours. Could you try and upgrade/downgrade your Flash player? Can you play any songs from the web panel?
    Reply With Quote Edit / Delete Reply Windows 7 Finland Show Events Agree Agree x 1 (list)

  3. Post #403
    Title

    August 2009
    300 Posts
    Hm, weird, it seems after updating Flash, I seem to be getting similar issues to yours. Could you try and upgrade/downgrade your Flash player? Can you play any songs from the web panel?
    Uhr, are there lower versions released? Chrome doesn't seem to want to "downgrade".

    But what could be causing the issue in the new update?

  4. Post #404
    Juze's Avatar
    November 2011
    57 Posts
    Uhr, are there lower versions released? Chrome doesn't seem to want to "downgrade".

    But what could be causing the issue in the new update?
    The latest Flash update basically removed all other Flash versions. You can also notice this if you try to browse the Steam store. Grab the "other versions" download from Adobe site and it should be fine.

  5. Post #405

    May 2012
    31 Posts
    What version should i be downgrading too?

  6. Post #406
    Title

    August 2009
    300 Posts
    I mean literally everyone who plays our server crash's and we have had to remove this mod because of that. So downgrading may temporarily fix the problem, yet it's not a solution. I cant expect players to downgrade flash just so they don't crash.

  7. Post #407
    Gold Banana
    Banana Lord.'s Avatar
    May 2010
    6,846 Posts
    I have no clue what's wrong with your setup then, I've had this running on my server (which peaked at like 35 players last night) for 5-6 months. Have you tried a fresh copy of WolfDJ?

  8. Post #408
    Title

    August 2009
    300 Posts
    I have no clue what's wrong with your setup then, I've had this running on my server (which peaked at like 35 players last night) for 5-6 months. Have you tried a fresh copy of WolfDJ?
    Yes. It works for only a handful of people apparently (With older flash versions). Ill try a fresh copy later today once my Dedicated server has finally setup.

  9. Post #409
    Title

    August 2009
    300 Posts
    Thinking about it, it doesn't work on a fresh copy because I started a SRCDS server from my PC and tested it, still crash's.

  10. Post #410
    Title

    August 2009
    300 Posts
    Sorry for the bump, but after installing wolfdj4 onto my dedi, and also fiddling around with PHP forever to get it to work (installed 5.2.0) Songs show up in the woldDJ menu and you can add and select then and play them without crashing. However I cannot hear them ingame. I have checked multiple things including:

    Volume in WolfDJ menu
    I have flash as it works fine on another server
    Game sound is also fine.

    Not really sure what's wrong, I can preview the songs just fine on the wolfdj webpanel.

  11. Post #411
    Juze's Avatar
    November 2011
    57 Posts
    @Mrkrabz: You should have just updated Flash player and kept your PHP etc. Nobody told you to downgrade, but rather update their Flash. Everything that has to do with downgrading is always more difficult and has more security risks.

    Anyway, I'm running to this same issue again. After moving from Apache to nginx, I'm getting a blank page from WolfDJ on every browser. Before that, I got a login screen without CSS and JS. Every other complex webpage on nginx works just fine, and the folders are chrooted to nginx:nginx with proper permissions from original post.

    Looking at error logs, it seems to have permamently cached to another URL, so now it's without CSS and JS. Source code has this:

    Code:
    		<link rel="stylesheet" type="text/css" href="css/compress.php/login+primary"/>
    		<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.6/jquery.min.js"></script>
    		<script type="text/javascript" src="js/compress.php/primary"></script>
    Followed by error logs:

    Code:
    2012/05/22 02:50:18 [error] 25940#0: *334 open() "/var/www/html/wolfdj4-new/css/compress.php/login+primary" failed (20: Not a directory), client: -snip-, server: _, request: "GET /wolfdj4-new/css/compress.php/login+primary HTTP/1.1", host: "-snip-", referrer: "-snip-/wolfdj4-new/login.php"
    2012/05/22 02:50:19 [error] 25940#0: *334 open() "/var/www/html/wolfdj4-new/js/compress.php/primary" failed (20: Not a directory), client: -snip-, server: _, request: "GET /wolfdj4-new/js/compress.php/primary HTTP/1.1", host: "-snip-", referrer: "http://-snip-/wolfdj4-new/login.php"
    EDIT: Falled back to Apache again, and I have to go through the hell to get it working on it as well now. PHP errors with permissions, which are just fine as they were before. This is why I don't like deprecated code. :/

  12. Post #412

    March 2012
    16 Posts
    Does anyone have a fresh download of WolfDJ 4.0? Seems as tho the previous one has gone dead.
    thx.

  13. Post #413
    Gold Banana
    Banana Lord.'s Avatar
    May 2010
    6,846 Posts
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Friendly Friendly x 1Useful Useful x 1 (list)

  14. Post #414

    March 2012
    16 Posts
    Thx man.

  15. Post #415
    Juze's Avatar
    November 2011
    57 Posts
    Has anyone succeeded running this on nginx yet? I'm still having issues, primarily "domain.net/wolfdj4/" redirecting to "domain.netlfdj4/login.php" and CSS styling missing.

    http://94.23.120.235/wolfdj4/
    http://94.23.120.235/wolfdj4/login.php

    PHP Version 5.3.3 (CGI/FastCGI)

    Code:
    Installed Packages
    php-cli.x86_64                                                                 5.3.3-3.el6_2.8                                                                  @updates
    lighttpd-fastcgi.x86_64                                                                1.4.28-3.el6                                                                @epel
    nginx.x86_64                                                                   1.2.0-1.el6.ngx                                                                    @nginx

  16. Post #416
    Gold Banana
    Banana Lord.'s Avatar
    May 2010
    6,846 Posts
    yeah I have mine running on NGINX now actually, set it up this morning

    did you set up some funky rewrite rules or something in the config? as for the CSS styling, read the first post (right above the video), you need to CHMod a few folders

  17. Post #417
    Juze's Avatar
    November 2011
    57 Posts
    yeah I have mine running on NGINX now actually, set it up this morning

    did you set up some funky rewrite rules or something in the config? as for the CSS styling, read the first post (right above the video), you need to CHMod a few folders
    You've advised me to chmod them earlier too, they should be just correct. Because of the compress.php/primary stuff, it doesn't seem to work.

    There's no really any rewrite rules more than this:

    Code:
    server {
        listen       80;
        server_name  _;
    
        #charset koi8-r;
        #access_log  /var/log/nginx/log/host.access.log  main;
    
        location / {
            root   /var/www/nginx;
            index  index.html index.htm index.php;
        }
    
        #error_page  404              /404.html;
    
        # redirect server error pages to the static page /50x.html
        #
        #error_page   500 502 503 504  /50x.html;
        #location = /50x.html {
        #    root   /usr/share/nginx/html;
        #}
    
        # proxy the PHP scripts to Apache listening on 127.0.0.1:80
        #
        #location ~ \.php$ {
        #    proxy_pass   http://127.0.0.1:8080;
        #}
    
        # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
        #
        location ~ \.php$ {
            root           nginx;
            fastcgi_pass   127.0.0.1:9000;
            fastcgi_index  index.php;
            #fastcgi_param  SCRIPT_FILENAME  /scripts$fastcgi_script_name;
    		#fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
    		fastcgi_param  SCRIPT_FILENAME  /var/www/nginx$fastcgi_script_name;
            include        fastcgi_params;
        }
    
        # deny access to .htaccess files, if Apache's document root
        # concurs with nginx's one
        #
        #location ~ /\.ht {
        #    deny  all;
        #}
    }
    EDIT: Fixed the redirects, but CSS is still missing?

  18. Post #418
    I call in friends to rate KatNotDinner dumb (lol)
    nick_9_8's Avatar
    December 2011
    1,651 Posts
    I keep having the same bloody problem:

    I type in goldenera.net76.net/wolfdj2

    When I enter my user and pass, it redirects me to:

    http://goldenera.net76.netml/wolfdj2/login.php

    It then says it cant find this link, obviously because it's chucked a ml in there!

    Any ideas?

  19. Post #419
    Juze's Avatar
    November 2011
    57 Posts
    I keep having the same bloody problem:

    I type in goldenera.net76.net/wolfdj2

    When I enter my user and pass, it redirects me to:

    http://goldenera.net76.netml/wolfdj2/login.php

    It then says it cant find this link, obviously because it's chucked a ml in there!

    Any ideas?
    If you're using nginx, use this config:

    Code:
    server {
        listen       80;
        server_name  _;
    
        #charset koi8-r;
        #access_log  /var/log/nginx/log/host.access.log  main;
    
        location / {
            root   /var/www/nginx;
            index  index.html index.htm index.php;
        }
    
        #error_page  404              /404.html;
    
        # redirect server error pages to the static page /50x.html
        #
        #error_page   500 502 503 504  /50x.html;
        #location = /50x.html {
        #    root   /usr/share/nginx/html;
        #}
    
        # proxy the PHP scripts to Apache listening on 127.0.0.1:80
        #
        #location ~ \.php$ {
        #    proxy_pass   http://127.0.0.1:8080;
        #}
    
        # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
        #
        location ~ \.php$ {
            root           /var/www/nginx;
            fastcgi_pass   127.0.0.1:9000;
            fastcgi_index  index.php;
            fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
            include        fastcgi_params;
        }
    
        # deny access to .htaccess files, if Apache's document root
        # concurs with nginx's one
        #
        location ~ /\.ht {
            deny  all;
        }
        
        location = /robots.txt  { access_log off; log_not_found off; }
        location = /favicon.ico { access_log off; log_not_found off; }
    }
    Change the locations to what you need.

    I'm still having issues with CSS though. Everything else works. Same problem even if all the files would be chmodded to 777.

  20. Post #420
    Gold Member
    elevate's Avatar
    April 2012
    3,781 Posts
    What's a good place to host PHP?
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Dumb Dumb x 1 (list)

  21. Post #421
    I call in friends to rate KatNotDinner dumb (lol)
    nick_9_8's Avatar
    December 2011
    1,651 Posts
    If you're using nginx, use this config:

    Code:
    server {
        listen       80;
        server_name  _;
    
        #charset koi8-r;
        #access_log  /var/log/nginx/log/host.access.log  main;
    
        location / {
            root   /var/www/nginx;
            index  index.html index.htm index.php;
        }
    
        #error_page  404              /404.html;
    
        # redirect server error pages to the static page /50x.html
        #
        #error_page   500 502 503 504  /50x.html;
        #location = /50x.html {
        #    root   /usr/share/nginx/html;
        #}
    
        # proxy the PHP scripts to Apache listening on 127.0.0.1:80
        #
        #location ~ \.php$ {
        #    proxy_pass   http://127.0.0.1:8080;
        #}
    
        # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
        #
        location ~ \.php$ {
            root           /var/www/nginx;
            fastcgi_pass   127.0.0.1:9000;
            fastcgi_index  index.php;
            fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
            include        fastcgi_params;
        }
    
        # deny access to .htaccess files, if Apache's document root
        # concurs with nginx's one
        #
        location ~ /\.ht {
            deny  all;
        }
        
        location = /robots.txt  { access_log off; log_not_found off; }
        location = /favicon.ico { access_log off; log_not_found off; }
    }
    Change the locations to what you need.

    I'm still having issues with CSS though. Everything else works. Same problem even if all the files would be chmodded to 777.
    Where do I chuck this?

  22. Post #422
    Juze's Avatar
    November 2011
    57 Posts
    Where do I chuck this?
    /etc/nginx/conf.d/default.conf

    What's a good place to host PHP?
    Your own servers obviously, or a cheap webhost.

  23. Post #423
    I call in friends to rate KatNotDinner dumb (lol)
    nick_9_8's Avatar
    December 2011
    1,651 Posts
    /etc/nginx/conf.d/default.conf



    Your own servers obviously, or a cheap webhost.
    Could you bold the things I need to change. I have no clue with this type of code :\

  24. Post #424
    Gold Banana
    Banana Lord.'s Avatar
    May 2010
    6,846 Posts
    Could you bold the things I need to change. I have no clue with this type of code :\
    you probably shouldn't be running a NGINX server if you can't configure it
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Agree Agree x 2 (list)

  25. Post #425
    I call in friends to rate KatNotDinner dumb (lol)
    nick_9_8's Avatar
    December 2011
    1,651 Posts
    Mm. Can you accept my invite on steam Bannana?

    Really need some help here !

  26. Post #426

    June 2012
    1 Posts
    Not sure if this is due to a Java update or something, or if it's just my own computer, but the Java applet on my WolfDJ website for uploading new songs is stuck at the loading screen, the "Java" logo and the revolving circle. I don't have any idea why, please help.

  27. Post #427
    Gold Banana
    Banana Lord.'s Avatar
    May 2010
    6,846 Posts
    Mm. Can you accept my invite on steam Bannana?

    Really need some help here !
    sorry I never saw your reply, do you still need help

    Edited:

    Not sure if this is due to a Java update or something, or if it's just my own computer, but the Java applet on my WolfDJ website for uploading new songs is stuck at the loading screen, the "Java" logo and the revolving circle. I don't have any idea why, please help.
    is your java up to date?

  28. Post #428
    Gold Member
    thegtz's Avatar
    January 2007
    102 Posts
    Is this addon still going to get updated by the owner?

    Just started using it and I like it alot. Had song verification problems when I first tried it out but I just switched over to a different host and its all good now.

  29. Post #429
    Gold Banana
    Banana Lord.'s Avatar
    May 2010
    6,846 Posts
    he doesn't seem to be checking the thread and I think it's been a while since he's updated it but the addon still works

  30. Post #430
    InfernalCookie's Avatar
    December 2010
    700 Posts
    How do I download this, the SVN doesn't work for me... :S

    JK, I'm stupid. I just saw your dropbox file in the page before this one. Thanks for that even though you didn't intend for me to get it! :P
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Funny Funny x 1 (list)

  31. Post #431
    citymel's Avatar
    June 2012
    25 Posts
    i cant use svn link is not working

  32. Post #432
    Gold Banana
    Banana Lord.'s Avatar
    May 2010
    6,846 Posts
    aaa

    Edited:

    I'm almost kinda tempted to take this project over if Wolf doesn't show his face

  33. Post #433
    Gold Banana
    Banana Lord.'s Avatar
    May 2010
    6,846 Posts
    does anyone have a problem with me taking over the project?

    Edited:

    I have fired off a PM to mr.wolf asking for permission too, but does anyone in the community have any arguments with me taking this project over? mr.wolf will still receive all credits, I'll just be working on squashing any bugs, making it rely less on datastream, and handling any feature requests you guys may have. Oh and I'll be switching the default repository to use the one my community does (only 325 songs but feel free to suggest more, the mods at my community are in charge of reviewing and adding any requests made there)

  34. Post #434
    Gold Banana
    Banana Lord.'s Avatar
    May 2010
    6,846 Posts
    See http://facepunch.com/showthread.php?t=1193293 for 4.x, I'm going to maintain this and get it working with GMod 13 (assuming mr.wolf doesn't ask me to remove the new thread)

    Edited:

    sorry for the triple post!

  35. Post #435
    McDunkable's Avatar
    July 2012
    196 Posts
    I have just downloaded this and did all the steps correctly, I uploaded the files to my web etc.

    When I go into../DJ4

    It shows me this: ( I have it as MySQL )

    Unknown Error(2048): PHP Startup: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in Unknown on line 0

    Could someone help meh ?

  36. Post #436
    Gold Member

    October 2011
    56 Posts
    snip

  37. Post #437
    Gold Member
    thegtz's Avatar
    January 2007
    102 Posts
    when i go and try to play a song in game they all showup but upon clicking on them you can't actually hear the music

    i have installed flash for other browsers
    here is my song.php http://dongmaster420.com/wolfdj/song.php
    and here is my songlist.php http://dongmaster420.com/wolfdj/songlist.php
    I got this problem too. I can see the song playing but people hear nothing.