1. Post #161
    CyberGmod Founder PropHuntv2 Home
    Phoenixf129's Avatar
    May 2009
    954 Posts
    Code:
    [28 Dec 2011 02:59PM] ERROR: Hook 'AdvDupe2_Spawning' Failed: [addons\advdupe2\lua\advdupe2\sv_clipboard.lua:1183] attempt to index local 'Queue' (a nil value)
    [28 Dec 2011 02:59PM] [addons\advdupe2\lua\weapons\gmod_tool\stools\advdupe2.lua:814] attempt to index field 'GhostEntities' (a nil value)

  2. Post #162
    mn_chaos's Avatar
    June 2011
    588 Posts
    Fuck. Center ballsockets now lose their collsion box AND smartsnap grid. I know it is the collision box too because I have a inboard hud which tells me world angle and position, collision box surface area and client netgraph. The ballsocket center props never show up and fall through world. It does wonders for adv ballsocket though. It saved Harbringer's tank.
    Reply With Quote Edit / Delete Reply Windows XP United States Show Events Lua King Lua King x 1 (list)

  3. Post #163
    Quality over quantity.
    Unslinga's Avatar
    August 2010
    880 Posts
    Can you have a checkbox to disable ghosts? that would at least help on the ghost problem...

  4. Post #164
    Gold Member
    vexx21322's Avatar
    December 2008
    10,576 Posts
    Can you have a checkbox to disable ghosts? that would at least help on the ghost problem...
    You can set it to show % of ghost, just change it to 0.
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Agree Agree x 1 (list)

  5. Post #165
    Concept's Avatar
    July 2007
    4 Posts
    I cant save or delete. I right click to ghost the item, but when I click save nothing happens or pops up.

  6. Post #166
    Gold Member
    -TB-'s Avatar
    August 2008
    1,383 Posts
    Fuck. Center ballsockets now lose their collsion box AND smartsnap grid. I know it is the collision box too because I have a inboard hud which tells me world angle and position, collision box surface area and client netgraph. The ballsocket center props never show up and fall through world. It does wonders for adv ballsocket though. It saved Harbringer's tank.
    I'm not sure what you mean by center ballsockets, and constraints don't have physics objects so I'm even more confused.

    I cant save or delete. I right click to ghost the item, but when I click save nothing happens or pops up.
    Did you enter something for the name of the file? and check the console for errors or notifications.

  7. Post #167
    Concept's Avatar
    July 2007
    4 Posts
    Yea I entered a name for the file, and gave it a description.

  8. Post #168

    March 2011
    253 Posts
    Is there a mirror to the file since my Tortoise SVN is severely messed up.

  9. Post #169
    Gold Member
    LemONPLaNE's Avatar
    January 2008
    3,612 Posts
    Is there a mirror to the file since my Tortoise SVN is severely messed up.
    Uninstall it and install a good client, like Slik.
    Reply With Quote Edit / Delete Reply Windows 7 Sweden Show Events Dumb Dumb x 1Disagree Disagree x 1 (list)

  10. Post #170
    Gold Member
    -TB-'s Avatar
    August 2008
    1,383 Posts
    Is there a mirror to the file since my Tortoise SVN is severely messed up.
    No mirrors, so that there wont be a bunch of different versions floating around.

    Yea I entered a name for the file, and gave it a description.
    And as for the console?

  11. Post #171
    Concept's Avatar
    July 2007
    4 Posts
    Haven't modified a thing.

  12. Post #172
    Gold Member
    -TB-'s Avatar
    August 2008
    1,383 Posts
    Haven't modified a thing.
    Huh? Open the console with the tilde key ~ after you try saving and see if it says anything pertaining to AD2. You may have to enable the developer console in the options menu.

  13. Post #173
    Concept's Avatar
    July 2007
    4 Posts
    ITS WORKING!!! AMERICA!!!
    Reply With Quote Edit / Delete Reply Windows Vista United States Show Events Dumb Dumb x 3 (list)

  14. Post #174
    mn_chaos's Avatar
    June 2011
    588 Posts
    The ballscket center tool I mean.

  15. Post #175
    Gold Member
    -TB-'s Avatar
    August 2008
    1,383 Posts
    The ballscket center tool I mean.
    I tested the tool and it duplicated without any problems. The problem you report still doesn't make any sense.

  16. Post #176
    mn_chaos's Avatar
    June 2011
    588 Posts
    the ballsocket center tool when used between two props or prop and world when duped with advdupe2 will dupe sagging ballsockets that do not correctly constrain the two entity together. (For example, if I constrain two plates with the ballsocket center tool with x,y and z set to 90/-90, the tool dupes them with sagging constraints and certainly DOESNT spin with the correct restraint input in the first place. This occurs with world too. I hope that explained the matter better.

  17. Post #177
    Gold Member
    -TB-'s Avatar
    August 2008
    1,383 Posts
    I just need to know the exact values for every option on the tool, cause I did what you said and I'm not getting anything that comes close to spinning. Xrotmin set to 90 Xrotmax set to -90 and same for y and z with nothing else checked. Just out of curiosity do you have TB's duplicator installed?

  18. Post #178
    Anticept's Avatar
    November 2005
    98 Posts
    I've added you to friends on steam -TB-, I'd like to talk about integrating AD2 and making it part of wire...









    Just kidding. But seriously, if this addon works, I see no reason to keep AD1 in wire, and just bridging it to your repo with an svn:external. I would like to ask permission though, if you disappear or stop maintaining it, that the wireteam would be able to take over.

    EDIT: What, no credit to TAD2020 for his original Adv Dupe? :P

    That's great.
    Finally I can have this useful thingy without the god damned wire.
    We've never had AD1 rely on wire. The only reason it was ever packaged alongside wire is because TAD2020 was also developing wiremod, and our subversion repository was a convenient place to put it. /shrug
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Winner Winner x 2Artistic Artistic x 1 (list)

  19. Post #179
    gamerpaddy's Avatar
    March 2009
    337 Posts
    hello again,
    got this error:
    [AdvDupe2Notify] Could not open [@addons/advdupe2/lua/advdupe2/sv_codec.lua:645] attempt to read AD2 file with malformed info block

    i saved the dupes with rev,36 on my server.. i made a backup to my pc (via ftp) and after reinstall. i upload the files.. and the error appears...
    now on every server + Singleplayer

    :(

  20. Post #180
    mn_chaos's Avatar
    June 2011
    588 Posts
    No. I removed your old duplicator as soon as you released this.

  21. Post #181
    Gold Member
    -TB-'s Avatar
    August 2008
    1,383 Posts
    Yes, i need them to never undo.
    Code:
    [28 Dec 2011 02:59PM] ERROR: Hook 'AdvDupe2_Spawning' Failed: [addons\advdupe2\lua\advdupe2\sv_clipboard.lua:1183] attempt to index local 'Queue' (a nil value)
    [28 Dec 2011 02:59PM] [addons\advdupe2\lua\weapons\gmod_tool\stools\advdupe2.lua:814] attempt to index field 'GhostEntities' (a nil value)
    Fixed in revision 37.

    Just kidding. But seriously, if this addon works, I see no reason to keep AD1 in wire, and just bridging it to your repo with one of those-link-thingies-that-svn-supports-which-i can't-remember-what-they-are-called-right-now. I would like to ask permission though, if you disappear or stop maintaining it, that the wireteam would be able to take over.
    Yeah, let's discuss it.

    hello again,
    got this error:
    [AdvDupe2Notify] Could not open [@addons/advdupe2/lua/advdupe2/sv_codec.lua:645] attempt to read AD2 file with malformed info block

    i saved the dupes with rev,36 on my server.. i made a backup to my pc (via ftp) and after reinstall. i upload the files.. and the error appears...
    now on every server + Singleplayer

    :(
    You will need to upload a couple of the files that are having the problem and post the link to them, then I'll get Donovan to look into it.

    No. I removed your old duplicator as soon as you released this.
    Still need exact steps on how to reproduce the problem. If I can't reproduce it I can't fix it.

  22. Post #182
    Calypso2300's Avatar
    June 2007
    33 Posts
    I'm having a problem myself....
    anything I try to spawn with AD2 has a wierd glitch-out when I try to walk on it..
    my perspective keeps bobbing up and down like I'm falling through the prop but the prop is trying to force me to stay above it. when it gets really bad, my perspective flickers underground.
    as far as I can tell, I'm actually walking on it fine, but the perspective is screwy.
    I've been assuming that the tool is parenting with most of the constraints borked and refusing to leave the parenting alone.

    this happens for both AD1 and AD2 contraptions. frozen or otherwise.

    Server I'm experiencing it on is a SB2 server, but I don't know how much difference that makes.
    happens with all settings I try it on.

    Paste at original position - On
    Paste with Constraints - On
    All other settings - Off

    oddly, whenever I open a contraption, it resets the settings so that Paste at original position is off, and Paste with Parenting is On.

    I have no solutions, I'm up to date on AD2, but I don't know about the server itself. I'll test it on singleplayer and get back to you...

  23. Post #183
    Gold Member
    -TB-'s Avatar
    August 2008
    1,383 Posts
    Are you trying to walk on it while it's frozen after pasting? And does unfreezing it and walking on it help?
    I have seen this bug due to that gmod bug that causes smart snap to disappear if so.

    If that's not the case do you have some kind of prop walking mod or player mod installed?

    If none of those send me the dupe and tell me what I need to paste it.

  24. Post #184
    Calypso2300's Avatar
    June 2007
    33 Posts
    ah, useful advice :) thanks.
    unfreezing then refreezing the props resulted in the glitching stopping.

    this is great for most applications, but when I'm trying to continue working on my frozen space station...its a pain. and everyone and their mum on the server will cry lag and let slip the bans of war.
    hopefully an update will remove the need but I have at least got a stopgap solution now :)

  25. Post #185
    Gold Member
    -TB-'s Avatar
    August 2008
    1,383 Posts
    Yeah its a gmod bug, there's nothing I can do about it. There is an option on the tool in the experimental section that is a work around for the problem.

    Edit* Its the option to disable Dupe spawn protection.
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Friendly Friendly x 1 (list)

  26. Post #186
    gamerpaddy's Avatar
    March 2009
    337 Posts
    You will need to upload a couple of the files that are having the problem and post the link to them, then I'll get Donovan to look into it.
    http://gamerpaddy.bplaced.net/dupe2/dupes.zip

  27. Post #187
    Gold Member
    -TB-'s Avatar
    August 2008
    1,383 Posts
    Hmm, I cannot extract the files out of the zip, it gives an error. It seems that the files may have just got corrupted some how when you first back them up.

    "Unknown method in car.txt" says that for all the files and then
    "No files to extract"

  28. Post #188
    mn_chaos's Avatar
    June 2011
    588 Posts
    Still have the problem. Step by step instructions on how to replicate the horrid socket duping.

    Spawn 1 default phx plate(any size will do it). Rotate it so it is aligned north.

    Take out the center ballsocket toll, turn rotation constraint ON, and set x,y and z min and max to -90 and 90 respectively.

    Click the prop and then the ground.

    Duplicate and paste. What happens to me is the plate sags (it does the same in respect to other props as well) and z seems to have no rotation constraint at all.

  29. Post #189
    Gold Member
    -TB-'s Avatar
    August 2008
    1,383 Posts
    Okay, I did all of this. Is the prop not supposed to rotate at all and just be able to move around? Because that's what I'm seeing. Though it's not constrained to anything so I don't see how it can sag.

    If you want you can just add me on steam and show me on my server.

  30. Post #190
    gamerpaddy's Avatar
    March 2009
    337 Posts

    Left upper corner,since rev 37

  31. Post #191
    Gold Member
    -TB-'s Avatar
    August 2008
    1,383 Posts
    There should be an error in the console.

  32. Post #192
    CyberGmod Founder PropHuntv2 Home
    Phoenixf129's Avatar
    May 2009
    954 Posts

    Left upper corner,since rev 37
    Timer Error: [weapons\gmod_tool\stools\advdupe2.lua:1766] attempt to compare number with nil

  33. Post #193
    Gold Member
    -TB-'s Avatar
    August 2008
    1,383 Posts
    Fixed in Revision 38.
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Informative Informative x 2Lua King Lua King x 1 (list)

  34. Post #194
    zild1221's Avatar
    August 2008
    16 Posts
    LIES! It's still happening in rev. 38. I just updated my client and my server (Actually a fresh SVN Checkout), and this problem still persists.

    Code:
    Timer Error: [weapons\gmod_tool\stools\advdupe2.lua:1773] attempt to compare number with nil

  35. Post #195
    Mr Donovan's Avatar
    August 2008
    124 Posts
    Hmm, I cannot extract the files out of the zip, it gives an error. It seems that the files may have just got corrupted some how when you first back them up.

    "Unknown method in car.txt" says that for all the files and then
    "No files to extract"
    I was able to extract them.

  36. Post #196
    Gold Member
    -TB-'s Avatar
    August 2008
    1,383 Posts
    LIES! It's still happening in rev. 38. I just updated my client and my server (Actually a fresh SVN Checkout), and this problem still persists.

    Code:
    Timer Error: [weapons\gmod_tool\stools\advdupe2.lua:1773] attempt to compare number with nil
    Ops, missed one line of code. Fixed now in revision 39.
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Funny Funny x 1 (list)

  37. Post #197
    Mr Donovan's Avatar
    August 2008
    124 Posts
    hello again,
    got this error:
    [AdvDupe2Notify] Could not open [@addons/advdupe2/lua/advdupe2/sv_codec.lua:645] attempt to read AD2 file with malformed info block

    i saved the dupes with rev,36 on my server.. i made a backup to my pc (via ftp) and after reinstall. i upload the files.. and the error appears...
    now on every server + Singleplayer

    :(
    I took a look at your files. Unfortunately, it appears that your files were transferred in text mode instead of in binary mode. This caused all instances of the character sequence "\r\n" (Windows newline) to be replaced with "\n" (newline elsewhere). Due to the methods used to encode AdvDupe2 files, this is not simply reversible. At this time, the AdvDupe2 codec supports error detection but not error correction.

    I have committed an update making the resulting error message more informative.
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Informative Informative x 1 (list)

  38. Post #198
    Chubsmagee's Avatar
    August 2011
    25 Posts
    Edit: Problem solved

  39. Post #199
    mn_chaos's Avatar
    June 2011
    588 Posts
    Whatever youve done, Its fixed. Thank you.

  40. Post #200
    Gold Member
    -TB-'s Avatar
    August 2008
    1,383 Posts
    Revision 41 fixes any parented physics objects that were able to fall not fall anymore, fixing possible server crashes, and sucking performance from falling physics.

    Thanks to Kafouille for helping me find a fix.
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Winner Winner x 2 (list)