1. Post #1
    PC Camp's Avatar
    July 2007
    363 Posts
    I get this error when I try to start gmod. I'm at the loading screen, and all the sudden I get the following error:



    Anyone have any idea on how to fix this? I tried a full gmod cleanup.

  2. Post #2
    Gold Member
    earthHunter's Avatar
    May 2006
    35 Posts
    This is happening to me, several of my friends, and several of their friends also.

  3. Post #3
    Mole2005's Avatar
    February 2006
    2 Posts
    PC Camp posted:
    I get this error when I try to start gmod.
    It seems to be happening to everyone in one way or another. Did you get a random update and now its refusing to work?

    I'm guessing we have to play the usual post-release waiting game.

  4. Post #4
    Gold Member
    Looter's Avatar
    July 2005
    548 Posts
    Yea, same problem here.

  5. Post #5
    PC Camp's Avatar
    July 2007
    363 Posts
    I'm deleting all my games and everything and reinstalling them now. I'll get back in the morning and hopefully it works.

  6. Post #6
    R33l Owntag3's Avatar
    May 2006
    44 Posts
    This seems to be happening to everyone for sure, 18 of my friends opened friends and have been complaining on different chat boxes. (18 windows opened) so this isn't scaled to a OS Vista/XP because it's heppening everywhere.

  7. Post #7
    PC Camp's Avatar
    July 2007
    363 Posts
    I have XP so this problem is for everyone.

  8. Post #8
    thepwnerer's Avatar
    July 2007
    5 Posts
    I have this problem, also.

  9. Post #9
    PC Camp's Avatar
    July 2007
    363 Posts
    Along with everyone who recently updated gmod. Randomly! :o

  10. Post #10
    ejundersc0re's Avatar
    May 2008
    17 Posts
    My Gmod crashes on start-up after a random update by "Steam" But I get this error Message...



    The exception unknown software exception (0xc0000409) occurred in the application at location 0x12dbb428



    please help, DATE CRASHED 6-11-08 TIME CRASHED 8:40.56

  11. Post #11
    El Gato Rojo's Avatar
    June 2008
    6 Posts
    I may just be stating the obvious, but here it goes: if the crashing is happening on every OS, the OS isn't the problem. Most likely, Garry got some 1s and 0s mixed up in the programing of the update.

  12. Post #12
    Gold Member
    Kronos Zul's Avatar
    February 2008
    735 Posts
    Same here. :(
    Error posted:
    The Instruction at "0x00010109" a referenced memory at "0x09d11554". The memory could not be "written".

    Click on OK to terminate the program
    :crying:

  13. Post #13
    Gold Member
    huntskikbut's Avatar
    November 2005
    735 Posts
    GMod didn't get updated recently though? :raise: I think it was that TF2 update.

  14. Post #14
    AlexG2490's Avatar
    October 2007
    12 Posts
    I'm not getting the error mentioned in the original post. I just see the loading screen (the blurred out version of the citadel courtyard) for 20-30 seconds, and then it crashes with a, "HL2.exe has stopped working" error. Is this the same issue, or do I have a separate problem to track down?

    There are two issues that make me think something else might be up, either with Steam or my computer on the whole:

    1. I tried to merge a folder with my addons folder but the file transfer just got stuck and I would have to restart windows explorer. This was fixed after a restart but it made me fear for my hard drive.

    2. I tried to launch Half Life 2 when Gmod wasn't acting right and got a "Platform Error: Module failed to initialize" error, but that was fixed by disabling the Steam Community ingame.

    So, I don't mean to hujack the thread, but perhaps could some other Vista people tell me if they're having Gmod issues the same way I am, instead of that error? I just wish I'd checked the forums before deleting garrysmod and redownloading so many times.

  15. Post #15
    TetaBonita's Avatar
    May 2005
    117 Posts
    I got it too (surprise surprise). Somebody broke something again... (Valve's fault?)

  16. Post #16
    Darebear's Avatar
    August 2006
    19 Posts
    Okay, so it's good to know it's not just me.

    We'll just have to wait for Garry to get a fix out.

  17. Post #17
    Niyou77's Avatar
    June 2008
    20 Posts
    AlexG2490 posted:
    I'm not getting the error mentioned in the original post. I just see the loading screen (the blurred out version of the citadel courtyard) for 20-30 seconds, and then it crashes with a, "HL2.exe has stopped working" error. Is this the same issue, or do I have a separate problem to track down?

    There are two issues that make me think something else might be up, either with Steam or my computer on the whole:

    1. I tried to merge a folder with my addons folder but the file transfer just got stuck and I would have to restart windows explorer. This was fixed after a restart but it made me fear for my hard drive.

    2. I tried to launch Half Life 2 when Gmod wasn't acting right and got a "Platform Error: Module failed to initialize" error, but that was fixed by disabling the Steam Community ingame.

    So, I don't mean to hujack the thread, but perhaps could some other Vista people tell me if they're having Gmod issues the same way I am, instead of that "0x00010109" error? I just wish I'd checked the forums before deleting garrysmod and redownloading so many times :P.
    Hey Alex. I am running on Vista and I get the same error. I haven't tried Half-Life 2 yet, but I am getting the "stopped working."

  18. Post #18
    What fun is it being cool if you can't wear a sombrero?
    Combineguy's Avatar
    June 2006
    2,309 Posts
    Yeah, a fresh reinstall doesn't do anything. If you launched it and it randomly updated chances are you're in the same bucket as the rest of us.

  19. Post #19
    Gold Member
    waxrock's Avatar
    October 2006
    3,162 Posts
    I am so glad I didn't update yet... was too busy playing CSS.

  20. Post #20
    Stars1477's Avatar
    June 2008
    27 Posts
    doesn't garry test the update before uploading it?

    Edit:

    doesn't garry test the update before uploading it?

  21. Post #21
    What fun is it being cool if you can't wear a sombrero?
    Combineguy's Avatar
    June 2006
    2,309 Posts
    It's not a real update if it says the last update was released in April.

  22. Post #22
    AlexG2490's Avatar
    October 2007
    12 Posts
    Thank Goodness! That's a load off my mind. Or at least it will be if everything's good in a day or so.

    Edit: Spelling changed in some instances for smartness

  23. Post #23
    danielblarg's Avatar
    December 2007
    4 Posts
    Niyou77 posted:
    Hey Alex. I am running on Vista and I get the same error. I haven't tried Half-Life 2 yet, but I am getting the "stopped working."
    Vista must just simplify the error or something.

  24. Post #24
    AlexG2490's Avatar
    October 2007
    12 Posts
    That's possible, Daniel. In the interests of completeness, here is the full problem report submitted from the Vista Problem Reports and Solutions Center

    Removed because all those codes and numbers were killing my smartness

  25. Post #25
    tomg's Avatar
    December 2007
    1 Posts
    well at least its not just me, still a bit annoying though.

  26. Post #26
    Glod Menber
    Amez's Avatar
    June 2008
    6,682 Posts
    I have the same problem as well. Also Camp how did you get that marvelous GUI for Xp?

  27. Post #27
    Visage's Avatar
    January 2008
    648 Posts
    My error is the same as the above only it says something about "Priviledged Instructions." Running it vanilla didn't help.

  28. Post #28
    Gold Member

    July 2006
    1,951 Posts
    I don't get any errors. It just shuts down immediately after loading.

  29. Post #29
    midnar's Avatar
    June 2007
    9 Posts
    waxrock posted:
    I am so glad I didn't update yet... was too busy playing CSS.

    thank god for cs:s same here

  30. Post #30
    Glod Menber
    Amez's Avatar
    June 2008
    6,682 Posts
    DarKSunrise posted:
    I don't get any errors. It just shuts down immediately after loading.
    As it does for me. I get no error at all, just a standard COD, crash to Desktop.

  31. Post #31
    Gold Member
    oxcjae.'s Avatar
    July 2006
    911 Posts
    Garry's Mod was doing just fine for me the other night, now it's doing this. Surely it can't be our fault.

  32. Post #32
    Gold Member
    Fables's Avatar
    August 2007
    4,239 Posts
    DarKSunrise posted:
    I don't get any errors. It just shuts down immediately after loading.
    I've got Vista and get the same problem, it seems VALVe's been updating not giving a rats ass about GMOD

  33. Post #33

    January 2008
    5 Posts
    We all know this aitn first time this game has been screwed. ALl just stay calm, wait for new update, this has been noted and under repair.

  34. Post #34
    nukewinter's Avatar
    January 2008
    7 Posts
    Same thing here. Hopefully Garry will fix it. Hopefully.

  35. Post #35
    Gold Member
    Veribigbos's Avatar
    October 2007
    696 Posts
    I suppose most of you might know this, but still; There is no reason to post something like "i'm not getting that error i'm getting this" since XP users get an actual error message like the one in the first post, and Vista doesn't display the error, instead Vista users see "hl2.exe stopped working" or a similar message.

  36. Post #36
    Visit my Minecraft Universe at: mrfj.webs.com
    mr_fj's Avatar
    November 2006
    1,530 Posts
    I don't think it's Garrys fault. I'm getting the error in all games, except Half Life 2. Hmm...

    Edit: The plot Thickens! :O

  37. Post #37
    Larry G's Avatar
    May 2008
    149 Posts
    For all we know, Garry's Mod is dead.
    None can actually make it beyond the loading screen of Death.






    I just hope Garry'd somehow fix this. It's really annoying. :sigh:

  38. Post #38

    May 2008
    8 Posts
    PC Camp posted:
    I'm deleting all my games and everything and reinstalling them now. I'll get back in the morning and hopefully it works.
    your doing all that work for nothing because it was an update that screwed the game. so Gary will (hopefully) fix it.

  39. Post #39
    El Culo's Avatar
    March 2008
    9 Posts
    There's people online, actually.

    One of my mates is online, lucky.

  40. Post #40
    madman983's Avatar
    April 2008
    2 Posts
    This error is very anoying. oh well back to playing CoD4 then