1. Post #1
    joe7721's Avatar
    July 2006
    11 Posts
    This is a glitch that i have had for a year now, I used to be able to run non-dedicated servers fine, And i played everyday. But one day a garrysmod update came out and for reasons unknown ever since that update i have not been able to make a server. It's been a year now, And even with the two recently released patches, Multiple game reinstalls, The fact that i'm not using a router of any kind, I still have this glitch.

    I can run a server and people can see it online, But when they try to join, It never lets them in, It gives them the error "Connection failed after 4 retrys.", And they never get to join.

    I have tried everything i can possibly think of to get rid of this error, I have reinstalled my game, Tried running the game without a firewall, etc, But it still won't work.

    I rememeber also that someone made a megathread on this same issue, But it eventually died without any solid solution being posted.

    I have been waiting patiently for a patch or a fix for this problem. It's been a year now. I had a lot of friends that used to come on my non-dedicated server just to mess around and build stuff, Since my server busted i've never seen any of them again. That and two updates have been released, But neither have done anything about this problem or even mention it.

    I do not use a router. I have tried running the game without a firewall. I have reinstalled garrysmod. I have tried running a server without any mods or addons. I have tried typing "sv_lan 0" and "heartbeat". None of these work so far.

    Has anybody found a fix or a solution?
    Reply With Quote Edit / Delete United States Show Events

  2. Post #2
    okopipurtdfr's Avatar
    July 2008
    6 Posts
    Your not alone with this problem.

    It happen's to me aswell, but to random people.
    Some friend's can join, some friends cant.

    Sometime's it say's the server is not responding as well.
    The only fix i could find was to get your friend's to find the server on the server list and join from there, and even then it didn't work somtimes.

    A fix for this would be great.
    Reply With Quote Edit / Delete United Kingdom Show Events

  3. Post #3
    J23's Avatar
    July 2008
    8 Posts
    You have to forward ports with your friend.
    Reply With Quote Edit / Delete Germany Show Events

  4. Post #4
    flapjax's Avatar
    December 2006
    12 Posts
    I have the same problem, and so does apparently a lot of people. Does it happen off and on, or does it happen every time you make a server? Cause when I make a listen server, it happens like 2/3rds of the time. I sometimes just restart my computer and that fixes it.
    Reply With Quote Edit / Delete United States Show Events

  5. Post #5
    jammupaska's Avatar
    July 2008
    2 Posts
    this happens to me too. i heard that someone knows the solution for it. i'm currently googling it, and i also asked steam about it.
    Reply With Quote Edit / Delete Finland Show Events

  6. Post #6

    September 2008
    1 Posts
    I am having a similar problem,
    im hosting a Gmod server with srcds. I can join just fine, but when a friend joins they get the Connection failed after 4 retries error or they time out at Sending client info.
    after i tried "Heartbeat" my friend connects but gets droped form the server after 10seconds.

    Im wondering if anyone here could shed some light on this issue?
    Reply With Quote Edit / Delete United Kingdom Show Events

  7. Post #7
    kennethffx2's Avatar
    October 2005
    1 Posts
    Plox help with this. I am also in need of help! I have two PC's in my room, on my Dell computer I can connect to any server I want. But on my Asus machine I keep getting the Connection Failed error. But it doesn't happen on all servers...just 80% of them.
    Reply With Quote Edit / Delete United States Show Events

  8. Post #8
    agirit's Avatar
    November 2008
    3 Posts
    Open and allow all ports, or you can open himachi and connect to a meeting group. That is what I do.
    Reply With Quote Edit / Delete United States Show Events

  9. Post #9

    January 2008
    85 Posts
    I have the same problem (Oh please don't ****ing even say i havent forwarded them, i added like big list and forwarded from everywhere mostly. But yeah i need help.
    Reply With Quote Edit / Delete Estonia Show Events

  10. Post #10

    December 2008
    8 Posts
    yeah, im stuck with this...can these types of threads stop dying, we need posts helping out, theres gotta be someone that knows how to fix this, i forwarded ports (even though i dont have a router), made a dedicated server, listen server, heartbeat + sv_lan 0, reinstalled, tried a different computer, everything is how it should be but HOSTING a server does not work
    Reply With Quote Edit / Delete United Kingdom Show Events

  11. Post #11

    November 2013
    3 Posts
    I too suffer this pain, and im sorry im reopening this tomb, but we need a fix... its been YEARS!!!

    (User was banned for this post ("Awful bump" - Craptasket))
    Reply With Quote Edit / Delete Windows 7 United States Show Events