1. Post #1
    Gold Member
    i_speel_good's Avatar
    June 2006
    3,267 Posts
    So I want to decompile the Spy player model. Open up XVI32, change "IDST0" to "IDST," and decompile. Decompiler crashes. Tried with "IDST.", "IDST/" and even with "IDST0" itself.

    Nothing.

    No checkbox is checked.

    Decompiler is in the sourcesdk/bin/ep1/bin folder, it's version 0.5 (latest), because it doesn't run at all from the sourcesdk/bin folder.

    Yes, I googled. Everyone said "IDST0" to "IDST,".

  2. Post #2
    Zyx
    Guest 3855 is lost and can't find the park exit
    Zyx's Avatar
    February 2005
    2,831 Posts
    It might just be a typo in your post, but it looks like you used IDST. instead of IDST,

    and try running ot from the orangebox/bin folder instead?

  3. Post #3
    Gold Member
    Lord Ned's Avatar
    April 2006
    3,702 Posts
    -Sound Scissors Make-
    Reply With Quote Edit / Delete Reply United States Show Events Funny Funny x 1 (list)

  4. Post #4
    Gold Member
    i_speel_good's Avatar
    June 2006
    3,267 Posts
    It might just be a typo in your post, but it looks like you used IDST. instead of IDST,
    I used comma, a stop and a slash. None worked

    and try running ot from the orangebox/bin folder instead?
    "The procedure entry point Q_AppendSlash could not be located in the dynamic link library vstdlib.dll."

    Also, Lord Ned sent me the files, but I still wanna fix this incase I want to decompile something else.

  5. Post #5
    F T
    Gold Member
    F T's Avatar
    December 2008
    8,631 Posts
    IDST0 to IDSTO?

    I can decompile TF2 Player models just fine, if need be, I could give you whatever one you want.
    Reply With Quote Edit / Delete Reply United States Show Events Friendly Friendly x 2 (list)

  6. Post #6
    Gold Member
    Lord Ned's Avatar
    April 2006
    3,702 Posts
    Put it in sourcesdk/bin/ep1/bin, not orangebox
    Reply With Quote Edit / Delete Reply United States Show Events Bad Reading Bad Reading x 2Agree Agree x 2Disagree Disagree x 1 (list)

  7. Post #7
    Gold Member
    i_speel_good's Avatar
    June 2006
    3,267 Posts
    Put it in sourcesdk/bin/ep1/bin, not orangebox
    Read the OP better

    Decompiler is in the sourcesdk/bin/ep1/bin folder
    Edited:

    IDST0 to IDSTO?
    Didn't work sadly. Thanks anyway!

  8. Post #8
    Gold Member
    Campin Carl's Avatar
    October 2006
    5,254 Posts
    Dont do that IDST thingy, but use this decomp instead: http://www.filefront.com/14033171/md...er_hacked.zip/
    It works like a charm no matter what tf2 stuff I decompile

  9. Post #9
    Gold Member
    i_speel_good's Avatar
    June 2006
    3,267 Posts
    Won't do justice either.

  10. Post #10
    insert long title here
    SEKCobra's Avatar
    January 2009
    15,152 Posts
    After Changing IDST0 to IDST, (in the model) it worked for me, but the animations are all fucked up D:

  11. Post #11
    Gold Member
    i_speel_good's Avatar
    June 2006
    3,267 Posts
    Okay, this is weird.

    With the hacked decompiler, I can only decompile the Pyro. Nothing else.

    And that's probably only because the Pyro doesn't have any facial expressions and such.

  12. Post #12
    You can't expect the universe and its entire contents to be contained within the confines of a tent.
    Sonic Fan's Avatar
    February 2008
    1,846 Posts
    Aww man TF2 playermodels and the decompilers acts like a bitch!

  13. Post #13
    three wieners
    SuperEmoBros's Avatar
    August 2009
    908 Posts
    Okay, this is weird.

    With the hacked decompiler, I can only decompile the Pyro. Nothing else.

    And that's probably only because the Pyro doesn't have any facial expressions and such.
    Yeah, the Pyro wears a ask so he doesn't have any facial expressions. Also the TF2 player models have different face designs than the HL2 ones, but I don't know if that's what's wrong.

  14. Post #14
    Silver Spirit's Avatar
    July 2009
    4,870 Posts
    I have the same problem with the L4D models, I can start the decompiling if I change them from IDST1 to IDST, but it crashes and only gives me a .vta file (the expressions file).

  15. Post #15
    Gold Member
    i_speel_good's Avatar
    June 2006
    3,267 Posts
    Yeah, L4D models only work with an older decompiler.

  16. Post #16
    Silver Spirit's Avatar
    July 2009
    4,870 Posts
    Yeah, L4D models only work with an older decompiler.
    Do they, which decompiler do you need, I've tried StudioCompiler and MdlDecompiler and neither of those worked.

  17. Post #17
    Gold Member
    i_speel_good's Avatar
    June 2006
    3,267 Posts
    MDLDecompiler 0.4 I think. Also, try with AND without IDST,

  18. Post #18
    Furryous's Avatar
    September 2009
    5 Posts
    I've had the exact same problem.

    I've used the hacked decompiler, edited my gameinfo.txt file to ignore the ToolsAppID issue, etc.
    I can get the decompiler to tell me it's loaded a model, as long as I manually type in the actual path to the .mdl file, (trying to use the browse feature crashes the decompiler).
    When I actually hit "Extract", the decompiler simply crashes.

    I had previously extracted everything from the TF2 set about 6 months ago, but just recently realized that the .VTA for the engineer didn't successfully get extracted. (The .vta's for all the other characters came out just fine).

    I don't suppose anybody has a mdldecompiler_expressions.vta for the engineer out there that they'd be willing to send me do they???

  19. Post #19
    Gold Member
    ferdam's Avatar
    June 2005
    2,057 Posts
    Well, so why don't you try MDLDecompiler 0.4 ? As you said, only Pyro could be decompiled because he has no facial expressions, and MDLD 0.4 worked on L4D models (L4D models have the problem that can't be decompiled with facial animations).

  20. Post #20
    Silver Spirit's Avatar
    July 2009
    4,870 Posts
    Well, so why don't you try MDLDecompiler 0.4 ? As you said, only Pyro could be decompiled because he has no facial expressions, and MDLD 0.4 worked on L4D models (L4D models have the problem that can't be decompiled with facial animations).
    Really? Thats the only part I can get when decompiling them O.o

  21. Post #21
    Gold Member
    i_speel_good's Avatar
    June 2006
    3,267 Posts
    Well, so why don't you try MDLDecompiler 0.4 ? As you said, only Pyro could be decompiled because he has no facial expressions, and MDLD 0.4 worked on L4D models (L4D models have the problem that can't be decompiled with facial animations).
    I've already tried 3 versions (newest, hacked, 0.4) with and without IDST changing

  22. Post #22
    Maxunit's Avatar
    March 2005
    73 Posts
    The hacked mdldecompiler works for me on any model...no matter if it is ep1 or ep2 engine or a hq model from FakeFactory mod.

  23. Post #23
    Stanislav SoDL's Avatar
    November 2009
    3 Posts
    I have this problem after i install Microsoft Visual Studio C++...
    Befor i did, i might decompile Tf2 models without any trouble...

    Now i want decompile PYRO.mdl and its crashed after starting (I press EXTRACT then its wrote me "LOADED model/...mdl etc.") Then Just-in-time debuggin'... i disable it by cleaning LOCAL_ Regedit files.. and just turned off it in Visual Studio.. And now its just no errors at all.. but decompiler still crash here...
    HACKED version doesnt help too..

    But... If i remember correctly.. This will fix self... dont know why.. maybe updates or something else like installing another soft...

    If any one know a cure of it... please help. Maybe some one already fix it. I hope. Thanks.

  24. Post #24
    Gold Member
    windwakr's Avatar
    September 2009
    4,603 Posts
    I have this problem after i install Microsoft Visual Studio C++...
    Befor i did, i might decompile Tf2 models without any trouble...

    Now i want decompile PYRO.mdl and its crashed after starting (I press EXTRACT then its wrote me "LOADED model/...mdl etc.") Then Just-in-time debuggin'... i disable it by cleaning LOCAL_ Regedit files.. and just turned off it in Visual Studio.. And now its just no errors at all.. but decompiler still crash here...
    HACKED version doesnt help too..

    But... If i remember correctly.. This will fix self... dont know why.. maybe updates or something else like installing another soft...

    If any one know a cure of it... please help. Maybe some one already fix it. I hope. Thanks.
    Models SMD's are included in the SDK. If you don't see them, open up the SDK and press refresh content.
    Reply With Quote Edit / Delete Reply United States Show Events Agree Agree x 3 (list)