1. Post #1
    CISC MASTER RACE.
    pentium's Avatar
    January 2008
    5,252 Posts
    Recently I was forced to fall back from an ATI Radeon HD4850 (partly because I hated the compiz support and also because it was essentially overkill) to my old 7300GT. This not only meant swapping cards but also swapping the drivers in Ubuntu. Now that that is complete I have one last thing that's pulling my hair out.

    I'm using a SyncMaster 225BW LCD panel (native resolution: 1680x1050 @ 60Hz) over VGA (There's a lockout in my motherboard itself which prevents DVI being used, even on PCI express video cards. I don't really understand it myself) and I'm entering the resolution and refresh rate into the xorg.conf and the driver is just ignoring it. Thus I'm stuck at 1024x768 and going any larger (a bit more fiddling got me to 1280x1024) causes the desktop to extend beyond the physical screen and I have to pan around to see my whole desktop.
    Yes, I am restarting X every time I adjust a setting in the xorg.conf file.
    Me and my friend spent a good four hours trying to figure out what was up and we are totally lost.
    Any clues?

  2. Post #2
    Gold Member
    PvtCupcakes's Avatar
    May 2008
    10,900 Posts
    Try using nvidia-settings

  3. Post #3
    Gold Member
    IpHa's Avatar
    March 2005
    1,997 Posts
    Run nvidia-xconfig. That will automatically configure xorg. After that you should be able to change the resolution any way you like, but if not use nvidia-settings.

  4. Post #4
    CISC MASTER RACE.
    pentium's Avatar
    January 2008
    5,252 Posts
    We have been using nvidia-settings but even then it will just let us go up to 1280x1024 in screen pan mode which is totally useless.
    I have my own settings I want to specify and that I know should work but it appears to have it's own settings which it seems to keep pulling out of its ass.

  5. Post #5
    Gold Member
    Cathbadh's Avatar
    March 2006
    1,071 Posts
    It's because you didn't properly configure your xorg.conf

  6. Post #6
    CISC MASTER RACE.
    pentium's Avatar
    January 2008
    5,252 Posts
    It's because you didn't properly configure your xorg.conf
    Then what the hell should I be entering?

  7. Post #7
    Gold Member
    IpHa's Avatar
    March 2005
    1,997 Posts
    Then what the hell should I be entering?
    Just let nvidia-xconfig do it for you.

  8. Post #8
    CISC MASTER RACE.
    pentium's Avatar
    January 2008
    5,252 Posts
    Just let nvidia-xconfig do it for you.
    And then what? It does very little?

  9. Post #9
    Gold Member
    Cathbadh's Avatar
    March 2006
    1,071 Posts
    I had to enter this section in to get my new monitor working:
    Code:
    Section "Screen"
        Identifier     "Screen[0]"
        Device         "Videocard0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "TwinViewOrientation" "LeftOf"
    #    Option         "MetaModes" "1680x1050"
        Option         "metamodes" "DFP-0: 1680x1050 +0+0, DFP-1: 1280x1024 +1680+0"
        SubSection     "Display"
            Depth       24
            Modes      "1680x1050"
        EndSubSection
    EndSection
    I only cared about getting it working at 1680x1050, so that's the only mode I entered in. This may only work with nvidia cards, however. And you don't need the twinview options. That's just for multihead. Handy if you have a second monitor.

    Edited:

    really, you should just look at the man pages for xorg.conf

  10. Post #10
    CISC MASTER RACE.
    pentium's Avatar
    January 2008
    5,252 Posts
    nope, I'm stuck at this shitty tiny resolution.