1. Post #1
    lilcheeselad's Avatar
    January 2009
    8,524 Posts
    So, I bought Saints Row 2 from the Steam sale the other day, and it downloaded fine and everything, but when I try to launch it, my screen just turns black then crashes to the desktop and says "sr2_pc.exe has stopped working". I have the latest drivers for my GPU, so it can't be that. My computer meets the requirements, 2 GB of ram, 2.60 ghz dual core processor, windows 7 home premium, and GTS 250. This is the only game this has happened to. I tried running DXSETUP in the DirectX folder, didn't help. What should I do? :confused:
    Reply With Quote Edit / Delete Reply United States Show Events Dumb Dumb x 1Funny Funny x 1 (list)

  2. Post #2

    October 2009
    4,686 Posts
    2.60 ghz dual core processor,:

    This is not a valid processor model.
    Locate the actual model please.
    Reply With Quote Edit / Delete Reply United States Show Events Agree Agree x 1 (list)

  3. Post #3
    lilcheeselad's Avatar
    January 2009
    8,524 Posts
    This is not a valid processor model.
    Locate the actual model please.
    AMD Athlon X2 64 5000+

    Sorry for being stupid.
    Reply With Quote Edit / Delete Reply United States Show Events Friendly Friendly x 1Dumb Dumb x 1 (list)

  4. Post #4

    October 2009
    4,686 Posts
    I've heard it is a very bad Console to PC port, so it might be that you can't run it. I have heard of people with much more powerful systems than that of yours having problems playing it.

  5. Post #5
    lilcheeselad's Avatar
    January 2009
    8,524 Posts
    Damn, oh well. I used to have it for the 360 and I loved it.
    Reply With Quote Edit / Delete Reply United States Show Events Optimistic Optimistic x 1 (list)

  6. Post #6

    October 2009
    4,686 Posts
    I would wait for a few more people to look at this and give their opinions on it though. I usually learn most of my info from things I read, and not everything is correct.
    Reply With Quote Edit / Delete Reply United States Show Events Informative Informative x 1 (list)

  7. Post #7
    dustbusta's Avatar
    May 2009
    1,447 Posts
    I have no idea how to help but I like your Descendants avatar.
    Reply With Quote Edit / Delete Reply Canada Show Events Agree Agree x 1 (list)

  8. Post #8
    lilcheeselad's Avatar
    January 2009
    8,524 Posts
    Apparently some guys had the same problem as me, they updated their sound drivers and it worked. I might try that.

    Edited:

    Also, thanks dustbusta.
    Reply With Quote Edit / Delete Reply United States Show Events Optimistic Optimistic x 1 (list)

  9. Post #9
    Penis Architect
    paul simon's Avatar
    November 2008
    9,779 Posts
    I've downloaded it, but haven't tried running it yet.

    GPU: GTX 280
    CPU: i7 920
    RAM: 6GB

    I'll try it now.

  10. Post #10
    lilcheeselad's Avatar
    January 2009
    8,524 Posts
    I've downloaded it, but haven't tried running it yet.

    GPU: GTX 280
    CPU: i7 920
    RAM: 6GB

    I'll try it now.
    What OS are you using?
    Reply With Quote Edit / Delete Reply United States Show Events Optimistic Optimistic x 1 (list)

  11. Post #11
    Penis Architect
    paul simon's Avatar
    November 2008
    9,779 Posts
    Windows 7 64bit, and i have no problems starting it up.

    Edited:

    Actually, i tried starting it once when i had my Q6600 with no success, so the processor might be the problem.

    Not sure though.

  12. Post #12
    lilcheeselad's Avatar
    January 2009
    8,524 Posts
    Should I try and reinstall it and see if that works?
    Reply With Quote Edit / Delete Reply United States Show Events Optimistic Optimistic x 1 (list)

  13. Post #13
    I survived Camp FP 2010
    Mattz333's Avatar
    June 2007
    1,661 Posts
    Yes, try a reinstall.

    Also you might want to try posting on the SR2 forums, you might get some better answers there. Although it might not be worth it, I'm running it on 9800GTX+ with ~3Ghz dual core (amd) with 4gb RAM and I still don't get a stable frame rate, the only reason I play it is for the mods.

  14. Post #14
    lilcheeselad's Avatar
    January 2009
    8,524 Posts
    When I try to start it up, the screen goes black, BAM, it crashes. No logos or stuff.

    Edited:

    Ok, I'll try and reinstall it.

    Edited:

    Holy shit guys, I got it to work. I have dual monitors, so before I was going to reinstall the game, I tried one solution someone posted on a forum, I made my other monitor the main one and had Saints Row 2 launch on it, and it started up perfectly. Holy crap. :buddy:

    Edited:

    The cutscenes are really laggy, but the actually gameplay isn't laggy.. Strange.
    Reply With Quote Edit / Delete Reply United States Show Events Dumb Dumb x 1 (list)

  15. Post #15
    Penis Architect
    paul simon's Avatar
    November 2008
    9,779 Posts
    I experienced exactly the same.

    Game runs at 60fps, cutscenes are laggy.


    Also, it's like it's running in fast motion, is the game supposed to be like that?

  16. Post #16
    What fun is it being cool if you can't wear a sombrero?
    Dennab
    June 2006
    2,334 Posts
    No. It's a bug with Volition's shitty ports.

  17. Post #17
    lilcheeselad's Avatar
    January 2009
    8,524 Posts
    Wow, this game really is a bad port. :/
    Reply With Quote Edit / Delete Reply United States Show Events Optimistic Optimistic x 1 (list)

  18. Post #18
    Penis Architect
    paul simon's Avatar
    November 2008
    9,779 Posts
    Wow, it's nearly unplayabe...

    Cars drive so fast, it's nearly impossible to make turns without a complete stop.
    Reply With Quote Edit / Delete Reply Norway Show Events Agree Agree x 1 (list)

  19. Post #19
    Tashixxx's Avatar
    July 2010
    1 Posts
    When I try to start it up, the screen goes black, BAM, it crashes. No logos or stuff.

    Edited:

    Ok, I'll try and reinstall it.

    Edited:

    Holy shit guys, I got it to work. I have dual monitors, so before I was going to reinstall the game, I tried one solution someone posted on a forum, I made my other monitor the main one and had Saints Row 2 launch on it, and it started up perfectly. Holy crap. :buddy:

    Edited:

    The cutscenes are really laggy, but the actually gameplay isn't laggy.. Strange.
    Edited:

    hey i was looking at your post and i was having the same problem (saints row 2) u think u can explain what u did that would help me so much...please reply back

    Edited:

    Edited:

    hey i was looking at your post and i was having the same problem (saints row 2) u think u can explain what u did that would help me so much...please reply back
    Edited:

    thank you...

    Edited:

    So, I bought Saints Row 2 from the Steam sale the other day, and it downloaded fine and everything, but when I try to launch it, my screen just turns black then crashes to the desktop and says "sr2_pc.exe has stopped working". I have the latest drivers for my GPU, so it can't be that. My computer meets the requirements, 2 GB of ram, 2.60 ghz dual core processor, windows 7 home premium, and GTS 250. This is the only game this has happened to. I tried running DXSETUP in the DirectX folder, didn't help. What should I do? :confused:
    Edited:

    (sr2_pc.exe has stopped working)

  20. Post #20
    Gold Member
    liquid_phase's Avatar
    January 2007
    618 Posts
    There is a patch for the stupid fast car driving on Windows 7 floating about on the net. I couldn't play it on my own, but with a friend it's pretty fun with the 'gentlemen of the row' mod.

  21. Post #21

    November 2011
    1 Posts
    I know this is an old thread but I had the same problem and I know the solution. Go to the installation folder ( Program Files (x86)/Steam/Steamapps/Common/saints row 2 ) And then go to the DirectX folder, and look for the program DXSETUP . Its more torwards the middle. But after running that, you should be fine!
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Informative Informative x 1 (list)