1. Post #81

    June 2008
    43 Posts
    not works on darkrp gamemode
    Reply With Quote Edit / Delete Korea, Republic of Show Events Bad Spelling Bad Spelling x 1Informative Informative x 1 (list)

  2. Post #82
    uchiha2727's Avatar
    February 2009
    728 Posts
    HOLY SHIT! it think that Physgun will replace the old one!
    Physgun Buildmode = :godwin:

    I would make a Petition to try and replace the old physgun, but i dont think Garry Would Approve.

    i mean who wouldnt Agree with me? this physgun thing is going to be a Gmod Revolution!
    Reply With Quote Edit / Delete United States Show Events Dumb Dumb x 9Disagree Disagree x 1 (list)

  3. Post #83
    Gold Member
    nicatronTg's Avatar
    July 2009
    4,698 Posts
    HOLY SHIT! it think that Physgun will replace the old one!
    Physgun Buildmode = :godwin:

    I would make a Petition to try and replace the old physgun, but i dont think Garry Would Approve.

    i mean who wouldnt Agree with me? this physgun thing is going to be a Gmod Revolution!
    I find it useful, but making it mandatory would screw a ton of players up.
    Reply With Quote Edit / Delete United States Show Events

  4. Post #84
    Gold Member
    hexpunK's Avatar
    August 2008
    15,139 Posts
    HOLY SHIT! it think that Physgun will replace the old one!
    Physgun Buildmode = :godwin:

    I would make a Petition to try and replace the old physgun, but i dont think Garry Would Approve.

    i mean who wouldnt Agree with me? this physgun thing is going to be a Gmod Revolution!
    Physgun Buildmode = Hitler/ Nazi comparison in a online discussion? You deserve those boxes.

    Also I can't help but feel you are rubbing your ego a bit with the "best GMod tools" thing in the OP, but physgun buildmode does look pretty cool. And I might take a look at PA, I need something to replace easy precision, as it is a pain in the ass most times.
    Reply With Quote Edit / Delete United Kingdom Show Events Agree Agree x 1 (list)

  5. Post #85
    Gold Member
    Whitesinner0's Avatar
    December 2006
    945 Posts
    Also I can't help buy feel you are rubbing your ego a bit with the "best GMod tools" thing in the OP, but physgun buildmode does look pretty cool.
    Englesh pleese.
    Reply With Quote Edit / Delete United States Show Events

  6. Post #86
    Gold Member
    hexpunK's Avatar
    August 2008
    15,139 Posts
    Englesh pleese.
    Yeah I don't know what happened there, oh well easy to fix
    Reply With Quote Edit / Delete United Kingdom Show Events

  7. Post #87
    BradenFase's Avatar
    February 2008
    330 Posts
    Thanks man. Can't wait to use it to build amazing shit.
    Reply With Quote Edit / Delete United States Show Events

  8. Post #88
    Gold Member
    Dennab
    April 2008
    5,108 Posts
    I installed it but I can't seem to be able to find the buildmode toggle button and the command doesnt do anything
    Reply With Quote Edit / Delete Canada Show Events

  9. Post #89
    Gold Member
    Whitesinner0's Avatar
    December 2006
    945 Posts
    I installed it but I can't seem to be able to find the buildmode toggle button and the command doesnt do anything
    For buildmode to work you need to bind a button to phys_buildmode. E.G. bind b "phys_buildmode"
    Reply With Quote Edit / Delete United States Show Events Disagree Disagree x 1 (list)

  10. Post #90
    Pestilence2k's Avatar
    March 2007
    5 Posts
    As a Nodex admin (hopefully not as useless, ahem Will), I fully endorse this product.

    ...Like seriously. PA is the fucking win. Never seen the power of forming precise constraints and providing super-advanced prop manipulation until Wenli showed it to me last week when I came back to GMod. Seriously... Smartsnap just became a kindergarten tool.

    To those who prefer precise, visual, and advanced manipulation... This tool's for you. A steep learning curve initially, but once that is surmounted, you pretty much become a better and more precise builder. Period.

    And phys_buildmode? Simple genius. It's good someone FINALLY made it (you'd think someone would make as soon as Gmod 10 came out?). I find myself pressing the keybind to enable it loads of times to move props and provide simple snapping for the phx presets.

    10 Thumbs up =D
    Reply With Quote Edit / Delete United States Show Events Agree Agree x 2Dumb Dumb x 1 (list)

  11. Post #91
    Gold Member
    Whitesinner0's Avatar
    December 2006
    945 Posts
    As a Nodex admin (hopefully not as useless, ahem Will), I fully endorse this product.

    ...Like seriously. PA is the fucking win. Never seen the power of forming precise constraints and providing super-advanced prop manipulation until Wenli showed it to me last week when I came back to GMod. Seriously... Smartsnap just became a kindergarten tool.

    To those who prefer precise, visual, and advanced manipulation... This tool's for you. A steep learning curve initially, but once that is surmounted, you pretty much become a better and more precise builder. Period.

    And phys_buildmode? Simple genius. It's good someone FINALLY made it (you'd think someone would make as soon as Gmod 10 came out?). I find myself pressing the keybind to enable it loads of times to move props and provide simple snapping for the phx presets.

    10 Thumbs up =D
    YOU HAVE 10 THUMBS......lucky.

    Also, I agree. And Pestilence its meh Brahe!
    Reply With Quote Edit / Delete United States Show Events

  12. Post #92
    Gold Member
    Dennab
    April 2008
    5,108 Posts
    Ok now I see the menu, and can activate all the checkboxes and sliders, but nothing happens. It's like a normal physgun. (yes enabled is on and I tried the console command)
    Reply With Quote Edit / Delete Canada Show Events

  13. Post #93
    Gold Member
    Whitesinner0's Avatar
    December 2006
    945 Posts
    Single Player or Server?
    Reply With Quote Edit / Delete United States Show Events

  14. Post #94
    Gold Member
    Dennab
    April 2008
    5,108 Posts
    SP
    Reply With Quote Edit / Delete Canada Show Events

  15. Post #95
    Gold Member
    tuusita's Avatar
    June 2005
    214 Posts
    I lost the ability to type values or text into any input boxes in any of my stools when I opened Precision Alignment tool. Had to restart map in order to fix it.

    What happens is that the blinking cursor doesn't show anymore when you click on a text box. When you try to type or enter values in the box, it's as if you have no menus open. For example, when you press number keys, it will try to select a weapon, or when you type something including WASD keys, it will move your player.

    No errors in the console when this happens.

    EDIT: I'm currently testing which in which conditions the bug appears...
    EDIT2: It seems that I need to actually use a text box (aka input field) to make the bug appear. Doesn't seem to matter in which stool I input something. <- NOT ACCURATE, read on...
    EDIT3: If I start a map and the first stool I open is the 'PA' stool, input fields stop working immediately....

    EDIT3.1: Clarification
    Example, I open some other tool first that has an input field. Then I click on the input field to make the blinking cursor appear. If I don't press Enter to accept the value and cursor is still blinking, I can open 'PA' or any other tool and click on input fields and the cursor will start blinking where I click. But if press Enter to accept value and blinking cursor disappears, it will NOT appear again, no matter in which tool I click. Context menu behaves the same way. Only exceptions I tested is Wire E2 gate's Editor window and its SaveAs input field which works.

    Help? :/

    PS. I've got the v1.23.
    PSS. Until this can be fixed, I've renamed the file 'precision_align.lua' to 'precision_align.luaX' to prevent loading it. This way I won't accidentally open the tool and screw it all up...

    PSSS. I'm loving the new ballsocket. Now my rotation-wise locked together props are truly that. =)
    Reply With Quote Edit / Delete Finland Show Events

  16. Post #96

    April 2009
    118 Posts
    I lost the ability to type values or text into any input boxes in any of my stools when I opened Precision Alignment tool. Had to restart map in order to fix it.
    So, how exactly do I reproduce this? Let me describe what I'm trying, according to your description:

    [list=1][*] Go to the Rope tool (for example)[*] Click in the "Force Limit" text box to bring up the blinking text cursor[*] Immediately go to the Precision Alignment tool without pressing enter[*] Click in "Snap Sensitivity" to bring up another blinking text cursor[*] Press enter[/list]
    And now you're saying I shouldn't be able to bring up the text cursor again? It seems to work fine for me when I do this though, is what I just described correct?
    Reply With Quote Edit / Delete United Kingdom Show Events

  17. Post #97
    Gold Member
    tuusita's Avatar
    June 2005
    214 Posts
    Yes, that's one way to do it, for me at least.
    Fastest way to reproduce is to start a map, open PA tool. Voila. No matter which text box I click now, it won't work. No cursor, can't type.
    Main thing seems to be that when you've opened PA tool, it stops the blinking cursor from appearing. If it is already blinking somewhere it will allow you to input values but once you make the cursor disappear with Enter key, it won't come back.
    Reply With Quote Edit / Delete Finland Show Events

  18. Post #98

    April 2009
    118 Posts
    Are you doing this in SP or on a server?
    Reply With Quote Edit / Delete United Kingdom Show Events

  19. Post #99
    Gold Member
    tuusita's Avatar
    June 2005
    214 Posts
    Are you doing this in SP or on a server?
    SP on flatgrass

    Could it be those fancy menu items at the top of the PA tool. Do they use Derma or some such? Just tossing that out there as a stupid question. :/
    Reply With Quote Edit / Delete Finland Show Events

  20. Post #100
    Gold Member
    Whitesinner0's Avatar
    December 2006
    945 Posts
    Just tossing that out there as a stupid question. :/
    No question is stupid, not asking the question is stupid. Remember that.
    Reply With Quote Edit / Delete United States Show Events Friendly Friendly x 1 (list)

  21. Post #101
    Gold Member
    Sodisna's Avatar
    May 2007
    2,908 Posts
    So, where's the video on the Precision Alignment?
    Reply With Quote Edit / Delete United States Show Events

  22. Post #102
    OmniPillage's Avatar
    March 2008
    4 Posts
    I have the same problem as tuusita.

    1. Merge contents of zip file (1.23) with '/garrysmod/garrysmod/'

    2. Start Gmod, SP on gm_construct, no lua errors

    3. Open rope tool and type in some values, spawn some ropes

    4. Open PA tool, then go back and open another tool

    Clicking on input boxes has no response, no cursor appears. Double clicking highlights whatever value is there, but still no cursor and cannot enter any new value. Pressing number keys when highlighting inputs causes weapons to be selected.

    Check box inputs all seem to still work.

    Addons installed:

    Wire (svn)
    Phx3 (svn)
    Stargate (svn)
    gm_mount2
    Wenlis Tools


    All the tools still seem to work fine, just can't input anything in text boxes. I'll try a fresh install when I get some time if this isn't resolved by then, but once this problem is resolved, PA and the other tools are definitely going to remain in my addon folder. Thanks for providing some potentially awesome tools.

    EDIT: Inputs in the PA reload bound menu work normally.
    Reply With Quote Edit / Delete United States Show Events

  23. Post #103
    Gold Member
    Whitesinner0's Avatar
    December 2006
    945 Posts
    So, where's the video on the Precision Alignment?
    Ask Wenli, he just got back from vacation, so who knows? WAIT, Wenli does!!!!

    Also, are you having probs with PA?
    Reply With Quote Edit / Delete United States Show Events

  24. Post #104
    Gold Member
    tuusita's Avatar
    June 2005
    214 Posts
    I have the same problem as tuusita.

    ...

    Clicking on input boxes has no response, no cursor appears. Double clicking highlights whatever value is there, but still no cursor and cannot enter any new value. Pressing number keys when highlighting inputs causes weapons to be selected.
    Yes, that is exactly what happens for me too. Everything else works except typing into the input fields since there's no cursor.

    ...

    All the tools still seem to work fine, just can't input anything in text boxes. ... once this problem is resolved, PA and the other tools are definitely going to remain in my addon folder. Thanks for providing some potentially awesome tools.
    Indeed. I've already tested my wired walker contraption with the improved adv. ballsockets and it was way better than the original. Thank You Wenli! =)
    Reply With Quote Edit / Delete Finland Show Events

  25. Post #105
    OmniPillage's Avatar
    March 2008
    4 Posts
    I tried a fresh install, deleted gmod from steam menu and deleted the garrysmod folder in "steam/steamapps/username". Let me know if I missed anything.

    Problem persists as before with no addons other than Wenlis tools. Tried 1.22 and 1.23, didn't notice any difference. No console errors with either version.
    Reply With Quote Edit / Delete United States Show Events

  26. Post #106
    kp3
    Gold Member
    kp3's Avatar
    January 2008
    2,986 Posts
    So, how exactly do I reproduce this? Let me describe what I'm trying, according to your description:

    [list=1][*] Go to the Rope tool (for example)[*] Click in the "Force Limit" text box to bring up the blinking text cursor[*] Immediately go to the Precision Alignment tool without pressing enter[*] Click in "Snap Sensitivity" to bring up another blinking text cursor[*] Press enter[/list]
    And now you're saying I shouldn't be able to bring up the text cursor again? It seems to work fine for me when I do this though, is what I just described correct?
    Also happens to me, But i'm not even sure it's related to PA. Sometimes it just happens to me. But yeah, I think that's happened to me before i got pa installed.
    Reply With Quote Edit / Delete Sweden Show Events

  27. Post #107

    April 2009
    118 Posts
    EDIT: Ah I think I've found the problem, I've updated the file - please let me know if the problem persists. I still couldn't get the problem to occur on my install, so I'm not 100% certain it worked.
    Reply With Quote Edit / Delete United Kingdom Show Events Friendly Friendly x 1 (list)

  28. Post #108
    Gold Member
    tuusita's Avatar
    June 2005
    214 Posts
    EDIT: Ah I think I've found the problem, I've updated the file - please let me know if the problem persists. I still couldn't get the problem to occur on my install, so I'm not 100% certain it worked.
    Loading up Gmod now...

    EDIT:
    Result: It now works OK! Thank you!
    I still don't know how to use this tool but still, it doesn't cause that cursor loss anymore. =))
    Reply With Quote Edit / Delete Finland Show Events

  29. Post #109
    OmniPillage's Avatar
    March 2008
    4 Posts
    Everything seems to work fine with 1.24. Thanks again for the awesome tools.
    Reply With Quote Edit / Delete United States Show Events

  30. Post #110
    Luxinus's Avatar
    March 2010
    137 Posts
    Physgun buildmode isn't working... I have the menu and such the console commands work but it doesn't lock to place or anything. Any help? Also where could I get ECS? Sorry if this has been mentioned...
    Reply With Quote Edit / Delete Canada Show Events

  31. Post #111
    Gold Member
    Dennab
    April 2008
    5,108 Posts
    Physgun buildmode isn't working... I have the menu and such the console commands work but it doesn't lock to place or anything. Any help? Also where could I get ECS? Sorry if this has been mentioned...
    I have the same problem.
    Reply With Quote Edit / Delete Canada Show Events

  32. Post #112

    April 2009
    118 Posts
    I have the same problem.
    I did send you a PM when you first had the problem, but you never replied so I assumed you sorted it out.

    The first thing to check is that this addon is server-side. It'll only work if you install it on the server, or use it in single player. It won't work if you try to use it on a server that doesn't have it installed, even if you have it installed on your computer.

    If it isn't working in single player, here's the likely cause: There are certain addons that conflict with Physgun Buildmode, usually because they have a specific bug, and there's nothing I can do to fix it; it's those addons that are causing the problem.

    So far I've found the bug in MWay and GCombat Core. You can try to find the problem yourself, although it involves looking at the code (you don't need to know much lua to find the problem). Do a text search for "PhysgunPickup" in all the lua files in your addons directory. Notepad++ is what I use for this; it'll do it pretty easily using Find In Files. It should find a few files including Physgun Buildmode if you have it installed and you did the search correctly.

    What you'll find are lines like this:
    Code:
    hook.Add( "PhysgunPickup", "buildmode_grab", Phys_Grab )
    It's the LAST bit of that line you're interested in, as that tells you the name of the function it's calling. So in this case it would be the "Phys_Grab" function. If you open up the file you should be able to find the function nearby that line, or failing that you can do a text search for the function name. For example:
    Code:
    function Phys_Grab ( ply, ent )
       (lots of code here)
    end
    Somewhere in that function you're looking for it to say "return true". The problem is caused when the function returns true, and buggy addons will return true for no reason every time the function runs. When the function returns true it overrides any other function that tries to use the PhysgunPickup hook, including Physgun Buildmode. So if it's always returning true, other addons never gets a chance to run. It could very well be overriding any prop protection you have as well, because PP often relies on this hook to stop other people picking up your stuff.

    If you find the function causing the problem, you can remove the "return true" line or comment it out to make things work again. You comment things out by putting // or -- in front of the line. In Notepad++ you can do this quickly by selecting the line and pressing ctrl-k.

    Please let me know if you manage to fix the problem using this method! I would like to build a list of the offending addons, which files they're in, and which lines to comment out so other people can apply the fix more easily.

    Also where could I get ECS?
    ECS was released on the Nodex website, but we closed that down a while ago and I'm not sure you can download it any more. The guy who made the Nodex version of ECS also owns the servers, and he hasn't made it very available, so I think the only place you'll be able to use it is on the Nodex servers or maybe any other servers he's shared it with.
    Reply With Quote Edit / Delete United Kingdom Show Events

  33. Post #113
    Gold Member
    Dennab
    April 2008
    5,108 Posts

    all my addons, it has to be one of them
    Reply With Quote Edit / Delete Canada Show Events

  34. Post #114
    Gold Member
    Whitesinner0's Avatar
    December 2006
    945 Posts

    all my addons, it has to be one of them
    I thought Phys_Buildmode w/e was to be installed in account name/garrysmod.
    Reply With Quote Edit / Delete United States Show Events

  35. Post #115
    Gold Member
    tuusita's Avatar
    June 2005
    214 Posts
    (image of addons...)
    all my addons, it has to be one of them
    Probably not related but I see you have a folder named 'addons' in your addons folder. What's in there? If there's more addons, you should move them into the real addons folder because they won't load correctly or at all if they are below another folder...
    Reply With Quote Edit / Delete Finland Show Events

  36. Post #116
    Get your own DarkRP Server!
    FPtje's Avatar
    January 2006
    5,540 Posts
    Fixed in FPP and DarkRP in the latest SVN revisions.
    Physgun buildmode now works in DarkRP and FPP servers with the latest SVN.
    Reply With Quote Edit / Delete Netherlands Show Events

  37. Post #117

    April 2009
    118 Posts
    Fixed in FPP and DarkRP in the latest SVN revisions.
    Physgun buildmode now works in DarkRP and FPP servers with the latest SVN.
    Awesome... so, was it because those mods were returning true on hook functions?
    Reply With Quote Edit / Delete United Kingdom Show Events

  38. Post #118
    Get your own DarkRP Server!
    FPtje's Avatar
    January 2006
    5,540 Posts
    Yes it was.

    When returning a boolean all other hooks will be ignored.
    Reply With Quote Edit / Delete Netherlands Show Events

  39. Post #119
    Gold Member
    Balto-the-Wolf-Dog's Avatar
    June 2009
    1,817 Posts
    sorry for the small bump, but i must complement

    Precision alignment was overwelming when i first looked at it. After some time i found it to be the best tool ive used. I could live on it, hydros, fins, e2, and weld alone. I started using it to make eight blade fin nacelle propellers. They are strudy and generate a lot of lift. They also look great thanks to your genious tool.
    Reply With Quote Edit / Delete United States Show Events

  40. Post #120
    Gold Member
    Socram's Avatar
    June 2006
    1,804 Posts
    I agree this tool is really quite good, especially physgun buildmode!
    Reply With Quote Edit / Delete United States Show Events