1. Post #761
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    Yep, maps ain't working.
    Please try it on a clean, fresh GMod. I can't reproduce your problems. I can see every map when I enter "maps" into the console.

  2. Post #762
    Gold Member
    Omolong's Avatar
    December 2007
    7,613 Posts
    I see every map there, but I think everyone else means in the map select menu.
    Reply With Quote Edit / Delete Reply United Kingdom Show Events Agree Agree x 1 (list)

  3. Post #763
    Zeloutional's Avatar
    January 2010
    760 Posts
    Does Hen's "Nightmare House 2", work with GM_Mount?

  4. Post #764
    MAspiderface v2's Avatar
    April 2010
    1,580 Posts
    Does Hen's "Nightmare House 2", work with GM_Mount?
    Any source mod works with gm_mount.
    Reply With Quote Edit / Delete Reply United States Show Events Agree Agree x 1 (list)

  5. Post #765
    VeryNiceGuy's Avatar
    July 2010
    1,062 Posts
    I wish the L4D2 maps worked in GMod, I'd love to take some screenshots in there
    Reply With Quote Edit / Delete Reply Germany Show Events Agree Agree x 1 (list)

  6. Post #766
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    I see every map there, but I think everyone else means in the map select menu.
    Now I get the problem. Trying to fix it. But I will not allow adding l4d1/2 maps to that list since they do not work.

    Edited:

    Uploaded the fix. If mount2 doesn't work for you, read the changelog carefully.

    Code:
    #46
    * [Update] Updated HLLib from 2.2.0 to 2.3.0. Also compiled it as /MULTITHREADED-DLL instead of /MULTITHREADED. Visual-Studio 2010 Redistributables (x86) are now required.
    	http://www.microsoft.com/downloads/details.aspx?FamilyID=a7b7a05e-6de6-4d3a-a423-37bf0912db84&displaylang=en
    * [Fixed] Fixed maps not showing up under "Create SinglePlayer" or "Create MultiPlayer"

  7. Post #767
    Project Lead, Internet Explorer for Linux
    lavacano's Avatar
    October 2008
    14,610 Posts
    I think the map crashes may be related to the maps calling for entities that the engine doesn't have (e.g. weapon_first_aid_kit_spawn).

    I have a VMF of l4d_hospital01_apartment (No Mercy 1) with all the necessary entity changes, but I don't feel like waiting for my not-badass computer to compile it. I also don't feel like going through ALL the VMFs for Left 4 Dead 1 AND 2 and making the changes (because I went and did that manually).

    If someone would like to pick up where I left off, here's all the changes I made:
    - Removed all item spawns (mollies, pistols, etc)
    - Removed the precipitation stuff I found above the safe room stairs (though apparently I was wrong in thinking they were introduced in Left 4 Dead)
    - Changed info_survivor_* to info_player_start (so it's possible to spawn in the survivor closets - you can open them though)

    You may also PM me for the VMF

  8. Post #768
    morphhh's Avatar
    December 2007
    42 Posts
    Why the link of the non-lite version of gm_mount2 keeps breaking?

  9. Post #769
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    I think the map crashes may be related to the maps calling for entities that the engine doesn't have (e.g. weapon_first_aid_kit_spawn).

    I have a VMF of l4d_hospital01_apartment (No Mercy 1) with all the necessary entity changes, but I don't feel like waiting for my not-badass computer to compile it. I also don't feel like going through ALL the VMFs for Left 4 Dead 1 AND 2 and making the changes (because I went and did that manually).

    If someone would like to pick up where I left off, here's all the changes I made:
    - Removed all item spawns (mollies, pistols, etc)
    - Removed the precipitation stuff I found above the safe room stairs (though apparently I was wrong in thinking they were introduced in Left 4 Dead)
    - Changed info_survivor_* to info_player_start (so it's possible to spawn in the survivor closets - you can open them though)

    You may also PM me for the VMF
    Missing entities do not crahs a map. Also, many textures etc were broken.

    Edited:

    Why the link of the non-lite version of gm_mount2 keeps breaking?
    Fixed everything. Anyway, for upgrading mount2, just download the lite.

  10. Post #770
    Gold Member
    Matrix374's Avatar
    May 2010
    9,573 Posts
    How do i mount these games with the new menu?

  11. Post #771
    Add this to GM_Mount2 update #47:
    Code:
    Cut out the BloodyHands proxy on some of the melee weapons from L4D2

  12. Post #772
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    Add this to GM_Mount2 update #47:
    Code:
    Cut out the BloodyHands proxy on some of the melee weapons from L4D2
    I forgot about the PM. Sorry.

  13. Post #773
    fartboy's Avatar
    November 2008
    50 Posts
    What does this HLlib thing do, and why does it need updating?

    (I'm only asking because the way it's written makes it seem like the map fix is separate.)

  14. Post #774
    Gold Member
    Dennab
    March 2009
    2,716 Posts
    What does this HLlib thing do, and why does it need updating?

    (I'm only asking because the way it's written makes it seem like the map fix is separate.)
    I think it's for loading VPK files/New textures in L4D?
    Reply With Quote Edit / Delete Reply Czech Republic Show Events Agree Agree x 1 (list)

  15. Post #775
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    What does this HLlib thing do, and why does it need updating?

    (I'm only asking because the way it's written makes it seem like the map fix is separate.)
    HLLib is a required module which allows you loading L4D1/2 content (vpk-files).
    The latest update includes the very latest version of HLLib. The changelog of HLLib can be found here.
    I also compiled it with Visual Studio 2010. The compiler had the so called /MULTITHREADED-DLL compile-flag enabled. This means basically that every external code it uses (e.g. for reading from the HDD) is now dynamically loaded from the dlls of Visual Studio 2010 Restributables (That's why you need to install them). Before that change, the "external" code has been compiled into HLLib itself which made it bigger in size and basically more unsecure (because if there is a bug in the external code you needed a fixed HLLib. Now you only have to update the Restributables instead, which is done by Windows Update).

  16. Post #776
    Seems that Left 4 Dead 2's pak02_dir.vpk can't be mounted, not even seperately. I know 1 option and it is to extract from that file yourself. And looks like VTFEdit 1.3.1 is out with support for 7.5 VTFs!

    pak02_dir.vpk is for using L4D stuff, so it is pointless to mount it.
    That means...... extraction! WOHOO (Based on Luigi's "That means..... killtime! WOHOO" from Luigi and Hyrule Castle). At least that VPK has the sandbags if you don't have DoD: S or ssomething and Bill with textures included

  17. Post #777
    Gold Member
    flashn00b's Avatar
    August 2005
    4,142 Posts
    Are there any plans for Vampire: The Masquarade - Bloodlines content? That game uses Source.

  18. Post #778
    Gold Member
    Omolong's Avatar
    December 2007
    7,613 Posts
    pak02_dir.vpk is for using L4D stuff (like the maps or custom content) in L4D2, so it is pointless to mount it.
    Reply With Quote Edit / Delete Reply United Kingdom Show Events Agree Agree x 1 (list)

  19. Post #779
    fartboy's Avatar
    November 2008
    50 Posts
    HLLib is a required module which allows you loading L4D1/2 content (vpk-files).
    The latest update includes the very latest version of HLLib. The changelog of HLLib can be found here.
    I also compiled it with Visual Studio 2010. The compiler had the so called /MULTITHREADED-DLL compile-flag enabled. This means basically that every external code it uses (e.g. for reading from the HDD) is now dynamically loaded from the dlls of Visual Studio 2010 Restributables (That's why you need to install them). Before that change, the "external" code has been compiled into HLLib itself which made it bigger in size and basically more unsecure (because if there is a bug in the external code you needed a fixed HLLib. Now you only have to update the Restributables instead, which is done by Windows Update).
    I never had issues loading Left 4 Dead content in GMod before. Why do we need this now?
    Reply With Quote Edit / Delete Reply Canada Show Events Dumb Dumb x 1 (list)

  20. Post #780
    Gold Member
    flashn00b's Avatar
    August 2005
    4,142 Posts
    I am convinced that something is broken. I can't get it to run even on a clean install.

  21. Post #781
    Gold Member
    Omolong's Avatar
    December 2007
    7,613 Posts
    I never had issues loading Left 4 Dead content in GMod before. Why do we need this now?
    We already had it, it just aVoN has updated it to work better.

  22. Post #782
    fartboy's Avatar
    November 2008
    50 Posts
    We already had it, it just aVoN has updated it to work better.
    Oh, alright.

  23. Post #783
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    I never had issues loading Left 4 Dead content in GMod before. Why do we need this now?
    What? L4D1/2 was mountable in GMod using my addon only because of HLLib.
    All I did was updating HLLib which now requires some DLLs you anyway need on your PC for some programs. So go with the future, install the MSVC 2010 Restributables and enjoy.

    Edited:

    I am convinced that something is broken. I can't get it to run even on a clean install.
    Install the MSVC 2010 Restributables x86!

  24. Post #784
    Gold Member
    Omolong's Avatar
    December 2007
    7,613 Posts
    That means...... extraction! WOHOO (Based on Luigi's "That means..... killtime! WOHOO" from Luigi and Hyrule Castle). At least that VPK has the sandbags if you don't have DoD: S or ssomething and Bill with textures included
    It isn't standard with L4D2.


    And stop replying to posts that are posted after yours in posts you posted before them. You are less likely to get any points you post there across, as most people that have read your post originally won't read it again.

  25. Post #785
    thenecronlord's Avatar
    May 2009
    1,290 Posts
    hey im having trouble geting this to work whare do i put the files?

    i installed the setup and nothing works i reely need some help

    i relly need some help i cant get this addon to work ive installed the setup and re installed gm_mount twice it wount work

  26. Post #786
    thenecronlord's Avatar
    May 2009
    1,290 Posts
    i relly need some help i cant get this addon to work ive installed the setup and re installed gm_mount twice it wount work

  27. Post #787
    Gold Member
    Fussy!'s Avatar
    June 2007
    9,067 Posts
    Let me get this straight: I have two accounts, one with GMod and all the Half Life games etc etc, but not L4D1 and 2. I can't get the models even though I have it installed and own them?

  28. Post #788
    Better Than Jacknife
    Minimole's Avatar
    December 2009
    8,962 Posts
    I have a question if I mount l4d will it cause that wire frame cable glitch with mount like it did with the plain l4d model pack?

  29. Post #789
    Drainwater's Avatar
    April 2009
    779 Posts
    I went through (most) of the pages, so I'm very sorry if you've answered this. I went through everything you've said, I can mount almost all the games I have. It won't let me mount SiN: Emergence though, which I own and have installed. It just says it's unavailable. Again, I'm very sorry if there was a quick fix or something you've mentioned earlier in the thread, I tried to go through it all but I found myself basically skimming most of the pages.

  30. Post #790
    Gold Member
    psychocyclone85's Avatar
    February 2009
    2,415 Posts
    So, I download the SVN, use the setup application, think everything is fine, and I go into gmod... nothing... no games to mount, nothing. What must I do?

  31. Post #791
    Drainwater's Avatar
    April 2009
    779 Posts
    Did you do that?
    Reply With Quote Edit / Delete Reply United States Show Events Disagree Disagree x 1 (list)

  32. Post #792
    GLaDOSLikesCake's Avatar
    August 2010
    6 Posts
    Hmm, looks like an update changed the Menu type. Is there any way to get past this?

  33. Post #793
    Drainwater's Avatar
    April 2009
    779 Posts
    From about page 13 on it starts dealing with that update and what you have to do, but it basically boils down to re-downloading it, using the installer included with it, and going to that link I quoted from Avon a couple of posts ago and downloading and installing that. That got most of them working for me, except for Sin Episodes Emergence.

  34. Post #794
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    i relly need some help i cant get this addon to work ive installed the setup and re installed gm_mount twice it wount work
    Try both:

    [list][*]Install the MSVC Restributables x86 (google for it)[*]If this doesn't work, try it on a clean GMod[/list]
    Edited:

    Let me get this straight: I have two accounts, one with GMod and all the Half Life games etc etc, but not L4D1 and 2. I can't get the models even though I have it installed and own them?
    No. This does not and will never work with my addon. Either extract the gamecontent and create a GMod-Addon or buy the game on the account they are missing on.

    Edited:

    I have a question if I mount l4d will it cause that wire frame cable glitch with mount like it did with the plain l4d model pack?
    Why don't you simply mount it and fit it out yourself?

    Edited:

    I went through (most) of the pages, so I'm very sorry if you've answered this. I went through everything you've said, I can mount almost all the games I have. It won't let me mount SiN: Emergence though, which I own and have installed. It just says it's unavailable. Again, I'm very sorry if there was a quick fix or something you've mentioned earlier in the thread, I tried to go through it all but I found myself basically skimming most of the pages.
    Try it on a clean GMod and make sure that every game has been run at least one and make sure that you own the games (Does not work with cracked GMod or "hacked" Steam like PacSteam)

  35. Post #795
    morphhh's Avatar
    December 2007
    42 Posts
    I installed MSVC Redistributables, verified game cache, runned every game one time, cleaned GMod, I own the games and still they don't appear to mount on the Extensions tab.

  36. Post #796
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    Make sure, the following is true

    [list][*]You have installed Steam[*]You have bought GMod on account A (Pirated GMod is incompatible)[*]You own the games you want to mount on account A (no secondary-account support! Pirated games are incompatible)[*]You have installed the MSVC 2010 Restributables (x86)[*]Optional: You have ran Windows Update at least once after the installed and rebooted at least once when asked[*]Optional: You have made Steam redownload GMod again (clean GMod)[*]You have downloaded the latest mount2 version[*]You have ran the setup.exe of mount2[/list]
    Now you are able to go to GMod/Extensions/Mountable Content.

  37. Post #797
    Fuck You, Laren Faust
    Banshee FrieNd's Avatar
    July 2009
    2,433 Posts
    Still Very Very Awesome!, Probably should have made it a little bit clearer about the MSVC thing. Is Alien Swarm Possible btw?

  38. Post #798

    August 2010
    9 Posts
    Hi, I'm having a problem with L4D/L4D2 content only on srcds. On single player it's spawning everything properly. On my dedi it's not. I copied the left4dead and left4dead2 folders out of my steamapps/common/*game* and moved them to srcds/orangebox/ . When server is loading it says Ok for mounting both but when I go to spawn something, it simply doesn't appear.

    And btw, I love GMMount2 <3

  39. Post #799
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    Still Very Very Awesome!, Probably should have made it a little bit clearer about the MSVC thing. Is Alien Swarm Possible btw?
    yes, it is, but I suggest not using it. All you need to know how to make it use its in the changelog.txt and readme.txt

    Edited:

    Hi, I'm having a problem with L4D/L4D2 content only on srcds. On single player it's spawning everything properly. On my dedi it's not. I copied the left4dead and left4dead2 folders out of my steamapps/common/*game* and moved them to srcds/orangebox/ . When server is loading it says Ok for mounting both but when I go to spawn something, it simply doesn't appear.

    And btw, I love GMMount2 <3
    Enter path into the console and post a screenshot. Any console-errors when spawning stuff? Is MSVC 2010 x86 installed?

  40. Post #800

    August 2010
    9 Posts
    Enter path into the console and post a screenshot. Any console-errors when spawning stuff? Is MSVC 2010 x86 installed?
    Here is my con log: http://pastebin.com/1vPzxri7

    MSVC 2010 x86 is installed on my machine running WinXP Pro x64.

    No, no errors when spawning, is their an advanced log or debug log available to use?

    Might be related, not sure, but I have setup the server a few times now. First time was standard content, second time was all content (the standard way) and third time was all content using GMMount2.

    Now... when I was setting up for the third time (starting fresh each time) when I logged on before I setup gmmount2 I noticed that all my prop list and models show up in the Q menu even when the server didn't have them yet. So, I guess what I'm getting at is; is there a way to clear the cache or w/e for the server on the client side or any way to resynch the contents?