1. Post #1
    Gold Member
    Jallen's Avatar
    December 2007
    7,584 Posts
    First of all, my in progress site (all by hand, no pre-written code, just the occasional modified tutorial code used) is here: http://jallenbah.co.uk

    Now, first problem - ugly boxes in firefox when clicking link divs, doesn't happen in chrome.

    How can I stop this, or can't I?

    Now, problem 2, slashes in my emails.
    Here's the message I'm sending from http://jallenbah.co.uk/contact.php (please don't abuse this, I'm trusting you)
    Code:
    There's strange slashes in my message!
    
    "what is this i dont even"
    
    fffffffffffffffffffff
    ffffffffffffffffff
    fffffffffffffffffffffffff
    fffffffffffff
    Here's how it ends up in my email inbox - \ before every " or '
    Code:
    ///////////////////////////////////////////////////////
    //- Jallenbah.co.uk -\\
    ------------------------------------------------------
    From: James Allen - someemail@somewhere.lol
    Subject: Why are there stooopid slashes in my message :(
    ------------------------------------------------------
    There\'s strange slashes in my message!
    
    \"what is this i dont even\"
    
    fffffffffffffffffffff
    ffffffffffffffffff
    fffffffffffffffffffffffff
    fffffffffffff
    ///////////////////////////////////////////////////////
    Here's my mail code...
    Code:
    $name_field = $_POST['name'];
    $email_field = $_POST['email'];
    $subject_field = $_POST['subject'];
    $message_field = $_POST['message'];
    
    $to = "<my email>";
    $from = "From: Jallenbah.co.uk <my email>";
    $subject = "Jallenbah.co.uk || " . $name_field . " - " . $subject_field;
    $body = "///////////////////////////////////////////////////////
    //- Jallenbah.co.uk -\\\\
    ------------------------------------------------------
    From: $name_field - $email_field
    Subject: $subject_field
    ------------------------------------------------------
    $message_field
    ///////////////////////////////////////////////////////";
    		
    mail($to, $subject, $body, $from);
    All other feedback is of course welcome, and if there's a security flaw you notice, please inform me of that too!
    Thanks.

  2. Post #2
    Gold Member
    andersonmat's Avatar
    May 2008
    2,607 Posts
    It's php escaping inputs.
    Reply With Quote Edit / Delete Reply United States Show Events Agree Agree x 1 (list)

  3. Post #3
    Gold Member
    Jallen's Avatar
    December 2007
    7,584 Posts
    Ok, how do I stop it?

  4. Post #4
    Gold Member
    Torekk's Avatar
    November 2006
    2,798 Posts
    Second thing, just use this:

    Code:
    outline: none;
    Reply With Quote Edit / Delete Reply Germany Show Events Informative Informative x 1 (list)

  5. Post #5
    Gold Member
    deadeye536's Avatar
    February 2008
    1,550 Posts
    Ok, how do I stop it?
    It looks like PHP has Magic Quotes enabled. You can try disabling it by reading this article in PHP's documentation.

    If you want to leave that enabled for whatever reason, you can try using something like this,
    $message_field = stripslashes($_POST['message']);

  6. Post #6
    Unmetered VPS
    Fizzadar's Avatar
    June 2010
    1,247 Posts
    My PHP install is fucked. Even with magic_quotes (runtime & gpc) disabled, it still does it :/

  7. Post #7
    Gold Member
    Jallen's Avatar
    December 2007
    7,584 Posts
    Second thing, just use this:

    Code:
    outline: none;
    This worked great, thanks.

    Edited:

    My PHP install is fucked. Even with magic_quotes (runtime & gpc) disabled, it still does it :/
    I solved the problem by doing

    Code:
    $message_field = stripslashes($message_field);
    It keeps slashes but makes \" turn to " etc. Basically fixes the problem.

  8. Post #8
    I spent $10 on this.
    :awesome:'s Avatar
    April 2009
    5,468 Posts
    sorry but your website looks pretty bad. The color scheme isn't that nice and the whole lines thing looks weird.

  9. Post #9
    Gold Member
    Jallen's Avatar
    December 2007
    7,584 Posts
    sorry but your website looks pretty bad. The color scheme isn't that nice and the whole lines thing looks weird.
    I disagree, I like the style, especially the colours.

    If you are viewing it in internet explorer then it will look like shit btw.

    Also, your website has a 742KB background ripped from some guys deviantart page. Uh...

  10. Post #10
    I spent $10 on this.
    :awesome:'s Avatar
    April 2009
    5,468 Posts
    Actually I was viewing it on chrome for mac

  11. Post #11
    Gold Member
    itsbth's Avatar
    March 2006
    214 Posts
    if (get_magic_quotes_gpc())
      foreach($_POST as $k => $v)
        $_POST[$k] = stripslashes($v);
    
    This is what I used back when I was still using PHP. Repeat for $_GET if necessary.

  12. Post #12
    turb__'s Avatar
    June 2010
    215 Posts
    Also, your website has a 742KB background ripped from some guys deviantart page. Uh...
    It's 2010, get over it. Large backgrounds are sexy.

    vladh.net
    envato.com
    anyhub.net
    charliesomerville.com

  13. Post #13
    Gold Member
    Jallen's Avatar
    December 2007
    7,584 Posts
    Guys, when I try to go here (bluehost thread): http://www.facepunch.com/showthread.php?t=951526

    I get this:


    Anyone else getting something similar?...

  14. Post #14
    Gold Member
    andersonmat's Avatar
    May 2008
    2,607 Posts
    Guys, when I try to go here (bluehost thread): http://www.facepunch.com/showthread.php?t=951526


    Anyone else getting something similar?...
    Probably because he posted the source code that was in his files.
    Reply With Quote Edit / Delete Reply United States Show Events Agree Agree x 1 (list)

  15. Post #15
    turb__'s Avatar
    June 2010
    215 Posts
    Anyone else getting something similar?...
    AVG sucks, MSE ftw

  16. Post #16
    Gold Member
    andersonmat's Avatar
    May 2008
    2,607 Posts
    I disagree, I like the style, especially the colours.
    You do. I don't.

  17. Post #17
    Gold Member
    jaybuz's Avatar
    May 2006
    5,516 Posts
    sorry but your website looks pretty bad. The color scheme isn't that nice and the whole lines thing looks weird.
    It's not the best website ever but it's definitely not the worst.

  18. Post #18
    I spent $10 on this.
    :awesome:'s Avatar
    April 2009
    5,468 Posts
    It's not the best website ever but it's definitely not the worst.
    thats true.

  19. Post #19
    Gold Member
    Jallen's Avatar
    December 2007
    7,584 Posts
    http://jallenbah.co.uk/

    Built it up a little, changed the title + bg since it looked a little boxy and simple.

    Thoughts?

    Wait shit broke it
    Ok fixed

    Who did this >:O
    Code:
    ///////////////////////////////////////////////////////
    //- Jallenbah.co.uk -\\
    ------------------------------------------------------
    From: a - a
    Subject: a
    ------------------------------------------------------
    a
    ///////////////////////////////////////////////////////

  20. Post #20
    Gold Member
    arienh4's Avatar
    August 2007
    2,403 Posts
    I would suggest making the lines a lot less opaque, and the red and yellow a little less clashing with your background. That should make it a lot better.

  21. Post #21
    sseug's Avatar
    June 2010
    174 Posts
    It's 2010, get over it. Large backgrounds are sexy.

    vladh.net
    envato.com
    anyhub.net
    charliesomerville.com
    Thanks, but Jallen is still right because :awesome: uh...well...sucks, I guess. I can't really think of anything more relevant to say about him.

  22. Post #22
    Gold Member
    deadeye536's Avatar
    February 2008
    1,550 Posts
    You might also want to increase the z-index of the No Javascript message. Unless the effect now is the desired effect.

  23. Post #23
    Gold Member
    Jallen's Avatar
    December 2007
    7,584 Posts
    You might also want to increase the z-index of the No Javascript message. Unless the effect now is the desired effect.
    Oh snap, completely didn't realise that. That's due to my relative placing of my new title I guess.

    Thanks, I'll add that to my mental todo list.